aboutsummaryrefslogtreecommitdiff
path: root/games/libggz
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-13 19:18:49 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-13 19:18:49 +0000
commit990c35956a34d01d4613bfff2b74ff1943f33ed6 (patch)
treeb897898756b0e7fe3beb190117c3aa8e15786554 /games/libggz
parent65d29cbbf0c3ece65b0c299cd1db18adea7adce5 (diff)
downloadports-990c35956a34d01d4613bfff2b74ff1943f33ed6.tar.gz
ports-990c35956a34d01d4613bfff2b74ff1943f33ed6.zip
- Update to 0.0.12
PR: ports/87384 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=145302
Diffstat (limited to 'games/libggz')
-rw-r--r--games/libggz/Makefile5
-rw-r--r--games/libggz/distinfo4
-rw-r--r--games/libggz/files/patch-configure10
-rw-r--r--games/libggz/files/patch-src-easysock.c12
4 files changed, 27 insertions, 4 deletions
diff --git a/games/libggz/Makefile b/games/libggz/Makefile
index d9197bf450af..511a3aeebbae 100644
--- a/games/libggz/Makefile
+++ b/games/libggz/Makefile
@@ -7,9 +7,10 @@
#
PORTNAME= libggz
-PORTVERSION= 0.0.11
+PORTVERSION= 0.0.12
CATEGORIES= games
-MASTER_SITES= http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
+MASTER_SITES= http://mirrors.dotsrc.org/ggzgamingzone/ggz/%SUBDIR%/ \
+ http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
diff --git a/games/libggz/distinfo b/games/libggz/distinfo
index 17d65370ee41..24badf2d4b19 100644
--- a/games/libggz/distinfo
+++ b/games/libggz/distinfo
@@ -1,2 +1,2 @@
-MD5 (libggz-0.0.11.tar.gz) = 6a3cac71b3b444c7b46dc27d166402e4
-SIZE (libggz-0.0.11.tar.gz) = 489049
+MD5 (libggz-0.0.12.tar.gz) = cd64702de6b9bea3cec8ed6364c23429
+SIZE (libggz-0.0.12.tar.gz) = 433830
diff --git a/games/libggz/files/patch-configure b/games/libggz/files/patch-configure
new file mode 100644
index 000000000000..c8fef95280d2
--- /dev/null
+++ b/games/libggz/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.bak Mon Sep 26 03:48:50 2005
++++ configure Fri Oct 7 13:01:38 2005
+@@ -20243,6 +20243,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <sys/types.h>
+ #include <sys/socket.h>
+ int
+ main ()
diff --git a/games/libggz/files/patch-src-easysock.c b/games/libggz/files/patch-src-easysock.c
new file mode 100644
index 000000000000..c6fe96017ae3
--- /dev/null
+++ b/games/libggz/files/patch-src-easysock.c
@@ -0,0 +1,12 @@
+--- src/easysock.c.orig Mon Sep 19 01:28:42 2005
++++ src/easysock.c Fri Oct 7 12:45:11 2005
+@@ -49,8 +49,8 @@
+ #include <sys/uio.h>
+ #include <sys/un.h>
+ #include <sys/param.h>
+-#include <arpa/inet.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <netdb.h>
+
+ #ifdef HAVE_WINSOCK2_H