aboutsummaryrefslogtreecommitdiff
path: root/games/libggz
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-09 01:33:12 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-09 01:33:12 +0000
commitec12e9166c520d50c990cfb7772c8a424cb5e132 (patch)
treed67711000b67c8c1ef264beb9d7337420c5bd426 /games/libggz
parent226ec8626da2e7b0e35644a0a63bb6233d9633f0 (diff)
downloadports-ec12e9166c520d50c990cfb7772c8a424cb5e132.tar.gz
ports-ec12e9166c520d50c990cfb7772c8a424cb5e132.zip
add libggz 0.0.7
The GGZ Gaming Zone - Base Library
Notes
Notes: svn path=/head/; revision=90672
Diffstat (limited to 'games/libggz')
-rw-r--r--games/libggz/Makefile30
-rw-r--r--games/libggz/distinfo1
-rw-r--r--games/libggz/files/patch-ltmain.sh15
-rw-r--r--games/libggz/pkg-descr4
-rw-r--r--games/libggz/pkg-plist5
5 files changed, 55 insertions, 0 deletions
diff --git a/games/libggz/Makefile b/games/libggz/Makefile
new file mode 100644
index 000000000000..c15701d3bc81
--- /dev/null
+++ b/games/libggz/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: libggz
+# Date created: Oct 8, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libggz
+PORTVERSION= 0.0.7
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ggz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The GGZ Gaming Zone - Base Library
+
+LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt
+
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ARGS= --disable-debug --with-gcrypt --with-tls
+
+INSTALLS_SHLIB= yes
+
+MAN3= ggz.h.3
+
+.include <bsd.port.mk>
diff --git a/games/libggz/distinfo b/games/libggz/distinfo
new file mode 100644
index 000000000000..ef0836b34cb0
--- /dev/null
+++ b/games/libggz/distinfo
@@ -0,0 +1 @@
+MD5 (libggz-0.0.7.tar.gz) = b7d963897b991762d63589647d757c6b
diff --git a/games/libggz/files/patch-ltmain.sh b/games/libggz/files/patch-ltmain.sh
new file mode 100644
index 000000000000..7436b6c83012
--- /dev/null
+++ b/games/libggz/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Wed Oct 8 22:11:50 2003
++++ ltmain.sh Wed Oct 8 22:12:05 2003
+@@ -4325,10 +4325,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/games/libggz/pkg-descr b/games/libggz/pkg-descr
new file mode 100644
index 000000000000..db73649aee56
--- /dev/null
+++ b/games/libggz/pkg-descr
@@ -0,0 +1,4 @@
+This is the GGZ base library libggz, used by the GGZ Gaming Zone server
+(ggzd), the ggzcore library and other components.
+
+WWW: http://www.ggzgamingzone.org/
diff --git a/games/libggz/pkg-plist b/games/libggz/pkg-plist
new file mode 100644
index 000000000000..d3fed864d901
--- /dev/null
+++ b/games/libggz/pkg-plist
@@ -0,0 +1,5 @@
+include/ggz.h
+include/ggz_common.h
+lib/libggz.a
+lib/libggz.so
+lib/libggz.so.1