aboutsummaryrefslogtreecommitdiff
path: root/games/linux-defcon
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-04 21:41:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-04 21:41:41 +0000
commit4ee6863913010e61cf9e2592f6efba8ae982a6f9 (patch)
tree615537e0b9cffa2ac045bf0b3ef8c322a549b6f3 /games/linux-defcon
parent0a023788feadc235240592ac733f889fc7460158 (diff)
downloadports-4ee6863913010e61cf9e2592f6efba8ae982a6f9.tar.gz
ports-4ee6863913010e61cf9e2592f6efba8ae982a6f9.zip
Defcon is announced as "The World's first Genocide 'em up". It is a
global thermonuclear war simulation inspired by movies like WarGames and features multiplayer support, different game modes and support for own game mods. WWW: http://www.introversion.co.uk/defcon/ PR: ports/112939 Submitted by: Marcus von Appen <mva at sysfault.org
Notes
Notes: svn path=/head/; revision=192767
Diffstat (limited to 'games/linux-defcon')
-rw-r--r--games/linux-defcon/Makefile60
-rw-r--r--games/linux-defcon/distinfo3
-rw-r--r--games/linux-defcon/files/defcon.in4
-rw-r--r--games/linux-defcon/pkg-descr6
-rw-r--r--games/linux-defcon/pkg-message14
-rw-r--r--games/linux-defcon/pkg-plist9
6 files changed, 96 insertions, 0 deletions
diff --git a/games/linux-defcon/Makefile b/games/linux-defcon/Makefile
new file mode 100644
index 000000000000..78d9edf47192
--- /dev/null
+++ b/games/linux-defcon/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: linux-defcon
+# Date created: 24 May 2007
+# Whom: Marcus von Appen <mva@sysfault.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= defcon
+PORTVERSION= 1.42
+CATEGORIES= games linux
+MASTER_SITES= http://download.introversion.co.uk/defcon/linux/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= mva@sysfault.org
+COMMENT= Defcon for Linux
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libogg.so.0:${PORTSDIR}/audio/linux-libogg \
+ ${LINUXBASE}/usr/lib/libvorbisfile.so.3:${PORTSDIR}/audio/linux-libvorbis
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_XLIB= yes
+NO_CDROM= Redistribution is limited, see license
+NO_BUILD= yes
+
+DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
+SUB_FILES= defcon
+
+OPTIONS= NVIDIA "Install support for nvidia" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NVIDIA)
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
+ ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+.endif
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/lib/defcon.bin.x86
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}/lib && \
+ ${INSTALL_PROGRAM} defcon.bin.x86 ${DATADIR} && \
+ ${INSTALL_DATA} *.dat open-www.sh ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKDIR}/defcon ${PREFIX}/bin/${PKGNAMEPREFIX}defcon
+.if !defined (NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/license.txt ${DOCSDIR}/license.txt
+ ${INSTALL_DATA} ${WRKSRC}/manual.pdf ${DOCSDIR}/manual.pdf
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-defcon/distinfo b/games/linux-defcon/distinfo
new file mode 100644
index 000000000000..0dead9b612ca
--- /dev/null
+++ b/games/linux-defcon/distinfo
@@ -0,0 +1,3 @@
+MD5 (defcon-v1.42.tar.gz) = df7ee425ebfa88615efc26508564feca
+SHA256 (defcon-v1.42.tar.gz) = 5973c32ef55d245b9adfbce33bb7c503d3f0ad7bf5deb55eba8754f9850cdf40
+SIZE (defcon-v1.42.tar.gz) = 63093946
diff --git a/games/linux-defcon/files/defcon.in b/games/linux-defcon/files/defcon.in
new file mode 100644
index 000000000000..883f7c52d04b
--- /dev/null
+++ b/games/linux-defcon/files/defcon.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%DATADIR%% || exit 1
+exec ./defcon.bin.x86 "$@"
diff --git a/games/linux-defcon/pkg-descr b/games/linux-defcon/pkg-descr
new file mode 100644
index 000000000000..c23a8f1af3c8
--- /dev/null
+++ b/games/linux-defcon/pkg-descr
@@ -0,0 +1,6 @@
+Defcon is announced as "The World's first Genocide 'em up". It is a
+global thermonuclear war simulation inspired by movies like WarGames
+and features multiplayer support, different game modes and support for
+own game mods.
+
+WWW: http://www.introversion.co.uk/defcon/
diff --git a/games/linux-defcon/pkg-message b/games/linux-defcon/pkg-message
new file mode 100644
index 000000000000..e282f248e3f7
--- /dev/null
+++ b/games/linux-defcon/pkg-message
@@ -0,0 +1,14 @@
+======================================================================
+This game will attempt to obtain some system information by
+accessing files in linux's procfs. You must install the Linux
+emulation procfs filesystem for this to work correctly. This can be
+accomplished by adding the following line to your /etc/fstab file:
+
+ linprocfs /compat/linux/proc linprocfs rw 0 0
+
+and then, as root, executing the commands:
+
+kldload linprocfs
+mount /compat/linux/proc
+
+======================================================================
diff --git a/games/linux-defcon/pkg-plist b/games/linux-defcon/pkg-plist
new file mode 100644
index 000000000000..afb52698e398
--- /dev/null
+++ b/games/linux-defcon/pkg-plist
@@ -0,0 +1,9 @@
+bin/linux-defcon
+%%DATADIR%%/defcon.bin.x86
+%%DATADIR%%/main.dat
+%%DATADIR%%/sounds.dat
+%%DATADIR%%/open-www.sh
+%%PORTDOCS%%%%DOCSDIR%%/license.txt
+%%PORTDOCS%%%%DOCSDIR%%/manual.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%