aboutsummaryrefslogtreecommitdiff
path: root/games/linux-enemyterritory-omni-bot
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-05-11 19:06:40 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-05-11 19:06:40 +0000
commitfd9276a0a76c383a9a09cf6cf081fcc4c435d1ca (patch)
tree21c7dc84e7b89d12ba536c2da4dd9cd5d14810a4 /games/linux-enemyterritory-omni-bot
parent09b015d99e84494079cee73327201665fd1b5cd7 (diff)
downloadports-fd9276a0a76c383a9a09cf6cf081fcc4c435d1ca.tar.gz
ports-fd9276a0a76c383a9a09cf6cf081fcc4c435d1ca.zip
Omni-Bot is an Enemy Territory modification providing computer controlled
players (bots). WWW: http://www.omni-bot.de/ PR: ports/93564 Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=162128
Diffstat (limited to 'games/linux-enemyterritory-omni-bot')
-rw-r--r--games/linux-enemyterritory-omni-bot/Makefile73
-rw-r--r--games/linux-enemyterritory-omni-bot/distinfo3
-rw-r--r--games/linux-enemyterritory-omni-bot/pkg-descr4
-rw-r--r--games/linux-enemyterritory-omni-bot/pkg-plist49
4 files changed, 129 insertions, 0 deletions
diff --git a/games/linux-enemyterritory-omni-bot/Makefile b/games/linux-enemyterritory-omni-bot/Makefile
new file mode 100644
index 000000000000..7eb8691ec765
--- /dev/null
+++ b/games/linux-enemyterritory-omni-bot/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: omni-bot
+# Date created: 7 May 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= omni-bot
+PORTVERSION= 0.51
+CATEGORIES= games linux
+MASTER_SITES= #
+PKGNAMEPREFIX= linux-enemyterritory-
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Omni-Bot is a bot for Enemy Territory
+
+RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_ZIP= yes
+USE_LINUX= yes
+NO_WRKSUBDIR= yes
+
+OPTIONS= ETPUB "Enable ETPub support" off
+
+DATADIR= ${PREFIX}/lib/enemyterritory
+DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ETPUB)
+RUN_DEPENDS+= et-etpub:${PORTSDIR}/games/linux-enemyterritory-etpub
+PLIST_SUB+= ETPUB=""
+.else
+PLIST_SUB+= ETPUB="@comment "
+.endif
+
+pre-fetch:
+ @cd ${DISTDIR} && ${FETCH_CMD:S/-A/-/} -o \
+ ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
+ 'http://www.omni-bot.de/e107/request.php?175'
+
+do-build:
+.for f in et etded
+ @(${ECHO} "#!/bin/sh"; \
+ ${ECHO} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} "$$@"') > \
+ ${WRKSRC}/${f}-${PORTNAME}
+.endfor
+
+do-install:
+.for f in et etded
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${DATADIR}/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/omni-bot/omnibot_et.so ${DATADIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/omni-bot/et ${DATADIR}/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/omnibot/qagame.mp.i386.so ${DATADIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/omnibot/omnibot_et.pk3 ${DATADIR}/${PORTNAME}
+.if defined(WITH_ETPUB)
+ cd ${DATADIR}/etpub && ${MV} qagame.mp.i386.so qagame.mp.i386.so.old
+ ${INSTALL_PROGRAM} ${WRKSRC}/etpub/qagame.mp.i386.so ${DATADIR}/etpub
+ ${INSTALL_DATA} ${WRKSRC}/etpub/omnibot_etpub.pk3 ${DATADIR}/etpub
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in *.txt omni-bot/*.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+ ${CP} -R ${WRKSRC}/omni-bot/docs ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-enemyterritory-omni-bot/distinfo b/games/linux-enemyterritory-omni-bot/distinfo
new file mode 100644
index 000000000000..03be46e95f2c
--- /dev/null
+++ b/games/linux-enemyterritory-omni-bot/distinfo
@@ -0,0 +1,3 @@
+MD5 (omni-bot-0.51.zip) = 9fd811ed543ae86b25e71d64ecef127c
+SHA256 (omni-bot-0.51.zip) = 22b323205e5d4225410098031e8eb43681e7aeaabd70dcafb750701e4e84cdc6
+SIZE (omni-bot-0.51.zip) = 5028339
diff --git a/games/linux-enemyterritory-omni-bot/pkg-descr b/games/linux-enemyterritory-omni-bot/pkg-descr
new file mode 100644
index 000000000000..0daa2b585e8c
--- /dev/null
+++ b/games/linux-enemyterritory-omni-bot/pkg-descr
@@ -0,0 +1,4 @@
+Omni-Bot is an Enemy Territory modification providing computer controlled
+players (bots).
+
+WWW: http://www.omni-bot.de/
diff --git a/games/linux-enemyterritory-omni-bot/pkg-plist b/games/linux-enemyterritory-omni-bot/pkg-plist
new file mode 100644
index 000000000000..19a17d97b09d
--- /dev/null
+++ b/games/linux-enemyterritory-omni-bot/pkg-plist
@@ -0,0 +1,49 @@
+bin/et-omni-bot
+bin/etded-omni-bot
+%%ETPUB%%@exec cd %D/%%DATADIR%%/etpub && mv qagame.mp.i386.so qagame.mp.i386.so.old
+%%ETPUB%%%%DATADIR%%/etpub/qagame.mp.i386.so
+%%ETPUB%%@unexec cd %D/%%DATADIR%%/etpub && mv qagame.mp.i386.so.old qagame.mp.i386.so
+%%ETPUB%%%%DATADIR%%/etpub/omnibot_etpub.pk3
+%%DATADIR%%/omni-bot/et/nav/et_custom_wps.zip
+%%DATADIR%%/omni-bot/et/nav/et_official_wps.zip
+%%DATADIR%%/omni-bot/et/scripts/def_bot.gm
+%%DATADIR%%/omni-bot/et/scripts/et_autoexec.gm
+%%DATADIR%%/omni-bot/et/scripts/sample.gm
+%%DATADIR%%/omni-bot/omnibot_et.pk3
+%%DATADIR%%/omni-bot/omnibot_et.so
+%%DATADIR%%/omni-bot/qagame.mp.i386.so
+%%PORTDOCS%%%%DOCSDIR%%/credits.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/english/Basic scripting Guide-Dateien/logo.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/english/Basic scripting Guide.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/english/Omni-bot Commands and Basic Usage-Dateien/logo.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/english/Omni-bot Commands and Basic Usage.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/english/Waypointing Tutorial-Dateien/logo.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/english/Waypointing Tutorial-Dateien/wp_1waylink.jpg
+%%PORTDOCS%%%%DOCSDIR%%/docs/english/Waypointing Tutorial-Dateien/wp_2waylinks.jpg
+%%PORTDOCS%%%%DOCSDIR%%/docs/english/Waypointing Tutorial-Dateien/wp_basic.jpg
+%%PORTDOCS%%%%DOCSDIR%%/docs/english/Waypointing Tutorial.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/german/Omni-bot Kommandos und grundlegende Funktionen-Dateien/logo.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/german/Omni-bot Kommandos und grundlegende Funktionen.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/german/Wegpunkte Tutorial-Dateien/logo.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/german/Wegpunkte Tutorial-Dateien/wp_1waylink.jpg
+%%PORTDOCS%%%%DOCSDIR%%/docs/german/Wegpunkte Tutorial-Dateien/wp_2waylinks.jpg
+%%PORTDOCS%%%%DOCSDIR%%/docs/german/Wegpunkte Tutorial-Dateien/wp_basic.jpg
+%%PORTDOCS%%%%DOCSDIR%%/docs/german/Wegpunkte Tutorial.html
+%%PORTDOCS%%%%DOCSDIR%%/docs_changelog.txt
+%%PORTDOCS%%%%DOCSDIR%%/et_changelog.txt
+%%PORTDOCS%%%%DOCSDIR%%/etpub_changelog.txt
+%%PORTDOCS%%%%DOCSDIR%%/install.de.txt
+%%PORTDOCS%%%%DOCSDIR%%/install.en.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/german/Wegpunkte Tutorial-Dateien
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/german/Omni-bot Kommandos und grundlegende Funktionen-Dateien
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/german
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/english/Waypointing Tutorial-Dateien
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/english/Omni-bot Commands and Basic Usage-Dateien
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/english/Basic scripting Guide-Dateien
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/english
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/omni-bot/et/scripts
+@dirrm %%DATADIR%%/omni-bot/et/nav
+@dirrm %%DATADIR%%/omni-bot/et
+@dirrm %%DATADIR%%/omni-bot