aboutsummaryrefslogtreecommitdiff
path: root/games/linux-majesty-demo
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-02-06 23:20:36 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-02-06 23:20:36 +0000
commitc5a6f7c7cdeb5ab8b7845ca3324f7440f5083564 (patch)
tree8706c7ced40a101369cbc7ae1d8d7c4ec29c2046 /games/linux-majesty-demo
parentc9ee1b078d1a24c37277a2461001ab58e29c2eff (diff)
downloadports-c5a6f7c7cdeb5ab8b7845ca3324f7440f5083564.tar.gz
ports-c5a6f7c7cdeb5ab8b7845ca3324f7440f5083564.zip
Majesty is a unique real-time strategy and fantasy simulation, where you
have to create and control your own kingdom, control your people with rewards and spells and try to solve the epic quest before you. WWW: http://www.linuxgamepublishing.com/info.php?id=8 PR: ports/131187 Submitted by: Marcus von Appen <mva at sysfault.org>
Notes
Notes: svn path=/head/; revision=227738
Diffstat (limited to 'games/linux-majesty-demo')
-rw-r--r--games/linux-majesty-demo/Makefile59
-rw-r--r--games/linux-majesty-demo/distinfo3
-rw-r--r--games/linux-majesty-demo/files/majesty.in4
-rw-r--r--games/linux-majesty-demo/pkg-descr5
-rw-r--r--games/linux-majesty-demo/pkg-plist29
5 files changed, 100 insertions, 0 deletions
diff --git a/games/linux-majesty-demo/Makefile b/games/linux-majesty-demo/Makefile
new file mode 100644
index 000000000000..14cb73320d00
--- /dev/null
+++ b/games/linux-majesty-demo/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: linux-majesty-demo
+# Date created: 2009-01-30
+# Whom: Marcus von Appen <mva@sysfault.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= majesty-demo
+PORTVERSION= 1.0.0
+CATEGORIES= games linux
+MASTER_SITES= http://demofiles.linuxgamepublishing.com/majesty/
+PKGNAMEPREFIX= linux-
+DISTNAME= majesty_demo
+EXTRACT_SUFX= .run
+
+MAINTAINER= mva@sysfault.org
+COMMENT= Majesty Gold Demo
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg \
+ ${LINUXBASE}/usr/lib/libSDL_mixer-1.2.so.0:${PORTSDIR}/audio/linux-sdl_mixer \
+ ${LINUXBASE}/usr/lib/libmikmod.so.2:${PORTSDIR}/audio/linux-mikmod \
+ ${LINUXBASE}/usr/lib/libogg.so.0:${PORTSDIR}/audio/linux-libogg \
+ ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= yes
+USE_XLIB= yes
+NO_CDROM= Redistribution is limited, see license
+NO_BUILD= yes
+
+DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
+SUB_FILES= majesty
+PORTDOCS= README README.licenses EULA
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && ${TAIL} +377 ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAR} jxf -
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/maj_demo
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/maj_demo.dynamic
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}/bin/Linux/x86 && \
+ ${INSTALL_PROGRAM} maj_demo maj_demo.dynamic ${DATADIR}
+ @${INSTALL_PROGRAM} ${WRKDIR}/majesty ${PREFIX}/bin/${PKGNAMEPREFIX}majesty
+ @${CP} -R ${WRKSRC}/quests ${DATADIR}
+ @${CP} -R ${WRKSRC}/data ${DATADIR}
+.if !defined (NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-majesty-demo/distinfo b/games/linux-majesty-demo/distinfo
new file mode 100644
index 000000000000..7c43ed2d30ce
--- /dev/null
+++ b/games/linux-majesty-demo/distinfo
@@ -0,0 +1,3 @@
+MD5 (majesty_demo.run) = d10e3c3c49634d847250234b1af72180
+SHA256 (majesty_demo.run) = 453b2bfa0a2473810945c717563cc459fc2b2cdd713155272872b1d8ef695de9
+SIZE (majesty_demo.run) = 36582366
diff --git a/games/linux-majesty-demo/files/majesty.in b/games/linux-majesty-demo/files/majesty.in
new file mode 100644
index 000000000000..1cf7369a2eee
--- /dev/null
+++ b/games/linux-majesty-demo/files/majesty.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%DATADIR%% || exit 1
+exec ./maj_demo "$@"
diff --git a/games/linux-majesty-demo/pkg-descr b/games/linux-majesty-demo/pkg-descr
new file mode 100644
index 000000000000..7f80e9dccc7a
--- /dev/null
+++ b/games/linux-majesty-demo/pkg-descr
@@ -0,0 +1,5 @@
+Majesty is a unique real-time strategy and fantasy simulation, where you
+have to create and control your own kingdom, control your people with
+rewards and spells and try to solve the epic quest before you.
+
+WWW: http://www.linuxgamepublishing.com/info.php?id=8
diff --git a/games/linux-majesty-demo/pkg-plist b/games/linux-majesty-demo/pkg-plist
new file mode 100644
index 000000000000..7a14d1b13455
--- /dev/null
+++ b/games/linux-majesty-demo/pkg-plist
@@ -0,0 +1,29 @@
+bin/linux-majesty
+%%DATADIR%%/maj_demo
+%%DATADIR%%/maj_demo.dynamic
+%%DATADIR%%/data/action.cam
+%%DATADIR%%/data/bytecode.bcd
+%%DATADIR%%/data/cinedata1.cam
+%%DATADIR%%/data/company.cam
+%%DATADIR%%/data/constants.rgs
+%%DATADIR%%/data/gpltext.cam
+%%DATADIR%%/data/interfacedata.cam
+%%DATADIR%%/data/maindata.cam
+%%DATADIR%%/data/miscdata.cam
+%%DATADIR%%/data/promo01.bmp
+%%DATADIR%%/data/promo02.bmp
+%%DATADIR%%/data/promo03.bmp
+%%DATADIR%%/data/promo04.bmp
+%%DATADIR%%/data/sounddesc.cam
+%%DATADIR%%/data/soundfx.cam
+%%DATADIR%%/data/terrtype.cam
+%%DATADIR%%/data/textdata.cam
+%%DATADIR%%/data/tilesetdata.cam
+%%DATADIR%%/data/titlepage.bmp
+%%DATADIR%%/data/unittype.cam
+%%DATADIR%%/data/voices.cam
+%%DATADIR%%/quests/vampiric_revenge.q
+%%DATADIR%%/quests/vampiric_revenge.qdd
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/quests
+@dirrm %%DATADIR%%