aboutsummaryrefslogtreecommitdiff
path: root/games/linux-warsow
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-23 02:50:30 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-23 02:50:30 +0000
commit896219d57fa799b70053fbf288abc552fca419a9 (patch)
tree2686506b4a9679b9d2afb1baf0659c7d33e40655 /games/linux-warsow
parent51207c444f1f315f563e028efbe1af82d632cf25 (diff)
downloadports-896219d57fa799b70053fbf288abc552fca419a9.tar.gz
ports-896219d57fa799b70053fbf288abc552fca419a9.zip
Add linux-warsow.
Warsow is a full free multiplayer first person shooter with cartoon design, using qfusion (a cool improvement to the Quake 2 engine). Highlights: - Besides classical trix coming from Quake scene, like Circle Jump, Strafe Jump, Double Jump, Bunny Hopping, etc., Warsow features its own Special Moves - Special moves of Warsow are Wall jumps, Dashes, Dodges, Ramp slides. All of them can be performed with a single key (spacebar by default) - All this brings huge depth of interactivity in 3D environment, really skilled gameplay, endless learning curves - Client and dedicated server - Load Quake 3 maps - Add bots - And more WWW: http://www.warsow.net/ PR: ports/88903 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Notes
Notes: svn path=/head/; revision=149140
Diffstat (limited to 'games/linux-warsow')
-rw-r--r--games/linux-warsow/Makefile88
-rw-r--r--games/linux-warsow/distinfo3
-rw-r--r--games/linux-warsow/files/warsow-wrapper.in4
-rw-r--r--games/linux-warsow/files/wsw_server-wrapper.in4
-rw-r--r--games/linux-warsow/pkg-deinstall16
-rw-r--r--games/linux-warsow/pkg-descr16
-rw-r--r--games/linux-warsow/pkg-install11
7 files changed, 142 insertions, 0 deletions
diff --git a/games/linux-warsow/Makefile b/games/linux-warsow/Makefile
new file mode 100644
index 000000000000..e580c51c45c9
--- /dev/null
+++ b/games/linux-warsow/Makefile
@@ -0,0 +1,88 @@
+# New ports collection makefile for: warsow
+# Date created: 2005-11-12
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= warsow
+PORTVERSION= 0.072a
+CATEGORIES= games linux
+MASTER_SITES= http://mirrors-av.club-internet.fr/pub/games/nofrag/warsow/ \
+ http://www.kpforum.net/games/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}_0.072alpha_linux
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free multiplayer first person shooter with cartoon design
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_LINUX= yes
+NO_BUILD= yes
+RESTRICTED= "Redistribution is limited, art is copyrighted"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+WARSOWDIR= ${PREFIX}/lib/${PORTNAME}
+WARSOWDIR_REL= ${WARSOWDIR:S,^${PREFIX}/,,}
+
+SUB_FILES= warsow-wrapper wsw_server-wrapper
+
+PLIST= ${WRKDIR}/pkg-plist
+PLIST_FILES= bin/warsow bin/wsw_server \
+ ${WARSOWDIR_REL}/warsow ${WARSOWDIR_REL}/wsw_server
+PORTDOCS= *
+
+DESKTOP_ENTRIES="Warsow" \
+ "Shoot cartoon enemies" \
+ "" \
+ "warsow" \
+ "Application;Game;" \
+ false
+
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
+.if defined(WITH_NVIDIA_GL)
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+.endif
+.else
+RUN_DEPENDS+= ${LINUXBASE}/lib/libGL.so.1:${PORTSDIR}/graphics/linux_glx
+.endif
+
+post-patch:
+ @${FIND} ${WRKSRC}/basewsw -type d -empty -exec ${TOUCH} "{}/.keep_me" \;
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @cd ${WRKSRC}/basewsw && \
+ ${FIND} * -type f | ${SORT} \
+ | ${SED} -e 's|^|${WARSOWDIR_REL}/basewsw/|' >> ${PLIST} && \
+ ${FIND} * -type d | ${SORT} -r \
+ | ${SED} -e 's|^|@dirrm ${WARSOWDIR_REL}/basewsw/|' >> ${PLIST}
+
+do-install:
+ cd ${WRKSRC}/basewsw && \
+ ${FIND} * -type d -exec ${MKDIR} "${WARSOWDIR}/basewsw/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${WARSOWDIR}/basewsw/{}" \;
+.for f in warsow wsw_server
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${WARSOWDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${f}-wrapper ${PREFIX}/bin/${f}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in Shader* bots_navigation.txt changelog.txt contact.txt demoavi.txt \
+ entities.def linux_sound_sdl.txt quick* server_admin.txt
+ ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
+. endfor
+.endif
+
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-warsow/distinfo b/games/linux-warsow/distinfo
new file mode 100644
index 000000000000..6f8bf6d064ec
--- /dev/null
+++ b/games/linux-warsow/distinfo
@@ -0,0 +1,3 @@
+MD5 (warsow_0.072alpha_linux.tar.gz) = bde7e468b0264d62f5cf987f4e143c0a
+SHA256 (warsow_0.072alpha_linux.tar.gz) = c8c33349e8eb19fde2d38dde2e760162151e2e3d05a676a757cb7677fc221e11
+SIZE (warsow_0.072alpha_linux.tar.gz) = 31990632
diff --git a/games/linux-warsow/files/warsow-wrapper.in b/games/linux-warsow/files/warsow-wrapper.in
new file mode 100644
index 000000000000..84720c7548fd
--- /dev/null
+++ b/games/linux-warsow/files/warsow-wrapper.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%PREFIX%%/lib/warsow || exit 1
+exec ./warsow "$@"
diff --git a/games/linux-warsow/files/wsw_server-wrapper.in b/games/linux-warsow/files/wsw_server-wrapper.in
new file mode 100644
index 000000000000..9b55c5fb81ba
--- /dev/null
+++ b/games/linux-warsow/files/wsw_server-wrapper.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%PREFIX%%/lib/warsow || exit 1
+exec ./wsw_server "$@"
diff --git a/games/linux-warsow/pkg-deinstall b/games/linux-warsow/pkg-deinstall
new file mode 100644
index 000000000000..6fb33555bef1
--- /dev/null
+++ b/games/linux-warsow/pkg-deinstall
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+case $2 in
+ DEINSTALL)
+ config_file=$PKG_PREFIX/lib/warsow/basewsw/config.cfg
+
+ if [ -e $config_file ] && ! [ -s $config_file ]; then
+ rm -f $config_file
+ fi
+ ;;
+
+ POST-DEINSTALL)
+ rmdir $PKG_PREFIX/lib/warsow/basewsw 2>/dev/null || true
+ rmdir $PKG_PREFIX/lib/warsow 2>/dev/null || true
+ ;;
+esac
diff --git a/games/linux-warsow/pkg-descr b/games/linux-warsow/pkg-descr
new file mode 100644
index 000000000000..1bcd3bfc7d9b
--- /dev/null
+++ b/games/linux-warsow/pkg-descr
@@ -0,0 +1,16 @@
+Warsow is a full free multiplayer first person shooter with cartoon design,
+using qfusion (a cool improvement to the Quake 2 engine). Highlights:
+
+ - Besides classical trix coming from Quake scene, like Circle Jump, Strafe
+ Jump, Double Jump, Bunny Hopping, etc., Warsow features its own Special
+ Moves
+ - Special moves of Warsow are Wall jumps, Dashes, Dodges, Ramp slides. All
+ of them can be performed with a single key (spacebar by default)
+ - All this brings huge depth of interactivity in 3D environment, really
+ skilled gameplay, endless learning curves
+ - Client and dedicated server
+ - Load Quake 3 maps
+ - Add bots
+ - And more
+
+WWW: http://www.warsow.net/
diff --git a/games/linux-warsow/pkg-install b/games/linux-warsow/pkg-install
new file mode 100644
index 000000000000..bd7f299115d0
--- /dev/null
+++ b/games/linux-warsow/pkg-install
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+[ "$2" != "POST-INSTALL" ] && exit 0
+
+config_file=$PKG_PREFIX/lib/warsow/basewsw/config.cfg
+
+if ! [ -e $config_file ]; then
+ touch $config_file
+ chown root:wheel $config_file 2>/dev/null
+ chmod 666 $config_file
+fi