aboutsummaryrefslogtreecommitdiff
path: root/games/marsnomercy
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/marsnomercy
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/marsnomercy')
-rw-r--r--games/marsnomercy/Makefile2
-rw-r--r--games/marsnomercy/files/patch-SConstruct6
2 files changed, 4 insertions, 4 deletions
diff --git a/games/marsnomercy/Makefile b/games/marsnomercy/Makefile
index 472879ec4718..d2161b90cf59 100644
--- a/games/marsnomercy/Makefile
+++ b/games/marsnomercy/Makefile
@@ -18,7 +18,7 @@ COMMENT= A turn-based strategy game setting on Mars
BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
-USE_GL= yes
+USE_GL= gl
USE_SDL= sdl image ttf
MAKE_ENV= CC="${CC}" CXX="${CXX}"
SCONS_ARGS= prefix=${PREFIX}
diff --git a/games/marsnomercy/files/patch-SConstruct b/games/marsnomercy/files/patch-SConstruct
index 5def5523e273..1ab7e68b7420 100644
--- a/games/marsnomercy/files/patch-SConstruct
+++ b/games/marsnomercy/files/patch-SConstruct
@@ -6,7 +6,7 @@
else:
+ # Section used for FreeBSD port
+ LOCALBASE = os.environ['LOCALBASE']
-+ X11BASE = os.environ['X11BASE']
++ LOCALBASE = os.environ['LOCALBASE']
# determine compiler and linker flags for SDL
- env.ParseConfig('sdl-config --cflags')
- env.ParseConfig('sdl-config --libs')
@@ -19,8 +19,8 @@
-
+ env.Replace(CC = os.environ['CC'])
+ env.Replace(CXX = os.environ['CXX'])
-+ env.Replace(CPPPATH = [X11BASE + '/include',LOCALBASE+ '/include'])
-+ env.Replace(LIBPATH = [X11BASE + '/lib',LOCALBASE+ '/lib'])
++ env.Replace(CPPPATH = [LOCALBASE + '/include',LOCALBASE+ '/include'])
++ env.Replace(LIBPATH = [LOCALBASE + '/lib',LOCALBASE+ '/lib'])
+ env.Append(CXXFLAGS = os.environ['CXXFLAGS'] + ' `' + SDL_CONFIG + ' --cflags`')
# generate help for options