aboutsummaryrefslogtreecommitdiff
path: root/games/megaglest
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/megaglest
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'games/megaglest')
-rw-r--r--games/megaglest/Makefile5
-rw-r--r--games/megaglest/files/patch-PNGReader.cpp10
2 files changed, 13 insertions, 2 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 791e1791cec2..27105060fdab 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -7,7 +7,7 @@
PORTNAME= megaglest
PORTVERSION= 3.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/current_release/
DISTNAME= ${PORTNAME}-source-${PORTVERSION}.3
@@ -17,7 +17,7 @@ COMMENT= Open source 3D real-time strategy game
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
vorbis.4:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= ${DATADIR}/tutorials/basic_tutorial/basic_tutorial.xml:${PORTSDIR}/games/megaglest-data
@@ -33,6 +33,7 @@ USE_OPENAL= al alut
USE_SDL= yes
USE_WX= 2.8+
+CFLAGS+= -I${LOCALBASE}/include/libpng15
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
OPTIONS= EDITOR "Install MegaGlest Editor" off
diff --git a/games/megaglest/files/patch-PNGReader.cpp b/games/megaglest/files/patch-PNGReader.cpp
new file mode 100644
index 000000000000..b05496007b98
--- /dev/null
+++ b/games/megaglest/files/patch-PNGReader.cpp
@@ -0,0 +1,10 @@
+--- source/shared_lib/sources/graphics/PNGReader.cpp.orig 2012-05-03 20:07:04.000000000 +0200
++++ source/shared_lib/sources/graphics/PNGReader.cpp 2012-05-03 20:07:48.000000000 +0200
+@@ -15,6 +15,7 @@
+ #include "pixmap.h"
+ #include <stdexcept>
+ #include <png.h>
++#include <pngpriv.h>
+ #include <setjmp.h>
+
+ #include "leak_dumper.h"