aboutsummaryrefslogtreecommitdiff
path: root/games/megaglest
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2012-09-03 19:01:55 +0000
committerCarlo Strub <cs@FreeBSD.org>2012-09-03 19:01:55 +0000
commitcd8abf7db0607a2063d210c9b526635c82277d16 (patch)
tree57b1530f04942ce39f69b33a1a464bca1e0c0e45 /games/megaglest
parent88dffc1be26621a3c8f2378f788026e4a3d54198 (diff)
downloadports-cd8abf7db0607a2063d210c9b526635c82277d16.tar.gz
ports-cd8abf7db0607a2063d210c9b526635c82277d16.zip
- Update to 3.6.0.3
- Submitter becomes new maintainer PR: ports/169376 Submitted by: Rusty Nejdl <rnejdl@ringofsaturn.com> Approved by: smoeller@nichthelfer.de (maintainer)
Notes
Notes: svn path=/head/; revision=303609
Diffstat (limited to 'games/megaglest')
-rw-r--r--games/megaglest/Makefile17
-rw-r--r--games/megaglest/distinfo4
-rw-r--r--games/megaglest/files/patch-source-shared_lib-sources-platform-posix-ircclient.cpp14
3 files changed, 26 insertions, 9 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 72d6b9f84a90..c1266436bae7 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -6,32 +6,35 @@
#
PORTNAME= megaglest
-PORTVERSION= 3.5.2
-PORTREVISION= 3
+PORTVERSION= 3.6.0.3
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/current_release/
-DISTNAME= ${PORTNAME}-source-${PORTVERSION}.3
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_${PORTVERSION}/
+DISTNAME= ${PORTNAME}-source-${PORTVERSION}
-MAINTAINER= smoeller@nichthelfer.de
+MAINTAINER= rnejdl@ringofsaturn.com
COMMENT= Open source 3D real-time strategy game
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
+ ftgl.2:${PORTSDIR}/graphics/ftgl \
vorbis.4:${PORTSDIR}/audio/libvorbis
-RUN_DEPENDS= ${DATADIR}/tutorials/basic_tutorial/basic_tutorial.xml:${PORTSDIR}/games/megaglest-data
+BUILD_DEPENDS= ${LOCALBASE}/include/libircclient.h:${PORTSDIR}/irc/libircclient \
+ ${LOCALBASE}/include/miniupnpc/miniupnpc.h:${PORTSDIR}/net/miniupnpc
+RUN_DEPENDS= ${DATADIR}/tutorials/2_basic_tutorial/2_basic_tutorial.xml:${PORTSDIR}/games/megaglest-data
SUB_FILES= pkg-message
USE_XZ= yes
USE_CMAKE= yes
USE_DOS2UNIX= yes
-USE_GL= yes
+USE_GL= glew gl glu
USE_LUA= 5.1
USE_OPENAL= al alut
USE_SDL= yes
USE_WX= 2.8+
+MAKE_JOBS_SAFE= yes
CFLAGS+= -I${LOCALBASE}/include/libpng15
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/games/megaglest/distinfo b/games/megaglest/distinfo
index 6bd3e3ff5256..46ca250c8421 100644
--- a/games/megaglest/distinfo
+++ b/games/megaglest/distinfo
@@ -1,2 +1,2 @@
-SHA256 (megaglest-source-3.5.2.3.tar.xz) = 76e1c899aeffa54cbf0de38104a7bc4d6abcc5a504922636bfba4c44d9d40454
-SIZE (megaglest-source-3.5.2.3.tar.xz) = 1185872
+SHA256 (megaglest-source-3.6.0.3.tar.xz) = 700b1eef534d72fa5efd329445aa085259a87dcea5e739eda629e6c41386b9f7
+SIZE (megaglest-source-3.6.0.3.tar.xz) = 1336432
diff --git a/games/megaglest/files/patch-source-shared_lib-sources-platform-posix-ircclient.cpp b/games/megaglest/files/patch-source-shared_lib-sources-platform-posix-ircclient.cpp
new file mode 100644
index 000000000000..c38c0172d74c
--- /dev/null
+++ b/games/megaglest/files/patch-source-shared_lib-sources-platform-posix-ircclient.cpp
@@ -0,0 +1,14 @@
+--- source/shared_lib/sources/platform/posix/ircclient.cpp 2012-01-23 14:36:15.000000000 -0600
++++ source/shared_lib/sources/platform/posix/ircclient.cpp.new 2012-06-24 09:51:37.000000000 -0500
+@@ -14,11 +14,7 @@
+ #include "util.h"
+ #include "platform_common.h"
+ #include "libircclient.h"
+-
+-// upstream moved some defines into new headers as of 1.6
+-#ifndef LIBIRCCLIENT_PRE1_6
+ #include "libirc_rfcnumeric.h"
+-#endif
+
+ #include <stdio.h>
+ #include <stdarg.h>