aboutsummaryrefslogtreecommitdiff
path: root/games/mvdsv
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
commitf2fc2d60ae226a1b8d5411fb4aab91ea92be6f91 (patch)
treee9a77f53d4fe679665594e718ad34b49668507cc /games/mvdsv
parent063f8ca62467e4709e58c8bb6b67c85970fe28a1 (diff)
downloadports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.tar.gz
ports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.zip
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
Notes
Notes: svn path=/head/; revision=132992
Diffstat (limited to 'games/mvdsv')
-rw-r--r--games/mvdsv/Makefile2
-rw-r--r--games/mvdsv/files/Makefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/games/mvdsv/Makefile b/games/mvdsv/Makefile
index 5420ff07131d..0cbbfadce3e8 100644
--- a/games/mvdsv/Makefile
+++ b/games/mvdsv/Makefile
@@ -45,7 +45,7 @@ pre-everything::
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "Define WITH_OPTIMIZED_CFLAGS to enable extra optimization options"
.endif
-.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
@${ECHO_MSG} "Define WITHOUT_X86_ASM to disable x86 assembly code"
.endif
diff --git a/games/mvdsv/files/Makefile b/games/mvdsv/files/Makefile
index bc1f37e86d85..74b6d442bbef 100644
--- a/games/mvdsv/files/Makefile
+++ b/games/mvdsv/files/Makefile
@@ -13,7 +13,7 @@
DO_CFLAGS = ${CFLAGS} -funsigned-char -I${LOCALBASE}/include -DSERVERONLY -Dstricmp=strcasecmp
-.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
DO_CFLAGS += -Did386
.endif
@@ -64,7 +64,7 @@ SV_OBJS = \
world.o \
zone.o
-.if ${MACHINE_ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
+.if ${ARCH} == "i386" && !defined(WITHOUT_X86_ASM)
SV_AS_OBJS = \
math.o \
sys_x86.o \