aboutsummaryrefslogtreecommitdiff
path: root/games/naev/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-23 20:36:23 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-23 20:36:23 +0000
commitd4fa20069ec06ee89dfdb3a4cc19442237d69761 (patch)
tree94d700b8a2c88fd6033c1bd97ea4cd4ba8ec0f91 /games/naev/Makefile
parent1b6531fbe3b5ccf6be24f272cb03c891d234ceda (diff)
downloadports-d4fa20069ec06ee89dfdb3a4cc19442237d69761.tar.gz
ports-d4fa20069ec06ee89dfdb3a4cc19442237d69761.zip
- Update to 0.6.0
PR: 198684 Submitted by: lightside@gmx.com Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=384609
Diffstat (limited to 'games/naev/Makefile')
-rw-r--r--games/naev/Makefile62
1 files changed, 34 insertions, 28 deletions
diff --git a/games/naev/Makefile b/games/naev/Makefile
index 2f948f72b5ad..10a2eb477dea 100644
--- a/games/naev/Makefile
+++ b/games/naev/Makefile
@@ -2,56 +2,62 @@
# $FreeBSD$
PORTNAME= naev
-PORTVERSION= 0.5.3
-PORTREVISION= 4
+PORTVERSION= 0.6.0
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
- ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= acm@FreeBSD.org
COMMENT= 2D action/RPG space game
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2 \
- libvorbisfile.so:${PORTSDIR}/audio/libvorbis
-RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/ndata-${PORTVERSION}:${PORTSDIR}/games/naev-data
+ libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
+ libzip.so:${PORTSDIR}/archivers/libzip \
+ libcsparse.so:${PORTSDIR}/math/suitesparse
+RUN_DEPENDS= ${DATADIR}/ndata-${PORTVERSION}.zip:${PORTSDIR}/games/naev-data
-USES= gmake pkgconfig tar:bzip2
-USE_AUTOTOOLS= automake:env aclocal:env autoconf:env
+USES= autoreconf:build gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_GL= glu
USE_GNOME= libxml2
-USE_SDL= sdl image
-CONFIGURE_ARGS= --with-ndata-path=${DATADIR}/ndata-${PORTVERSION}
+CONFIGURE_ARGS= --with-ndata-path="${DATADIR}/ndata-${PORTVERSION}.zip" \
+ --enable-debug=no
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lm
-PLIST_FILES= bin/${PORTNAME} man/man6/naev.6.gz
-SUB_FILES= pkg-message
+PORTDATA= *
+PORTDOCS= *
+
+PLIST_FILES= bin/${PORTNAME} man/man6/naev.6.gz \
+ share/applications/${PORTNAME}.desktop \
+ share/appdata/${PORTNAME}.appdata.xml \
+ share/pixmaps/${PORTNAME}.png
+
+OPTIONS_DEFINE= DOCS OPENAL SDL2 SDL_MIXER
+OPTIONS_DEFAULT= OPENAL SDL2 SDL_MIXER
-OPTIONS_DEFINE= OPENAL SDL_MIXER
+OPENAL_USES= openal
+OPENAL_CONFIGURE_WITH= openal
SDL_MIXER_DESC= SDL_mixer sound backend
+SDL_MIXER_CONFIGURE_WITH= sdlmixer
+SDL2_DESC= Use SDL2 instead of SDL
+SDL2_CONFIGURE_WITH= sdl2
+SDL2_USE= SDL=sdl2
+SDL2_USE_OFF= SDL=sdl
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MOPENAL}
-USES+= openal
-CONFIGURE_ARGS+= --with-openal=yes
-.else
-CONFIGURE_ARGS+= --with-openal=no
-.endif
-
.if ${PORT_OPTIONS:MSDL_MIXER}
-USE_SDL+= mixer
-CONFIGURE_ARGS+= --with-sdlmixer=yes
-.else
-CONFIGURE_ARGS+= --with-sdlmixer=no
+. if ${PORT_OPTIONS:MSDL2}
+USE_SDL+= mixer2
+. else
+USE_SDL+= mixer
+. endif
.endif
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6
-
.include <bsd.port.mk>