aboutsummaryrefslogtreecommitdiff
path: root/games/nethack32
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-06-15 02:33:45 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-06-15 02:33:45 +0000
commit10c8d61b5dbf1093d49732642b9314c44d963bf5 (patch)
tree74979fe5224114f903e2abf1f5d6c092d123908a /games/nethack32
parenta5e07169fa665e9d78d522d8a7dfb58553a5e09e (diff)
downloadports-10c8d61b5dbf1093d49732642b9314c44d963bf5.tar.gz
ports-10c8d61b5dbf1093d49732642b9314c44d963bf5.zip
You die... But wait... Your medallion begins to glow!--More--
You feel much better! The medallion crumbles to dust!--More-- You survived that attempt on your life. Approved by: knu
Notes
Notes: svn path=/head/; revision=61308
Diffstat (limited to 'games/nethack32')
-rw-r--r--games/nethack32/Makefile37
-rw-r--r--games/nethack32/distinfo2
-rw-r--r--games/nethack32/files/patch-ab49
-rw-r--r--games/nethack32/files/patch-ac47
-rw-r--r--games/nethack32/files/patch-ad20
-rw-r--r--games/nethack32/files/patch-ae37
-rw-r--r--games/nethack32/files/patch-af12
-rw-r--r--games/nethack32/files/patch-ag40
-rw-r--r--games/nethack32/pkg-comment1
-rw-r--r--games/nethack32/pkg-descr13
-rw-r--r--games/nethack32/pkg-plist124
11 files changed, 382 insertions, 0 deletions
diff --git a/games/nethack32/Makefile b/games/nethack32/Makefile
new file mode 100644
index 000000000000..049d5147cbdf
--- /dev/null
+++ b/games/nethack32/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: nethack
+# Date created: 27 March 1995
+# Whom: asami
+#
+# $FreeBSD$
+#
+
+PORTNAME= nethack
+PORTVERSION= 3.2.3
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.nethack.org/pub/nethack/nh322/src/ \
+ ftp://ftp.wtower.com/nethack/sources/
+DISTNAME= nethack-3.2.2
+
+PATCH_SITES= ftp://ftp.nethack.org/pub/nethack/nh323/src/
+PATCHFILES= nh-3.2.2-3.2.3.diff
+
+MAINTAINER= glewis@FreeBSD.org
+
+NO_LATEST_LINK= yes
+
+USE_XPM= yes
+USE_GMAKE= yes
+MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
+
+pre-configure:
+ @cd ${WRKSRC}/sys/unix; ${SH} setup.sh
+
+post-install:
+ @cd ${WRKSRC}/doc; ${CHMOD} 644 *.6
+ @cd ${WRKSRC}/doc; PREFIX=${PREFIX} ${MAKE} manpages
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/nethack32/distinfo b/games/nethack32/distinfo
new file mode 100644
index 000000000000..052adcdf3017
--- /dev/null
+++ b/games/nethack32/distinfo
@@ -0,0 +1,2 @@
+MD5 (nethack-3.2.2.tar.gz) = c85de4d14453b3a2d182d1dfc2ca04df
+MD5 (nh-3.2.2-3.2.3.diff) = 440141990df326d5a973d890179cffae
diff --git a/games/nethack32/files/patch-ab b/games/nethack32/files/patch-ab
new file mode 100644
index 000000000000..a22424c84079
--- /dev/null
+++ b/games/nethack32/files/patch-ab
@@ -0,0 +1,49 @@
+--- sys/unix/Makefile.src.orig Wed Dec 11 05:20:09 1996
++++ sys/unix/Makefile.src Sun Mar 21 17:50:08 1999
+@@ -124,8 +124,8 @@
+ # flags for debugging:
+ # CFLAGS = -g -I../include
+
+-CFLAGS = -O -I../include
+-LFLAGS =
++CFLAGS += -O -I../include -I${X11BASE}/include
++LFLAGS = -L${X11BASE}/lib
+
+
+ # Set the WINSRC, WINOBJ, and WINLIB lines to correspond to your desired
+@@ -146,8 +146,8 @@
+ winmisc.o winstat.o wintext.o winval.o tile.o
+ #
+ #
+-WINSRC = $(WINTTYSRC)
+-WINOBJ = $(WINTTYOBJ)
++WINSRC = $(WINTTYSRC) $(WINX11SRC)
++WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
+
+ # on some systems the termcap library is in -ltermcap or -lcurses
+ # on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
+@@ -167,13 +167,13 @@
+ #
+ # libraries for X11
+ # If USE_XPM is defined in config.h, you will also need -lXpm here.
+-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
++WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11 -lXpm
+ # WINX11LIB = -lXaw -lXmu -lXt -lX11
+ # WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
+ # WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
+ #
+ #
+-WINLIB = $(WINTTYLIB)
++WINLIB = $(WINTTYLIB) $(WINX11LIB)
+
+ # any other strange libraries your system needs (for Sysunix only -- the more
+ # specialized targets should already be right)
+@@ -197,7 +197,7 @@
+ # IRIX 4.0.x needs -lsun if NIS (YP) is being used for passwd file lookup
+ # LIBS = -lsun
+ #
+-LIBS =
++LIBS = -lSM -lICE
+
+ # make NetHack
+ GAME = nethack
diff --git a/games/nethack32/files/patch-ac b/games/nethack32/files/patch-ac
new file mode 100644
index 000000000000..ee05125afe6c
--- /dev/null
+++ b/games/nethack32/files/patch-ac
@@ -0,0 +1,47 @@
+diff -ruN ./include/config.h ../nethack-3.2.2/include/config.h
+--- ./include/config.h Wed Dec 11 05:20:07 1996
++++ ../nethack-3.2.2/include/config.h Sun Mar 21 17:25:02 1999
+@@ -211,7 +211,7 @@
+ * Some combinations make no sense. See the installation document.
+ */
+ #define TTY_GRAPHICS /* good old tty based graphics */
+-/* #define X11_GRAPHICS /* X11 interface */
++#define X11_GRAPHICS /* X11 interface */
+
+ /*
+ * Define the default window system. This should be one that is compiled
+@@ -256,7 +256,7 @@
+ * would allow:
+ * xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
+ */
+-/* # define USE_XPM /* Disable if you do not have the XPM library */
++# define USE_XPM /* Disable if you do not have the XPM library */
+ # ifdef USE_XPM
+ # define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
+ # endif
+@@ -296,12 +296,12 @@
+
+ #ifdef UNIX
+ /* path and file name extension for compression program */
+-# define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
+-# define COMPRESS_EXTENSION ".Z" /* compress's extension */
++/* # define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
++/* # define COMPRESS_EXTENSION ".Z" /* compress's extension */
+
+ /* An example of one alternative you might want to use: */
+-/* # define COMPRESS "/usr/local/bin/gzip" /* FSF gzip compression */
+-/* # define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
++# define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
++# define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
+ #endif
+ #ifndef COMPRESS
+ # define INTERNAL_COMP /* control use of NetHack's compression routines */
+@@ -331,7 +331,7 @@
+ * otherwise it will be the current directory.
+ */
+ # ifndef HACKDIR
+-# define HACKDIR "/usr/games/lib/nethackdir" /* nethack directory */
++# define HACKDIR "/usr/local/share/nethack" /* nethack directory */
+ # endif
+
+ /*
diff --git a/games/nethack32/files/patch-ad b/games/nethack32/files/patch-ad
new file mode 100644
index 000000000000..4ff9c983d5ca
--- /dev/null
+++ b/games/nethack32/files/patch-ad
@@ -0,0 +1,20 @@
+--- include/system.h.orig Mon Nov 4 08:01:25 1996
++++ include/system.h Sat Jun 19 16:18:02 1999
+@@ -80,7 +80,7 @@
+ # if !defined(SUNOS4) || defined(RANDOM)
+ E void FDECL(srandom, (unsigned int));
+ # else
+-# ifndef bsdi
++# if !defined(bsdi) && !defined(__FreeBSD__)
+ E int FDECL(srandom, (unsigned int));
+ # endif
+ # endif
+@@ -510,7 +510,7 @@
+ # if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC)
+ E time_t FDECL(time, (time_t *));
+ # else
+-E long FDECL(time, (time_t *));
++E time_t FDECL(time, (time_t *));
+ # endif /* ULTRIX */
+
+ #ifdef VMS
diff --git a/games/nethack32/files/patch-ae b/games/nethack32/files/patch-ae
new file mode 100644
index 000000000000..b5c24ee2719d
--- /dev/null
+++ b/games/nethack32/files/patch-ae
@@ -0,0 +1,37 @@
+diff -ruN ./include/unixconf.h ../nethack-3.2.2/include/unixconf.h
+--- ./include/unixconf.h Wed Dec 11 05:20:08 1996
++++ ../nethack-3.2.2/include/unixconf.h Sun Mar 21 17:25:02 1999
+@@ -31,7 +31,7 @@
+
+ /* define any of the following that are appropriate */
+ /* #define SVR4 /* use in addition to SYSV for System V Release 4 */
+-#define NETWORK /* if running on a networked system */
++/* #define NETWORK /* if running on a networked system */
+ /* e.g. Suns sharing a playground through NFS */
+ #define SUNOS4 /* SunOS 4.x */
+ /* #define LINUX /* Another Unix clone */
+@@ -42,12 +42,12 @@
+ /* #define AIX_31 /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
+ * job control (note that AIX is SYSV otherwise)
+ * Also define this for AIX 3.2 */
+-/* #define TEXTCOLOR /* Use System V r3.2 terminfo color support */
++#define TEXTCOLOR /* Use System V r3.2 terminfo color support */
+ /* and/or ANSI color support on termcap systems */
+ /* and/or X11 color */
+-/* #define POSIX_JOB_CONTROL /* use System V / POSIX job control
++#define POSIX_JOB_CONTROL /* use System V / POSIX job control
+ * (e.g., VSUSP) */
+-/* #define POSIX_TYPES /* use POSIX types for system calls and termios */
++#define POSIX_TYPES /* use POSIX types for system calls and termios */
+ /* define for many recent OS releases, including
+ * those with specific defines (since types are
+ * changing toward the standard from earlier chaos).
+@@ -125,7 +125,7 @@
+ * A stat system call is done on the mailbox every MAILCKFREQ moves.
+ */
+
+-#define MAIL /* Deliver mail during the game */
++/* #define MAIL /* Deliver mail during the game */
+
+ /* The Andrew Message System does mail a little differently from normal
+ * UNIX. Mail is deposited in the user's own directory in ~/Mailbox
diff --git a/games/nethack32/files/patch-af b/games/nethack32/files/patch-af
new file mode 100644
index 000000000000..75c84c235c88
--- /dev/null
+++ b/games/nethack32/files/patch-af
@@ -0,0 +1,12 @@
+diff -ruN ./sys/unix/Makefile.doc ../nethack-3.2.2/sys/unix/Makefile.doc
+--- ./sys/unix/Makefile.doc Wed Dec 11 05:20:08 1996
++++ ../nethack-3.2.2/sys/unix/Makefile.doc Sun Mar 21 17:25:02 1999
+@@ -31,7 +31,7 @@
+
+
+ GAME = nethack
+-MANDIR = /usr/man/man6
++MANDIR = ${PREFIX}/man/man6
+ MANEXT = 6
+
+ # manual installation for most BSD-style systems
diff --git a/games/nethack32/files/patch-ag b/games/nethack32/files/patch-ag
new file mode 100644
index 000000000000..6fbe422824f3
--- /dev/null
+++ b/games/nethack32/files/patch-ag
@@ -0,0 +1,40 @@
+diff -ruN ./sys/unix/Makefile.top ../nethack-3.2.2/sys/unix/Makefile.top
+--- ./sys/unix/Makefile.top Wed Dec 11 05:20:10 1996
++++ ../nethack-3.2.2/sys/unix/Makefile.top Sun Mar 21 17:29:27 1999
+@@ -16,14 +16,14 @@
+ # make NetHack
+ GAME = nethack
+ GAMEUID = games
+-GAMEGRP = bin
++GAMEGRP = games
+
+ # Permissions - some places use setgid instead of setuid, for instance
+ # See also the option "SECURE" in include/config.h
+-GAMEPERM = 04755
+-FILEPERM = 0644
++GAMEPERM = 02755
++FILEPERM = 0664
+ EXEPERM = 0755
+-DIRPERM = 0755
++DIRPERM = 0775
+
+ # GAMEDIR also appears in config.h as "HACKDIR".
+ #
+@@ -32,13 +32,13 @@
+ # therefore there should not be anything in GAMEDIR that you want to keep
+ # (if there is, you'll have to do the installation by hand or modify the
+ # instructions)
+-GAMEDIR = /usr/games/lib/$(GAME)dir
+-SHELLDIR = /usr/games
++GAMEDIR = ${PREFIX}/share/$(GAME)
++SHELLDIR = ${PREFIX}/bin
+
+ # per discussion in Install.X11
+-VARDATND =
++# VARDATND =
+ # VARDATND = x11tiles pet_mark.xbm
+-# VARDATND = x11tiles pet_mark.xbm rip.xpm
++VARDATND = x11tiles pet_mark.xbm rip.xpm
+
+ VARDATD = data oracles options quest.dat rumors
+ VARDAT = $(VARDATD) $(VARDATND)
diff --git a/games/nethack32/pkg-comment b/games/nethack32/pkg-comment
new file mode 100644
index 000000000000..70ca7a893988
--- /dev/null
+++ b/games/nethack32/pkg-comment
@@ -0,0 +1 @@
+A dungeon explorin', slashin', hackin' game
diff --git a/games/nethack32/pkg-descr b/games/nethack32/pkg-descr
new file mode 100644
index 000000000000..52e265b8886f
--- /dev/null
+++ b/games/nethack32/pkg-descr
@@ -0,0 +1,13 @@
+This is nethack. You and your puppy (or kitten) will explore the deep
+dungeons to retrieve the long-lost magical item that causes so much
+trouble to anyone.
+
+Take care, and try not to miss meals.
+
+WWW: http://www.win.tue.nl/games/roguelike/nethack/
+
+- Satoshi
+asami@cs.berkeley.edu
+
+P.S. There is a newsgroup "rec.games.roguelike.nethack" if you are
+ truly interested.
diff --git a/games/nethack32/pkg-plist b/games/nethack32/pkg-plist
new file mode 100644
index 000000000000..7dfddb3cb28d
--- /dev/null
+++ b/games/nethack32/pkg-plist
@@ -0,0 +1,124 @@
+bin/nethack
+share/nethack/nethack
+@exec mkdir %D/share/nethack/save
+@exec chmod -R 775 %D/share/nethack
+@exec chmod 2755 %D/share/nethack/nethack
+@exec chown games:games %D/share/nethack/save
+@unexec rm -rf %D/share/nethack/save
+%%PORTDOCS%%share/doc/nethack/Guidebook.txt
+share/nethack/pet_mark.xbm
+share/nethack/rip.xpm
+share/nethack/x11tiles
+share/nethack/A-filla.lev
+share/nethack/A-fillb.lev
+share/nethack/A-goal.lev
+share/nethack/A-locate.lev
+share/nethack/A-start.lev
+share/nethack/B-filla.lev
+share/nethack/B-fillb.lev
+share/nethack/B-goal.lev
+share/nethack/B-locate.lev
+share/nethack/B-start.lev
+share/nethack/C-filla.lev
+share/nethack/C-fillb.lev
+share/nethack/C-goal.lev
+share/nethack/C-locate.lev
+share/nethack/C-start.lev
+share/nethack/E-filla.lev
+share/nethack/E-fillb.lev
+share/nethack/E-goal.lev
+share/nethack/E-locate.lev
+share/nethack/E-start.lev
+share/nethack/H-filla.lev
+share/nethack/H-fillb.lev
+share/nethack/H-goal.lev
+share/nethack/H-locate.lev
+share/nethack/H-start.lev
+share/nethack/K-filla.lev
+share/nethack/K-fillb.lev
+share/nethack/K-goal.lev
+share/nethack/K-locate.lev
+share/nethack/K-start.lev
+share/nethack/P-filla.lev
+share/nethack/P-fillb.lev
+share/nethack/P-goal.lev
+share/nethack/P-locate.lev
+share/nethack/P-start.lev
+share/nethack/R-filla.lev
+share/nethack/R-fillb.lev
+share/nethack/R-goal.lev
+share/nethack/R-locate.lev
+share/nethack/R-start.lev
+share/nethack/S-filla.lev
+share/nethack/S-fillb.lev
+share/nethack/S-goal.lev
+share/nethack/S-locate.lev
+share/nethack/S-start.lev
+share/nethack/T-filla.lev
+share/nethack/T-fillb.lev
+share/nethack/T-goal.lev
+share/nethack/T-locate.lev
+share/nethack/T-start.lev
+share/nethack/V-filla.lev
+share/nethack/V-fillb.lev
+share/nethack/V-goal.lev
+share/nethack/V-locate.lev
+share/nethack/V-start.lev
+share/nethack/W-filla.lev
+share/nethack/W-fillb.lev
+share/nethack/W-goal.lev
+share/nethack/W-locate.lev
+share/nethack/W-start.lev
+share/nethack/air.lev
+share/nethack/asmodeus.lev
+share/nethack/astral.lev
+share/nethack/baalz.lev
+share/nethack/bigrm-1.lev
+share/nethack/bigrm-2.lev
+share/nethack/bigrm-3.lev
+share/nethack/bigrm-4.lev
+share/nethack/bigrm-5.lev
+share/nethack/castle.lev
+share/nethack/cmdhelp
+share/nethack/data
+share/nethack/dungeon
+share/nethack/earth.lev
+share/nethack/fakewiz1.lev
+share/nethack/fakewiz2.lev
+share/nethack/fire.lev
+share/nethack/help
+share/nethack/hh
+share/nethack/history
+share/nethack/juiblex.lev
+share/nethack/knox.lev
+share/nethack/license
+share/nethack/medusa-1.lev
+share/nethack/medusa-2.lev
+share/nethack/minefill.lev
+share/nethack/minend-1.lev
+share/nethack/minend-2.lev
+share/nethack/minetn-1.lev
+share/nethack/minetn-2.lev
+share/nethack/opthelp
+share/nethack/options
+share/nethack/oracle.lev
+share/nethack/oracles
+share/nethack/orcus.lev
+share/nethack/quest.dat
+share/nethack/rumors
+share/nethack/sanctum.lev
+share/nethack/tower1.lev
+share/nethack/tower2.lev
+share/nethack/tower3.lev
+share/nethack/valley.lev
+share/nethack/water.lev
+share/nethack/wizard1.lev
+share/nethack/wizard2.lev
+share/nethack/wizard3.lev
+share/nethack/wizhelp
+@mode 664
+share/nethack/logfile
+share/nethack/record
+share/nethack/perm
+@dirrm share/nethack
+%%PORTDOCS%%@dirrm share/doc/nethack