aboutsummaryrefslogtreecommitdiff
path: root/games/newvox/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-08-23 12:28:12 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-08-23 12:28:12 +0000
commita0c139383d4637187e1f93862ff17999dd05f155 (patch)
tree28608fb9a9019534fe4bd326d5db8007fbcc97ab /games/newvox/Makefile
parentad75835a64cad156b09a80a3a480b375d13d93b4 (diff)
downloadports-a0c139383d4637187e1f93862ff17999dd05f155.tar.gz
ports-a0c139383d4637187e1f93862ff17999dd05f155.zip
Add voxel-1.0
Voxel-style landscape rendering. Move around the landscape by using the arrow keys. Obtained from: OpenBSD
Notes
Notes: svn path=/head/; revision=46705
Diffstat (limited to 'games/newvox/Makefile')
-rw-r--r--games/newvox/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/games/newvox/Makefile b/games/newvox/Makefile
new file mode 100644
index 000000000000..4b279fb662fa
--- /dev/null
+++ b/games/newvox/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: newvox
+# Date created: 23 Aug 2001
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= newvox
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://www.libsdl.org/projects/newvox/src/
+
+MAINTAINER= kris@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG="${PREFIX}/bin/sdl11-config"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/newvox ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/newvox
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/newvox
+.endif
+
+.include <bsd.port.mk>