aboutsummaryrefslogtreecommitdiff
path: root/games/njam/files
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-09-20 11:21:59 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-09-20 11:21:59 +0000
commit0d2725682b8325a08b11592d11062997bb9dc7f2 (patch)
tree46ab0c86563bfc2fbab1ecc5f9dadffb47afe737 /games/njam/files
parent750f1f56ed3264341b911b1182fc2f3f4dd609c2 (diff)
downloadports-0d2725682b8325a08b11592d11062997bb9dc7f2.tar.gz
ports-0d2725682b8325a08b11592d11062997bb9dc7f2.zip
- Update devel/sdl12 to version 1.2.11. Now we employ stock SDL directory
structure (i.e. include/SDL for includes and sdl-config for configuration binary) - Update graphics/sdl_ttf to version 2.0.8 - Update graphics/sdl_image to version 1.2.5 - Update audio/sdl_mixer to version 1.2.7 - Update net/sdl_net to version 1.2.6 - Update Mk/bsd.sdl.mk accordingly - Fix dependent ports to fit the new directory structure and avoid several API breakages - Bump up portrevisions for all dependent ports to allow them to be upgraded by portupgrade/portmaster etc tools Approved by: kris (portmgr), sem (mentor)
Notes
Notes: svn path=/head/; revision=173460
Diffstat (limited to 'games/njam/files')
-rw-r--r--games/njam/files/patch-Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/njam/files/patch-Makefile b/games/njam/files/patch-Makefile
index 50e5241c9fb0..0f46e5cf3365 100644
--- a/games/njam/files/patch-Makefile
+++ b/games/njam/files/patch-Makefile
@@ -14,7 +14,7 @@
# If you hate warnings under Cygwin use these flags instead
# MY_CFLAGS = -I/usr/local/include/SDL -Dmain=SDL_main -DWIN32 -Uunix -mno-cygwin
-MY_CFLAGS = `sdl-config --cflags`
-+MY_CFLAGS += `sdl11-config --cflags`
++MY_CFLAGS += `sdl-config --cflags`
%.o: %.cpp
- $(CC) -O3 -c $(MY_CFLAGS) $< -o $@
@@ -24,7 +24,7 @@
$(PROGRAM): $(OBJECTS)
- $(CC) `sdl-config --libs` -o$(PROGRAM) $(OBJECTS) -lSDL -lSDL_mixer -lSDL_net -lSDL_image
-+ $(CC) `sdl11-config --libs` -o$(PROGRAM) $(OBJECTS) -lSDL_mixer -lSDL_net -lSDL_image
++ $(CC) `sdl-config --libs` -o$(PROGRAM) $(OBJECTS) -lSDL_mixer -lSDL_net -lSDL_image
clean:
$(RM) *.o