aboutsummaryrefslogtreecommitdiff
path: root/games/opengfx
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-11-04 19:17:39 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-11-04 19:17:39 +0000
commitb0752d9f661e50faaff44bc1122eef360e1246a4 (patch)
tree703e3b81351d722c133e1e3146b25319f57b09f3 /games/opengfx
parent2bcfee535d1bb7c27583d0c08a38e38c147f6b94 (diff)
downloadports-b0752d9f661e50faaff44bc1122eef360e1246a4.tar.gz
ports-b0752d9f661e50faaff44bc1122eef360e1246a4.zip
Add new port games/opengfx:
OpenGFX is free alternative graphics for OpenTTD game engine. WWW: http://dev.openttdcoop.org/projects/opengfx PR: ports/151916 Submitted by: Ilya A. Arhipov <admin at gorodkirov.ru>
Notes
Notes: svn path=/head/; revision=264089
Diffstat (limited to 'games/opengfx')
-rw-r--r--games/opengfx/Makefile29
-rw-r--r--games/opengfx/distinfo2
-rw-r--r--games/opengfx/pkg-descr3
-rw-r--r--games/opengfx/pkg-plist12
4 files changed, 46 insertions, 0 deletions
diff --git a/games/opengfx/Makefile b/games/opengfx/Makefile
new file mode 100644
index 000000000000..7c7c5661051a
--- /dev/null
+++ b/games/opengfx/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: opengfx
+# Date created: 2010-11-04
+# Whom: Ilya A. Arhipov
+#
+# $FreeBSD$
+#
+
+PORTNAME= opengfx
+PORTVERSION= 0.3.1
+CATEGORIES= games
+MASTER_SITES= http://ftp.snt.utwente.nl/pub/games/openttd/binaries/extra/opengfx/${PORTVERSION}/ \
+ http://gb.binaries.openttd.org/binaries/extra/opengfx/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-all
+
+MAINTAINER= micro@heavennet.ru
+COMMENT= Free alternative graphics for OpenTTD game engine
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+post-extract:
+ @${FIND} ${WRKDIR}/opengfx-${PORTVERSION} -type f -name "*.txt" -exec ${MV} {} {}-gfx \;
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/openttd/data
+ ${INSTALL_DATA} ${WRKDIR}/opengfx-${PORTVERSION}/* \
+ ${PREFIX}/share/openttd/data
+
+.include <bsd.port.mk>
diff --git a/games/opengfx/distinfo b/games/opengfx/distinfo
new file mode 100644
index 000000000000..87309820d5c4
--- /dev/null
+++ b/games/opengfx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (opengfx-0.3.1-all.zip) = 16be83cd0fc59ba8f1a8b3f3ebe26e6c0df325ca7593976de74e073c5d1ee39b
+SIZE (opengfx-0.3.1-all.zip) = 3387182
diff --git a/games/opengfx/pkg-descr b/games/opengfx/pkg-descr
new file mode 100644
index 000000000000..047cb033e8b2
--- /dev/null
+++ b/games/opengfx/pkg-descr
@@ -0,0 +1,3 @@
+OpenGFX is free alternative graphics for OpenTTD game engine.
+
+WWW: http://dev.openttdcoop.org/projects/opengfx
diff --git a/games/opengfx/pkg-plist b/games/opengfx/pkg-plist
new file mode 100644
index 000000000000..b1452b84f8e2
--- /dev/null
+++ b/games/opengfx/pkg-plist
@@ -0,0 +1,12 @@
+share/openttd/data/changelog.txt-gfx
+share/openttd/data/license.txt-gfx
+share/openttd/data/ogfx1_base.grf
+share/openttd/data/ogfxc_arctic.grf
+share/openttd/data/ogfxe_extra.grf
+share/openttd/data/ogfxh_tropical.grf
+share/openttd/data/ogfxi_logos.grf
+share/openttd/data/ogfxt_toyland.grf
+share/openttd/data/opengfx.obg
+share/openttd/data/readme.txt-gfx
+@dirrmtry share/openttd/data
+@dirrmtry share/openttd