aboutsummaryrefslogtreecommitdiff
path: root/games/p5-Games-AlphaBeta
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-31 11:50:26 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-31 11:50:26 +0000
commit341645c901d2a4f6ed3fc80afaeb5bbbbc163081 (patch)
tree3985c7174d5e57edff0fc4fcf785f59592eae863 /games/p5-Games-AlphaBeta
parentbaf95d8d2d99f24e2cb34a3a901d2e439226833e (diff)
downloadports-341645c901d2a4f6ed3fc80afaeb5bbbbc163081.tar.gz
ports-341645c901d2a4f6ed3fc80afaeb5bbbbc163081.zip
Add p5-Games-AlphaBeta 0.4.5, game-tree search with object oriented
interface. PR: ports/84165 Submitted by: Aaron Dalton <aaron@daltons.ca>
Notes
Notes: svn path=/head/; revision=141564
Diffstat (limited to 'games/p5-Games-AlphaBeta')
-rw-r--r--games/p5-Games-AlphaBeta/Makefile26
-rw-r--r--games/p5-Games-AlphaBeta/distinfo2
-rw-r--r--games/p5-Games-AlphaBeta/pkg-descr18
-rw-r--r--games/p5-Games-AlphaBeta/pkg-plist8
4 files changed, 54 insertions, 0 deletions
diff --git a/games/p5-Games-AlphaBeta/Makefile b/games/p5-Games-AlphaBeta/Makefile
new file mode 100644
index 000000000000..93e2c391cd35
--- /dev/null
+++ b/games/p5-Games-AlphaBeta/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Games-AlphaBeta
+# Date created: 27 July 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-AlphaBeta
+PORTVERSION= 0.4.5
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Game-tree search with object oriented interface
+
+BUILD_DEPENDS= ${SITE_PERL}/Games/Sequential.pm:${PORTSDIR}/games/p5-Games-Sequential
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Games::AlphaBeta.3 Games::AlphaBeta::Position.3 \
+ Games::AlphaBeta::Reversi.3
+
+.include <bsd.port.mk>
diff --git a/games/p5-Games-AlphaBeta/distinfo b/games/p5-Games-AlphaBeta/distinfo
new file mode 100644
index 000000000000..ada2eb52ee9b
--- /dev/null
+++ b/games/p5-Games-AlphaBeta/distinfo
@@ -0,0 +1,2 @@
+MD5 (Games-AlphaBeta-0.4.5.tar.gz) = a6a6b18960cced47f12747e26dd18271
+SIZE (Games-AlphaBeta-0.4.5.tar.gz) = 8952
diff --git a/games/p5-Games-AlphaBeta/pkg-descr b/games/p5-Games-AlphaBeta/pkg-descr
new file mode 100644
index 000000000000..1a153ab716eb
--- /dev/null
+++ b/games/p5-Games-AlphaBeta/pkg-descr
@@ -0,0 +1,18 @@
+Games::AlphaBeta provides a generic implementation of the AlphaBeta
+game-tree search algorithm (also known as MiniMax search with alpha beta
+pruning). This algorithm can be used to find the best move at a particular
+position in any two-player, zero-sum game with perfect information.
+Examples of such games include Chess, Othello, Connect4, Go, Tic-Tac-Toe
+and many, many other boardgames.
+
+Users must pass an object representing the initial state of the game as the
+first argument to new(). This object must provide the following methods:
+copy(), apply(), endpos(), evaluate() and findmoves(). This is explained
+more carefully in Games::AlphaBeta::Position which is a base class you can
+use to implement your position object.
+
+WWW: http://search.cpan.org/dist/Games-AlphaBeta
+Author: Stig Brautaset <stig@brautaset.org>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/games/p5-Games-AlphaBeta/pkg-plist b/games/p5-Games-AlphaBeta/pkg-plist
new file mode 100644
index 000000000000..1a7b60a81efb
--- /dev/null
+++ b/games/p5-Games-AlphaBeta/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Games/AlphaBeta.pm
+%%SITE_PERL%%/Games/AlphaBeta/Position.pm
+%%SITE_PERL%%/Games/AlphaBeta/Reversi.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/AlphaBeta/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/AlphaBeta
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Games/AlphaBeta
+@unexec rmdir %D/%%SITE_PERL%%/Games 2>/dev/null || true