aboutsummaryrefslogtreecommitdiff
path: root/games/p5-Games-Bingo-Print/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-09-01 14:43:05 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-09-01 14:43:05 +0000
commitd1a1be32bb370b8a08f8f3e7d0b79dfcc3c83a38 (patch)
tree8001364dc26e797d24637bb0664724a0641c7bc7 /games/p5-Games-Bingo-Print/Makefile
parent1423ac796148ec15c594a386281290fcba7301b7 (diff)
downloadports-d1a1be32bb370b8a08f8f3e7d0b79dfcc3c83a38.tar.gz
ports-d1a1be32bb370b8a08f8f3e7d0b79dfcc3c83a38.zip
Add p5-Games-Bingo-Print 0.01,
games::Bingo::Print - PDF Generation Class. PR: 55815 Submitted by: Lars Thegler <lars@thegler.dk>
Notes
Notes: svn path=/head/; revision=88284
Diffstat (limited to 'games/p5-Games-Bingo-Print/Makefile')
-rw-r--r--games/p5-Games-Bingo-Print/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/p5-Games-Bingo-Print/Makefile b/games/p5-Games-Bingo-Print/Makefile
new file mode 100644
index 000000000000..495d4f81eb5c
--- /dev/null
+++ b/games/p5-Games-Bingo-Print/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Games-Bingo
+# Date created: 14. August 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-Bingo-Print
+PORTVERSION= 0.01
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Games::Bingo::Print - PDF Generation Class
+
+BUILD_DEPENDS= ${SITE_PERL}/Games/Bingo.pm:${PORTSDIR}/games/p5-Games-Bingo \
+ ${SITE_PERL}/PDFLib.pm:${PORTSDIR}/print/p5-PDFLib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Games::Bingo::Print.3 \
+ Games::Bingo::Print::Card.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing example for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingo_print.pl ${EXAMPLESDIR}
+.endif
+
+test:
+ @cd ${WRKSRC}; make test
+
+.include <bsd.port.mk>