aboutsummaryrefslogtreecommitdiff
path: root/games/p5-Games-Tournament-RoundRobin/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 08:30:09 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 08:30:09 +0000
commit7cc6a84f994bbcf0774b541d303eceb00ad74deb (patch)
tree0db69e772cabe62d6d62199290c310d7fa8c0b69 /games/p5-Games-Tournament-RoundRobin/Makefile
parent02ddb4a65ecd5c2ffd6fad65d49db859810da300 (diff)
downloadports-7cc6a84f994bbcf0774b541d303eceb00ad74deb.tar.gz
ports-7cc6a84f994bbcf0774b541d303eceb00ad74deb.zip
Adding port games/p5-Games-Tournament-RoundRobin, a pairing algorithm for Round Robin tournaments.
Submitted by: aaron Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=156260
Diffstat (limited to 'games/p5-Games-Tournament-RoundRobin/Makefile')
-rw-r--r--games/p5-Games-Tournament-RoundRobin/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/p5-Games-Tournament-RoundRobin/Makefile b/games/p5-Games-Tournament-RoundRobin/Makefile
new file mode 100644
index 000000000000..520d23e57350
--- /dev/null
+++ b/games/p5-Games-Tournament-RoundRobin/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Games-Tournament-RoundRobin
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-Tournament-RoundRobin
+PORTVERSION= 0.01
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Round-Robin Tournament Schedule Pairings
+
+MAN3= Games::Tournament::RoundRobin.3 \
+ Games::League::Member.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6
+.endif
+
+.include <bsd.port.post.mk>