aboutsummaryrefslogtreecommitdiff
path: root/games/pinball/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2015-12-27 16:04:35 +0000
committerThierry Thomas <thierry@FreeBSD.org>2015-12-27 16:04:35 +0000
commit1ed6285b3238759e11ddac7b48f029d5a76e754f (patch)
treeffba0a034b8b6570515c21768b08b0473346d250 /games/pinball/Makefile
parent41bacec2154eb09671d2d4e4b59bbb2ad2ef5f80 (diff)
downloadports-1ed6285b3238759e11ddac7b48f029d5a76e754f.tar.gz
ports-1ed6285b3238759e11ddac7b48f029d5a76e754f.zip
Modernize plist and fix highscore handling.
PR: ports/205629 Submitted by: amdmi3
Notes
Notes: svn path=/head/; revision=404579
Diffstat (limited to 'games/pinball/Makefile')
-rw-r--r--games/pinball/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 4ce171c507dc..c256e8639827 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pinball
PORTVERSION= 0.3.1
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -38,10 +38,17 @@ DOCS= README
# For gmake>=3.82
pre-configure:
- ${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
+ @${FIND} ${WRKSRC} -name Makefile.in -print | ${XARGS} \
${REINPLACE_CMD} -e 's,^dnl,# dnl,'
post-install:
+ @${MV} ${STAGEDIR}/var/games/pinball/professor/highscores \
+ ${STAGEDIR}/var/games/pinball/professor/highscores.sample
+ @${MV} ${STAGEDIR}/var/games/pinball/tux/highscores \
+ ${STAGEDIR}/var/games/pinball/tux/highscores.sample
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pinball/lib*.so*
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}