aboutsummaryrefslogtreecommitdiff
path: root/games/pingus
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-07 08:46:30 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2007-10-07 08:46:30 +0000
commit79a93d0231fbeab73d23e70ea8d9d214f1982b10 (patch)
treeb84198d98fdcd62a864a34ddcc1604dfa3a02f0d /games/pingus
parentbdcb9f0e58f826441a8e077b50812580898b5ae1 (diff)
downloadports-79a93d0231fbeab73d23e70ea8d9d214f1982b10.tar.gz
ports-79a93d0231fbeab73d23e70ea8d9d214f1982b10.zip
- Some mezz@ improvements
- Bump PORTREVISION - Remove pkg-message file Submitted by: mezz@ via email
Notes
Notes: svn path=/head/; revision=201036
Diffstat (limited to 'games/pingus')
-rw-r--r--games/pingus/Makefile9
-rw-r--r--games/pingus/files/patch-SConstruct21
-rw-r--r--games/pingus/files/pkg-message.in12
3 files changed, 24 insertions, 18 deletions
diff --git a/games/pingus/Makefile b/games/pingus/Makefile
index a8f98322e774..1dc55f00176a 100644
--- a/games/pingus/Makefile
+++ b/games/pingus/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pingus
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://pingus.seul.org/files/
@@ -23,7 +24,10 @@ USE_SCONS= yes
USE_SDL= sdl image mixer
PLIST= ${WRKDIR}/pkg-plist
-SUB_FILES= pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|add_path("data")|add_path("${DATADIR}")|g' \
+ ${WRKSRC}/src/pingus_main.cpp
pre-install:
@${RM} -f ${PLIST}
@@ -40,7 +44,4 @@ do-install:
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/games/pingus/files/patch-SConstruct b/games/pingus/files/patch-SConstruct
index 54bc2acce18c..e5b0ef18f932 100644
--- a/games/pingus/files/patch-SConstruct
+++ b/games/pingus/files/patch-SConstruct
@@ -1,5 +1,14 @@
---- SConstruct.orig 2007-10-05 10:46:32.000000000 -0500
-+++ SConstruct 2007-10-05 11:09:38.000000000 -0500
+--- SConstruct.orig 2007-09-22 10:46:31.000000000 -0500
++++ SConstruct 2007-10-07 01:15:19.000000000 -0500
+@@ -326,7 +326,7 @@
+ not (os.path.exists('config.py') and os.path.exists('config.h')) and \
+ not GetOption('clean'):
+ opts = DefineOptions(None, ARGUMENTS)
+- env = Environment(options = opts)
++ env = Environment(ENV = os.environ, options = opts)
+ Help(opts.GenerateHelpText(env))
+
+ opts.Update(env)
@@ -337,7 +337,9 @@
if os.environ.has_key('PKG_CONFIG_PATH'):
env['ENV']['PKG_CONFIG_PATH'] = os.environ['PKG_CONFIG_PATH']
@@ -11,3 +20,11 @@
config_h_defines = []
+@@ -406,7 +408,6 @@
+
+ config_h = open('config.h', 'w')
+ config_h.write('#define VERSION "0.7.1"\n')
+- config_h.write('#define ENABLE_BINRELOC 1\n')
+ config_h.write('#define ICONV_CONST\n') # FIXME: make a check for this
+ for (v,k) in config_h_defines:
+ config_h.write('#define %s %s\n' % (v, k))
diff --git a/games/pingus/files/pkg-message.in b/games/pingus/files/pkg-message.in
deleted file mode 100644
index dfb75ed5d2cf..000000000000
--- a/games/pingus/files/pkg-message.in
+++ /dev/null
@@ -1,12 +0,0 @@
-###############################################################################
-
-The Pingus game was installed
-
-1) Use the --datadir option to the correct path of pingus data
-
- # pingus --datadir %%DATADIR%%
-
-2) Enjoy it
-
-###############################################################################
-