aboutsummaryrefslogtreecommitdiff
path: root/games/pmars/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/pmars/Makefile
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/pmars/Makefile')
-rw-r--r--games/pmars/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/pmars/Makefile b/games/pmars/Makefile
index 3d2c064aa915..1ab72d959556 100644
--- a/games/pmars/Makefile
+++ b/games/pmars/Makefile
@@ -7,10 +7,9 @@
PORTNAME= pmars
PORTVERSION= 0.9.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= corewar
+MASTER_SITES= SF/corewar
MAINTAINER= alepulver@FreeBSD.org
COMMENT= A portable corewar system with ICWS'94 extensions
@@ -70,11 +69,11 @@ MAKE_ARGS+= CFLAGS+="-DSMALLMEM"
.endif
.if !defined(WITHOUT_X11)
-USE_XLIB= yes
+USE_XORG= x11
TARGETS+= x11
X11_ARGS+= CFLAGS+="-DXWINGRAPHX" \
- CFLAGS+="-I${X11BASE}/include" \
- LIB+="-L${X11BASE}/lib -lX11"
+ CFLAGS+="-I${LOCALBASE}/include" \
+ LIB+="-L${LOCALBASE}/lib -lX11"
PLIST_SUB+= X11=""
.else
PLIST_SUB+= X11="@comment "