aboutsummaryrefslogtreecommitdiff
path: root/games/pokerth
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-01-10 21:51:08 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-01-10 21:51:08 +0000
commitb962d46bbca3e7eea6dc52472497cefaf41b7438 (patch)
tree60d59958c6ec24b56a4283cfc88fcac28ebdd43c /games/pokerth
parent2e971ff4455092d4cf3713c3515690345b9cc799 (diff)
downloadports-b962d46bbca3e7eea6dc52472497cefaf41b7438.tar.gz
ports-b962d46bbca3e7eea6dc52472497cefaf41b7438.zip
Update to version 0.9
PR: ports/163952 Submitted by: maintainer, based on work by David Roffiaen
Notes
Notes: svn path=/head/; revision=288924
Diffstat (limited to 'games/pokerth')
-rw-r--r--games/pokerth/Makefile9
-rw-r--r--games/pokerth/distinfo4
-rw-r--r--games/pokerth/files/patch-src_engine_log.h10
-rw-r--r--games/pokerth/files/patch-src_net_common_ircthread.cpp11
-rw-r--r--games/pokerth/pkg-plist6
5 files changed, 33 insertions, 7 deletions
diff --git a/games/pokerth/Makefile b/games/pokerth/Makefile
index 751df6f4ae9c..58c2c3f42dc4 100644
--- a/games/pokerth/Makefile
+++ b/games/pokerth/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= pokerth
-PORTVERSION= 0.8.3
-PORTREVISION= 1
+PORTVERSION= 0.9
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.8
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.9
DISTNAME= PokerTH-${PORTVERSION}-src
MAINTAINER= mad@madpilot.net
@@ -22,7 +21,9 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
mikmod.2:${PORTSDIR}/audio/libmikmod \
gnutls.47:${PORTSDIR}/security/gnutls \
curl.6:${PORTSDIR}/ftp/curl \
- gsasl.15:${PORTSDIR}/security/gsasl
+ gsasl.15:${PORTSDIR}/security/gsasl \
+ tinyxml:${PORTSDIR}/textproc/tinyxml
+BUILD_DEPENDS= ${LOCALBASE}/include/libircclient.h:${PORTSDIR}/irc/libircclient
USE_ICONV= yes
USE_BZIP2= yes
diff --git a/games/pokerth/distinfo b/games/pokerth/distinfo
index fab164dde550..c9e1e508fb36 100644
--- a/games/pokerth/distinfo
+++ b/games/pokerth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PokerTH-0.8.3-src.tar.bz2) = ff68054753b87dc8713306a96b53108b2e485610086a28481f0fc3d7a365a02e
-SIZE (PokerTH-0.8.3-src.tar.bz2) = 7037418
+SHA256 (PokerTH-0.9-src.tar.bz2) = ce67b6969b83a3d752d1a9b2fddd13927e89a726d827ebbc23f76c4392006145
+SIZE (PokerTH-0.9-src.tar.bz2) = 8892387
diff --git a/games/pokerth/files/patch-src_engine_log.h b/games/pokerth/files/patch-src_engine_log.h
new file mode 100644
index 000000000000..a77074fbd19b
--- /dev/null
+++ b/games/pokerth/files/patch-src_engine_log.h
@@ -0,0 +1,10 @@
+--- src/engine/log.h.orig 2012-01-04 13:48:11.224976420 +0100
++++ src/engine/log.h 2012-01-04 14:01:30.113974000 +0100
+@@ -21,6 +21,7 @@
+
+ #include "engine_defs.h"
+ #include "game_defs.h"
++#include <string>
+
+ struct sqlite3;
+
diff --git a/games/pokerth/files/patch-src_net_common_ircthread.cpp b/games/pokerth/files/patch-src_net_common_ircthread.cpp
new file mode 100644
index 000000000000..7a2eca6b0f42
--- /dev/null
+++ b/games/pokerth/files/patch-src_net_common_ircthread.cpp
@@ -0,0 +1,11 @@
+--- src/net/common/ircthread.cpp.orig 2012-01-04 14:33:45.259685354 +0100
++++ src/net/common/ircthread.cpp 2012-01-04 14:32:53.601974192 +0100
+@@ -19,7 +19,7 @@
+ #include <net/socket_helper.h>
+ #include <net/ircthread.h>
+ #include <net/socket_msg.h>
+-#include <libircclient/libircclient.h>
++#include <libircclient.h>
+ #include <boost/algorithm/string/predicate.hpp>
+ #include <queue>
+ #include <sstream>
diff --git a/games/pokerth/pkg-plist b/games/pokerth/pkg-plist
index 86a40d052b9f..99f2ceb0a798 100644
--- a/games/pokerth/pkg-plist
+++ b/games/pokerth/pkg-plist
@@ -295,7 +295,7 @@ share/pixmaps/pokerth.png
%%DATADIR%%/data/gfx/gui/table/default/smallblindPuck.png
%%DATADIR%%/data/gfx/gui/table/default/table.png
%%DATADIR%%/data/gfx/gui/table/default/toolboxbg.png
-%%DATADIR%%/data/misc/gpl2.html
+%%DATADIR%%/data/misc/agpl.html
%%DATADIR%%/data/sounds/default/allin.wav
%%DATADIR%%/data/sounds/default/bet.wav
%%DATADIR%%/data/sounds/default/call.wav
@@ -307,6 +307,9 @@ share/pixmaps/pokerth.png
%%DATADIR%%/data/sounds/default/playerconnected.wav
%%DATADIR%%/data/sounds/default/raise.wav
%%DATADIR%%/data/sounds/default/yourturn.wav
+%%DATADIR%%/data/sounds/default/blinds_raises_level1.wav
+%%DATADIR%%/data/sounds/default/blinds_raises_level2.wav
+%%DATADIR%%/data/sounds/default/blinds_raises_level3.wav
%%DATADIR%%/data/translations/pokerth_af.qm
%%DATADIR%%/data/translations/pokerth_bg.qm
%%DATADIR%%/data/translations/pokerth_ca.qm
@@ -330,6 +333,7 @@ share/pixmaps/pokerth.png
%%DATADIR%%/data/translations/pokerth_sv.qm
%%DATADIR%%/data/translations/pokerth_ta.qm
%%DATADIR%%/data/translations/pokerth_tr.qm
+%%DATADIR%%/data/translations/pokerth_jp.qm
%%DATADIR%%/data/translations/pokerth_zhcn.qm
%%DATADIR%%/data/translations/qt_de.qm
%%DATADIR%%/data/translations/qt_es.qm