aboutsummaryrefslogtreecommitdiff
path: root/games/puckman
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-12-31 18:18:06 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-12-31 18:18:06 +0000
commit8b4a45dbae4a08068762efd7aa1dbf6f44d70c85 (patch)
tree0e1b9a417aa5514c88234b376eca8d138fa41bb5 /games/puckman
parent625cdd1b6d77f436eb99ff10f4419edbddc66118 (diff)
downloadports-8b4a45dbae4a08068762efd7aa1dbf6f44d70c85.tar.gz
ports-8b4a45dbae4a08068762efd7aa1dbf6f44d70c85.zip
- Change Makefile header
- Bump PORTREVISION - Change master sites, icon, use GitHub=yes - Remove leading article from COMMENT - USES gmake instead of USE_GMAKE - Use pkg-plist instead of PLIST_FILES and PORTDATA - Support STAGEDIR - Add DOCS Option - Add Desktop entry file - Use REINPLACE_CMD instead of simple patches - Break lines around 80 characters - Simplify Makefile - Remove obsolete patches Approved by: pawel / wg (mentors, implicit)
Notes
Notes: svn path=/head/; revision=338332
Diffstat (limited to 'games/puckman')
-rw-r--r--games/puckman/Makefile56
-rw-r--r--games/puckman/distinfo6
-rw-r--r--games/puckman/files/patch-Makefile24
-rw-r--r--games/puckman/files/patch-puckman.c11
-rw-r--r--games/puckman/pkg-plist194
5 files changed, 228 insertions, 63 deletions
diff --git a/games/puckman/Makefile b/games/puckman/Makefile
index 983749f02c5f..8d96c31a9001 100644
--- a/games/puckman/Makefile
+++ b/games/puckman/Makefile
@@ -1,49 +1,53 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= puckman
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= https://github.com/downloads/patapizza/puckman/
+MASTER_SITES= SF/nemysisfreebsdp/${CATEGORIES}/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@FreeBSD.org
-COMMENT= An unofficial clone of the original Pac-Man game
+COMMENT= Unofficial clone of the original Pac-Man game
LICENSE= GPLv3
-FETCH_ARGS?= -Fpr
-USE_GMAKE= yes
-USE_SDL= sdl image gfx
+USE_GITHUB= yes
+GH_ACCOUNT= patapizza
+GH_PROJECT= puckman
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= f5b809c
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png
+USES= gmake
+USE_SDL= sdl image gfx
-PORTDATA= *
PORTDOCS= README.md
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
+
+DESKTOP_ENTRIES="Puck-Man" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' \
+ ${WRKSRC}/puckman.c
do-build:
cd ${WRKSRC} && ${CC} -o ${PORTNAME} ${CFLAGS} \
-DDATA_PREFIX=\"${DATADIR}/\" \
- -lm `${SDL_CONFIG} --cflags --libs` -lSDL -lSDL_image -lSDL_gfx -lm puckman.c
+ -lm `${SDL_CONFIG} --cflags --libs` -lSDL -lSDL_image \
+ -lSDL_gfx -lm puckman.c
do-install:
-# Executable
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
-# Data
- ${MKDIR} ${DATADIR}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} images ${DATADIR})
-
-# Pixmaps
- ${INSTALL_DATA} ${WRKSRC}/images/logo.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} images ${STAGEDIR}${DATADIR})
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-# Documentation
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.md ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/puckman/distinfo b/games/puckman/distinfo
index e492ce1a04cc..ef49f362bc01 100644
--- a/games/puckman/distinfo
+++ b/games/puckman/distinfo
@@ -1,2 +1,4 @@
-SHA256 (puckman-1.0.tar.gz) = 842919da45c77de4c77f66f11dde9f189b1d0d764f2ba76f5b93ee3288e967b2
-SIZE (puckman-1.0.tar.gz) = 210385
+SHA256 (puckman-1.0.tar.gz) = 995e90845993600ed6693f4a857cf6b0d6e9dc431ccea35c6b9243830f73e86a
+SIZE (puckman-1.0.tar.gz) = 191432
+SHA256 (puckman.png) = d00633d0b1e426d79fde35bed4aa67f7540b0e46cd5641287537d89464903d3f
+SIZE (puckman.png) = 695
diff --git a/games/puckman/files/patch-Makefile b/games/puckman/files/patch-Makefile
deleted file mode 100644
index 2e2c2ddb9936..000000000000
--- a/games/puckman/files/patch-Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
---- Makefile.orig 2012-08-16 19:32:29.000000000 +0200
-+++ Makefile 2012-08-16 20:12:01.000000000 +0200
-@@ -1,10 +1,10 @@
--BIN = $(DESTDIR)/usr/bin
--ICONS = $(DESTDIR)/usr/share/puckman/images
--ICON = $(DESTDIR)/usr/share/pixmaps
--SYMICON = $(DESTDIR)/usr/share/icons/hicolor/48x48/apps
-+BIN = $(DESTDIR)/usr/local/bin
-+ICONS = $(DESTDIR)/usr/local/share/puckman/images
-+ICON = $(DESTDIR)/usr/local/share/pixmaps
-+SYMICON = $(DESTDIR)/usr/local/share/icons/hicolor/48x48/apps
- SHELL = /bin/sh
- CC = g++
--prefix = /usr
-+prefix = /usr/local
- includedir = $(prefix)/include
- pacdir = ~/.puckman
- puckman: puckman.c
-@@ -23,4 +23,4 @@
-
- uninstall:
- rm -vr $(ICONS) $(BIN)/puckman $(ICON)/puckman.png $(SYMICON)/puckman.png
-- if test -e $(DESTDIR)/usr/share/applications/puckman.desktop; then rm -v $(DESTDIR)/usr/share/applications/puckman.desktop; fi
-+ if test -e $(DESTDIR)/usr/local/share/applications/puckman.desktop; then rm -v $(DESTDIR)/usr/local/share/applications/puckman.desktop; fi
diff --git a/games/puckman/files/patch-puckman.c b/games/puckman/files/patch-puckman.c
deleted file mode 100644
index 243cdb6ec7ca..000000000000
--- a/games/puckman/files/patch-puckman.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- puckman.c.orig 2012-08-16 19:32:29.000000000 +0200
-+++ puckman.c 2012-08-16 20:11:00.000000000 +0200
-@@ -29,7 +29,7 @@
- #include <SDL_image.h>
- #include <SDL_gfxPrimitives.h>
-
--#define PACPATH "/usr/share/puckman/"
-+#define PACPATH "/usr/local/share/puckman/"
- #define SCREEN_WIDTH 461
- #define SCREEN_HEIGHT 580
- #define RIGHT 0
diff --git a/games/puckman/pkg-plist b/games/puckman/pkg-plist
new file mode 100644
index 000000000000..035419a0fef4
--- /dev/null
+++ b/games/puckman/pkg-plist
@@ -0,0 +1,194 @@
+bin/puckman
+share/pixmaps/puckman.png
+%%DATADIR%%/images/0.png
+%%DATADIR%%/images/1.png
+%%DATADIR%%/images/100.png
+%%DATADIR%%/images/1600.png
+%%DATADIR%%/images/2.png
+%%DATADIR%%/images/200.png
+%%DATADIR%%/images/3.png
+%%DATADIR%%/images/300.png
+%%DATADIR%%/images/4.png
+%%DATADIR%%/images/400.png
+%%DATADIR%%/images/5.png
+%%DATADIR%%/images/500.png
+%%DATADIR%%/images/6.png
+%%DATADIR%%/images/7.png
+%%DATADIR%%/images/700.png
+%%DATADIR%%/images/8.png
+%%DATADIR%%/images/800.png
+%%DATADIR%%/images/9.png
+%%DATADIR%%/images/anim.gif
+%%DATADIR%%/images/anim0.gif
+%%DATADIR%%/images/anim1.gif
+%%DATADIR%%/images/anim10.gif
+%%DATADIR%%/images/anim11.gif
+%%DATADIR%%/images/anim12.gif
+%%DATADIR%%/images/anim13.gif
+%%DATADIR%%/images/anim14.gif
+%%DATADIR%%/images/anim15.gif
+%%DATADIR%%/images/anim16.gif
+%%DATADIR%%/images/anim17.gif
+%%DATADIR%%/images/anim18.gif
+%%DATADIR%%/images/anim19.gif
+%%DATADIR%%/images/anim2.gif
+%%DATADIR%%/images/anim20.gif
+%%DATADIR%%/images/anim21.gif
+%%DATADIR%%/images/anim22.gif
+%%DATADIR%%/images/anim23.gif
+%%DATADIR%%/images/anim24.gif
+%%DATADIR%%/images/anim25.gif
+%%DATADIR%%/images/anim26.gif
+%%DATADIR%%/images/anim27.gif
+%%DATADIR%%/images/anim28.gif
+%%DATADIR%%/images/anim29.gif
+%%DATADIR%%/images/anim3.gif
+%%DATADIR%%/images/anim30.gif
+%%DATADIR%%/images/anim31.gif
+%%DATADIR%%/images/anim32.gif
+%%DATADIR%%/images/anim33.gif
+%%DATADIR%%/images/anim34.gif
+%%DATADIR%%/images/anim35.gif
+%%DATADIR%%/images/anim36.gif
+%%DATADIR%%/images/anim37.gif
+%%DATADIR%%/images/anim38.gif
+%%DATADIR%%/images/anim4.gif
+%%DATADIR%%/images/anim5.gif
+%%DATADIR%%/images/anim6.gif
+%%DATADIR%%/images/anim7.gif
+%%DATADIR%%/images/anim8.gif
+%%DATADIR%%/images/anim9.gif
+%%DATADIR%%/images/back.png
+%%DATADIR%%/images/candy0.gif
+%%DATADIR%%/images/candy1.gif
+%%DATADIR%%/images/candy2.gif
+%%DATADIR%%/images/candy3.gif
+%%DATADIR%%/images/candy4.gif
+%%DATADIR%%/images/candy5.gif
+%%DATADIR%%/images/dead0.gif
+%%DATADIR%%/images/dead1.gif
+%%DATADIR%%/images/dead10.gif
+%%DATADIR%%/images/dead11.gif
+%%DATADIR%%/images/dead2.gif
+%%DATADIR%%/images/dead3.gif
+%%DATADIR%%/images/dead4.gif
+%%DATADIR%%/images/dead5.gif
+%%DATADIR%%/images/dead6.gif
+%%DATADIR%%/images/dead7.gif
+%%DATADIR%%/images/dead8.gif
+%%DATADIR%%/images/dead9.gif
+%%DATADIR%%/images/dot.png
+%%DATADIR%%/images/enter.png
+%%DATADIR%%/images/eyes0.png
+%%DATADIR%%/images/eyes1.png
+%%DATADIR%%/images/eyes2.png
+%%DATADIR%%/images/eyes3.png
+%%DATADIR%%/images/fruit0.png
+%%DATADIR%%/images/fruit1.png
+%%DATADIR%%/images/fruit2.png
+%%DATADIR%%/images/fruit3.png
+%%DATADIR%%/images/gameover.png
+%%DATADIR%%/images/getready.png
+%%DATADIR%%/images/ghost000.gif
+%%DATADIR%%/images/ghost001.gif
+%%DATADIR%%/images/ghost010.gif
+%%DATADIR%%/images/ghost011.gif
+%%DATADIR%%/images/ghost020.gif
+%%DATADIR%%/images/ghost021.gif
+%%DATADIR%%/images/ghost030.gif
+%%DATADIR%%/images/ghost031.gif
+%%DATADIR%%/images/ghost100.gif
+%%DATADIR%%/images/ghost101.gif
+%%DATADIR%%/images/ghost110.gif
+%%DATADIR%%/images/ghost111.gif
+%%DATADIR%%/images/ghost120.gif
+%%DATADIR%%/images/ghost121.gif
+%%DATADIR%%/images/ghost130.gif
+%%DATADIR%%/images/ghost131.gif
+%%DATADIR%%/images/ghost200.gif
+%%DATADIR%%/images/ghost201.gif
+%%DATADIR%%/images/ghost210.gif
+%%DATADIR%%/images/ghost211.gif
+%%DATADIR%%/images/ghost220.gif
+%%DATADIR%%/images/ghost221.gif
+%%DATADIR%%/images/ghost230.gif
+%%DATADIR%%/images/ghost231.gif
+%%DATADIR%%/images/ghost300.gif
+%%DATADIR%%/images/ghost301.gif
+%%DATADIR%%/images/ghost310.gif
+%%DATADIR%%/images/ghost311.gif
+%%DATADIR%%/images/ghost320.gif
+%%DATADIR%%/images/ghost321.gif
+%%DATADIR%%/images/ghost330.gif
+%%DATADIR%%/images/ghost331.gif
+%%DATADIR%%/images/highscores0.png
+%%DATADIR%%/images/highscores1.png
+%%DATADIR%%/images/legal.png
+%%DATADIR%%/images/letter65.png
+%%DATADIR%%/images/letter66.png
+%%DATADIR%%/images/letter67.png
+%%DATADIR%%/images/letter68.png
+%%DATADIR%%/images/letter69.png
+%%DATADIR%%/images/letter70.png
+%%DATADIR%%/images/letter71.png
+%%DATADIR%%/images/letter72.png
+%%DATADIR%%/images/letter73.png
+%%DATADIR%%/images/letter74.png
+%%DATADIR%%/images/letter75.png
+%%DATADIR%%/images/letter76.png
+%%DATADIR%%/images/letter77.png
+%%DATADIR%%/images/letter78.png
+%%DATADIR%%/images/letter79.png
+%%DATADIR%%/images/letter80.png
+%%DATADIR%%/images/letter81.png
+%%DATADIR%%/images/letter82.png
+%%DATADIR%%/images/letter83.png
+%%DATADIR%%/images/letter84.png
+%%DATADIR%%/images/letter85.png
+%%DATADIR%%/images/letter86.png
+%%DATADIR%%/images/letter87.png
+%%DATADIR%%/images/letter88.png
+%%DATADIR%%/images/letter89.png
+%%DATADIR%%/images/letter90.png
+%%DATADIR%%/images/level.png
+%%DATADIR%%/images/lives.png
+%%DATADIR%%/images/logo.png
+%%DATADIR%%/images/notice.png
+%%DATADIR%%/images/pacman00.gif
+%%DATADIR%%/images/pacman01.gif
+%%DATADIR%%/images/pacman02.gif
+%%DATADIR%%/images/pacman03.gif
+%%DATADIR%%/images/pacman10.gif
+%%DATADIR%%/images/pacman11.gif
+%%DATADIR%%/images/pacman12.gif
+%%DATADIR%%/images/pacman13.gif
+%%DATADIR%%/images/pacman20.gif
+%%DATADIR%%/images/pacman21.gif
+%%DATADIR%%/images/pacman22.gif
+%%DATADIR%%/images/pacman23.gif
+%%DATADIR%%/images/pacman30.gif
+%%DATADIR%%/images/pacman31.gif
+%%DATADIR%%/images/pacman32.gif
+%%DATADIR%%/images/pacman33.gif
+%%DATADIR%%/images/paused.png
+%%DATADIR%%/images/playgame0.png
+%%DATADIR%%/images/playgame1.png
+%%DATADIR%%/images/puckman.png
+%%DATADIR%%/images/quitgame0.png
+%%DATADIR%%/images/quitgame1.png
+%%DATADIR%%/images/rules.png
+%%DATADIR%%/images/rules0.png
+%%DATADIR%%/images/rules1.png
+%%DATADIR%%/images/scared00.gif
+%%DATADIR%%/images/scared01.gif
+%%DATADIR%%/images/scared10.gif
+%%DATADIR%%/images/scared11.gif
+%%DATADIR%%/images/scared12.gif
+%%DATADIR%%/images/scared13.gif
+%%DATADIR%%/images/scared14.gif
+%%DATADIR%%/images/scared15.gif
+%%DATADIR%%/images/scared16.gif
+%%DATADIR%%/images/scared17.gif
+%%DATADIR%%/images/score.png
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%