aboutsummaryrefslogtreecommitdiff
path: root/games/pvpgn
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-04 12:18:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-04 12:18:18 +0000
commit6acd6844db613b90a089b40cc1c882d4bceaf35b (patch)
treebedf62dc84f317a82e0b744125099d90a8a2338e /games/pvpgn
parentb98c462e47438d13a33073d0ad685272d406cf16 (diff)
downloadports-6acd6844db613b90a089b40cc1c882d4bceaf35b.tar.gz
ports-6acd6844db613b90a089b40cc1c882d4bceaf35b.zip
- Update to 1.7.8
- Provide option to disable Diablo II server PR: ports/85584 Submitted by: Max E. Kuznecov <mek@mek.uz.ua> (maintainer)
Notes
Notes: svn path=/head/; revision=141892
Diffstat (limited to 'games/pvpgn')
-rw-r--r--games/pvpgn/Makefile12
-rw-r--r--games/pvpgn/distinfo4
-rw-r--r--games/pvpgn/pkg-install11
-rw-r--r--games/pvpgn/pkg-plist10
4 files changed, 28 insertions, 9 deletions
diff --git a/games/pvpgn/Makefile b/games/pvpgn/Makefile
index a2bd4a015039..18cba516c91e 100644
--- a/games/pvpgn/Makefile
+++ b/games/pvpgn/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pvpgn
-PORTVERSION= 1.7.7
+PORTVERSION= 1.7.8
CATEGORIES= games
MASTER_SITES= http://download.berlios.de/pvpgn/
DISTFILES= ${EXTRACT_ONLY} pvpgn-support-1.0.tar.gz
@@ -43,7 +43,8 @@ MAN5= bnetd.conf.5 bntext.5
OPTIONS= MYSQL "Include MySQL user accounts support" off \
PGSQL "Include PostgreSQL user accounts support" off \
- SQLITE3 "Include SQLite3 user accounts support" off
+ SQLITE3 "Include SQLite3 user accounts support" off \
+ D2 "Enable Diablo II server (D2CS/D2DBS)" on
.include <bsd.port.pre.mk>
@@ -62,6 +63,13 @@ CONFIGURE_ARGS+=--with-sqlite3
LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
.endif
+.if defined(WITHOUT_D2)
+CONFIGURE_ARGS+= --disable-d2cs --disable-d2dbs
+PLIST_SUB+= WITH_D2="@comment "
+.else
+PLIST_SUB+= WITH_D2=""
+.endif
+
## support files
SUPPORT_SUFFX= .tar.gz
diff --git a/games/pvpgn/distinfo b/games/pvpgn/distinfo
index ce5516aab90d..58d42feb0a8a 100644
--- a/games/pvpgn/distinfo
+++ b/games/pvpgn/distinfo
@@ -1,4 +1,4 @@
-MD5 (pvpgn/pvpgn-1.7.7.tar.bz2) = 465e18b04ca903eca7e2973a2d557e46
-SIZE (pvpgn/pvpgn-1.7.7.tar.bz2) = 983639
+MD5 (pvpgn/pvpgn-1.7.8.tar.bz2) = b3f4e2328ba3e9bde53ddabf444aa130
+SIZE (pvpgn/pvpgn-1.7.8.tar.bz2) = 987125
MD5 (pvpgn/pvpgn-support-1.0.tar.gz) = 8ba36144ea3a7efe200536c142bb7886
SIZE (pvpgn/pvpgn-support-1.0.tar.gz) = 126047
diff --git a/games/pvpgn/pkg-install b/games/pvpgn/pkg-install
index a3dba675756d..bf224c91c38c 100644
--- a/games/pvpgn/pkg-install
+++ b/games/pvpgn/pkg-install
@@ -11,6 +11,8 @@ POST-INSTALL)
HOME_DIR=/nonexistent
LOGDIR=/var/log/pvpgn
PIDDIR=/var/run/pvpgn
+ PKGNAME=$1
+ PVPGN_CONFDIR=${PKG_PREFIX:-/usr/local}/etc/pvpgn
if pw group show "${GROUP}" 2>/dev/null; then
echo "You already have a group \"${GROUP}\", so I will use it."
@@ -53,6 +55,15 @@ POST-INSTALL)
chown -R ${USER}:${GROUP} %%PVPGN_DIR%%
mkdir -m 750 ${LOGDIR} ${PIDDIR} 2> /dev/null
chown -R ${USER}:${GROUP} ${LOGDIR} ${PIDDIR}
+
+ echo "===> Post-installation informations for ${PKGNAME}"
+ echo ""
+ echo " o You can find the configuration files for this"
+ echo " package in the directory ${PVPGN_CONFDIR}."
+ echo " Please note, that the files were installed as *.conf-sample"
+ echo " In order to run server, you must rename them."
+ echo ""
+
exit 0
;;
esac
diff --git a/games/pvpgn/pkg-plist b/games/pvpgn/pkg-plist
index 24a0f5fd472c..ae52a8a0ef01 100644
--- a/games/pvpgn/pkg-plist
+++ b/games/pvpgn/pkg-plist
@@ -31,9 +31,9 @@ etc/pvpgn/bnxpcalc.conf-sample
etc/pvpgn/bnxplevel.conf-sample
etc/pvpgn/channel.conf-sample
etc/pvpgn/command_groups.conf-sample
-etc/pvpgn/d2cs.conf-sample
-etc/pvpgn/d2dbs.conf-sample
-etc/pvpgn/d2server.ini-sample
+%%WITH_D2%%etc/pvpgn/d2cs.conf-sample
+%%WITH_D2%%etc/pvpgn/d2dbs.conf-sample
+%%WITH_D2%%etc/pvpgn/d2server.ini-sample
etc/pvpgn/news.txt-sample
etc/pvpgn/realm.conf-sample
etc/pvpgn/sql_DB_layout.conf-sample
@@ -44,8 +44,8 @@ etc/pvpgn/versioncheck.conf-sample
etc/rc.d/bnetd%%RC_SUFX%%
sbin/bnetd
sbin/bntrackd
-sbin/d2cs
-sbin/d2dbs
+%%WITH_D2%%sbin/d2cs
+%%WITH_D2%%sbin/d2dbs
%%DATADIR%%/files/IX86ver1.mpq
%%DATADIR%%/files/PMACver1.mpq
%%DATADIR%%/files/WAR3IX86.mpq