aboutsummaryrefslogtreecommitdiff
path: root/games/pythoong
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-05 07:10:50 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-10-05 07:10:50 +0000
commitb7bdcd418e7aca3dd98409e16a4c4ae9bc289d02 (patch)
tree1b4ff069c830fd60b78ef9613fa9aa5abef69f83 /games/pythoong
parentbebd89314e57ff34ea47724c5605a0f32c425dcf (diff)
downloadports-b7bdcd418e7aca3dd98409e16a4c4ae9bc289d02.tar.gz
ports-b7bdcd418e7aca3dd98409e16a4c4ae9bc289d02.zip
Implement USE_GNOME, part 1.
Notes
Notes: svn path=/head/; revision=33428
Diffstat (limited to 'games/pythoong')
-rw-r--r--games/pythoong/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/games/pythoong/Makefile b/games/pythoong/Makefile
index bc4b6086ab90..97488dbad7a8 100644
--- a/games/pythoong/Makefile
+++ b/games/pythoong/Makefile
@@ -13,28 +13,21 @@ MASTER_SITES= http://perso.wanadoo.fr/christophe.cressend/tarballs/
MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= xbmtopbm:${PORTSDIR}/graphics/netpbm
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
-RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GNOME= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
-CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
- GTK_CONFIG="${GTK_CONFIG}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-post-extract:
+pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/pixmaps|\$\(datadir\)/gnome/pixmaps|g ; \
- s|\$\(localstatedir\)/games|\$\(datadir\)/gnome/games|g'
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>