aboutsummaryrefslogtreecommitdiff
path: root/games/qgo
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-13 06:57:45 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-13 06:57:45 +0000
commit198345a8b8dc7cef33dc2de22a12ec5517c9592e (patch)
tree67186d2787f4fc6da5104f427ff533ea7926760f /games/qgo
parent11ec8fb1bce08b2a69c4cf0c2b8e4966d5d0f0ce (diff)
downloadports-198345a8b8dc7cef33dc2de22a12ec5517c9592e.tar.gz
ports-198345a8b8dc7cef33dc2de22a12ec5517c9592e.zip
add qgo 0.0.8
A Go board and SGF editor written with the Qt library
Notes
Notes: svn path=/head/; revision=57650
Diffstat (limited to 'games/qgo')
-rw-r--r--games/qgo/Makefile29
-rw-r--r--games/qgo/distinfo1
-rw-r--r--games/qgo/files/patch-src:main.cpp41
-rw-r--r--games/qgo/pkg-comment1
-rw-r--r--games/qgo/pkg-descr5
-rw-r--r--games/qgo/pkg-plist25
6 files changed, 102 insertions, 0 deletions
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
new file mode 100644
index 000000000000..3b345f8c5b9e
--- /dev/null
+++ b/games/qgo/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: qgo
+# Date created: Mar 22, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= qgo
+PORTVERSION= 0.0.8
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_QT_VER= 2
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= QTDIR=${X11BASE} LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,qt.so,qt2.so,g ; \
+ s,/moc,/moc2,g" ${WRKSRC}/configure
+ @${PERL} -pi -e "s,-lqt,-lqt2,g" ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/games/qgo/distinfo b/games/qgo/distinfo
new file mode 100644
index 000000000000..81d3f1752067
--- /dev/null
+++ b/games/qgo/distinfo
@@ -0,0 +1 @@
+MD5 (qgo-0.0.8.tar.gz) = 8e46106c3d537ac6891291c39e0e755c
diff --git a/games/qgo/files/patch-src:main.cpp b/games/qgo/files/patch-src:main.cpp
new file mode 100644
index 000000000000..36ec0ba33e41
--- /dev/null
+++ b/games/qgo/files/patch-src:main.cpp
@@ -0,0 +1,41 @@
+--- src/main.cpp.orig Sat Apr 13 14:35:57 2002
++++ src/main.cpp Sat Apr 13 14:37:01 2002
+@@ -30,8 +30,10 @@
+ #include <qtextcodec.h>
+
+ #ifdef _WS_X11_
++#ifndef __FreeBSD__
+ #include <getopt.h>
+ #endif
++#endif
+
+ #ifdef _WS_WIN_
+ #include <windows.h>
+@@ -46,6 +48,7 @@
+ #endif
+
+ #ifdef _WS_X11_
++#ifndef __FreeBSD__
+ static struct option const long_options[] =
+ {
+ {"help", no_argument, 0, 'h'},
+@@ -91,6 +94,7 @@
+ return optind;
+ }
+ #endif
++#endif
+
+ #ifdef _WS_WIN_
+ /*
+@@ -134,7 +138,11 @@
+ int main( int argc, char **argv )
+ {
+ #ifdef _WS_X11_
++#ifndef __FreeBSD__
+ int i = decode_switches (argc, argv);
++#else
++ int i=1;
++#endif
+ #else
+ int i=1;
+ #endif
diff --git a/games/qgo/pkg-comment b/games/qgo/pkg-comment
new file mode 100644
index 000000000000..6a9e563e4ddf
--- /dev/null
+++ b/games/qgo/pkg-comment
@@ -0,0 +1 @@
+A Go board and SGF editor written with the Qt library
diff --git a/games/qgo/pkg-descr b/games/qgo/pkg-descr
new file mode 100644
index 000000000000..c470f44e6d77
--- /dev/null
+++ b/games/qgo/pkg-descr
@@ -0,0 +1,5 @@
+qGo is a Go board and full featured SGF editor written with the Qt library,
+available for Linux and Windows. Go is an ancient boardgame, very common in
+Japan, China and Korea.
+
+WWW: http://qgo.sourceforge.net/
diff --git a/games/qgo/pkg-plist b/games/qgo/pkg-plist
new file mode 100644
index 000000000000..3fe11613fd32
--- /dev/null
+++ b/games/qgo/pkg-plist
@@ -0,0 +1,25 @@
+bin/qgo
+share/qgo/sounds/stone.au
+share/qgo/sounds/stone.wav
+share/qgo/translations/qgo_de.qm
+@dirrm share/qgo/sounds
+@dirrm share/qgo/translations
+@dirrm share/qgo
+share/doc/qgo/html/images/note.png
+share/doc/qgo/html/images/tip.png
+share/doc/qgo/html/images/warning.png
+share/doc/qgo/html/ch01.html
+share/doc/qgo/html/ch01s04.html
+share/doc/qgo/html/ch02.html
+share/doc/qgo/html/ch02s02.html
+share/doc/qgo/html/ch02s03.html
+share/doc/qgo/html/ch03.html
+share/doc/qgo/html/ch03s02.html
+share/doc/qgo/html/ch03s23.html
+share/doc/qgo/html/ch03s28.html
+share/doc/qgo/html/ch03s31.html
+share/doc/qgo/html/index.html
+share/doc/qgo/html/pr01.html
+@dirrm share/doc/qgo/html/images
+@dirrm share/doc/qgo/html
+@dirrm share/doc/qgo