aboutsummaryrefslogtreecommitdiff
path: root/games/qtads
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-02-22 16:03:46 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-02-22 16:03:46 +0000
commit1571ecba78270888d3234daad047ecbde43dcf8e (patch)
tree081bab1ff381ec1df3a83e22aeeb86541e722036 /games/qtads
parent44fadad99d898e0f5962f8e5567e8018f0433f03 (diff)
downloadports-1571ecba78270888d3234daad047ecbde43dcf8e.tar.gz
ports-1571ecba78270888d3234daad047ecbde43dcf8e.zip
QTads is a cross-platform, multimedia interpreter for Tads games,
compatible with HTML TADS. Both Tads versions in use today (Tads 2 and Tads 3) are supported. WWW: http://qtads.sourceforge.net/ PR: ports/175863 Submitted by: Kai Wang <kaiwang27@gmail.com>
Notes
Notes: svn path=/head/; revision=312775
Diffstat (limited to 'games/qtads')
-rw-r--r--games/qtads/Makefile28
-rw-r--r--games/qtads/distinfo2
-rw-r--r--games/qtads/files/patch-src-osqt.h12
-rw-r--r--games/qtads/pkg-descr5
4 files changed, 47 insertions, 0 deletions
diff --git a/games/qtads/Makefile b/games/qtads/Makefile
new file mode 100644
index 000000000000..7b86b6cd6f88
--- /dev/null
+++ b/games/qtads/Makefile
@@ -0,0 +1,28 @@
+# Created by: Kai Wang <kaiwang27@gmail.com>
+# $FreeBSD$
+
+PORTNAME= qtads
+PORTVERSION= 2.1.6
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-2.x/${PORTVERSION}
+
+MAINTAINER= kaiwang27@gmail.com
+COMMENT= Cross-platform multimedia interpreter for TADS games
+
+LICENSE= GPLv2
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_QT4= gui moc_build network qmake_build rcc_build uic_build
+USE_SDL= sdl mixer sound
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/qtads
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKE_ARGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/qtads/distinfo b/games/qtads/distinfo
new file mode 100644
index 000000000000..fc22f0180bdd
--- /dev/null
+++ b/games/qtads/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qtads-2.1.6.tar.bz2) = 33f29b4c1b225f1a1e7ad1405a1bb7eb8ec4b1d567eac48a120071f7793373c8
+SIZE (qtads-2.1.6.tar.bz2) = 2523761
diff --git a/games/qtads/files/patch-src-osqt.h b/games/qtads/files/patch-src-osqt.h
new file mode 100644
index 000000000000..3009a5ed56a0
--- /dev/null
+++ b/games/qtads/files/patch-src-osqt.h
@@ -0,0 +1,12 @@
+--- src/osqt.h.orig 2013-02-05 12:40:00.000000000 +0100
++++ src/osqt.h 2013-02-05 12:40:26.000000000 +0100
+@@ -35,6 +35,9 @@
+ #endif
+ #endif
+
++/* FreeBSD doesn't have ulong defined. */
++#undef OS_ULONG_DEFINED
++
+ #define OSNOUI_OMIT_OS_FPRINTZ
+ #define OSNOUI_OMIT_OS_FPRINT
+ #define OSNOUI_OMIT_OS_CVT_URL_DIR
diff --git a/games/qtads/pkg-descr b/games/qtads/pkg-descr
new file mode 100644
index 000000000000..1c7231cb94ef
--- /dev/null
+++ b/games/qtads/pkg-descr
@@ -0,0 +1,5 @@
+QTads is a cross-platform, multimedia interpreter for Tads games,
+compatible with HTML TADS. Both Tads versions in use today (Tads 2 and
+Tads 3) are supported.
+
+WWW: http://qtads.sourceforge.net/