aboutsummaryrefslogtreecommitdiff
path: root/games/quake2-psychomod
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-01-10 22:22:30 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-01-10 22:22:30 +0000
commitaa3e03a8dd18093904289ee2ad2e266160dcc655 (patch)
treee43ded7937d52baae622d1fd2407fad4655cca8a /games/quake2-psychomod
parentc43b31a89f1357ba1756ac1926a328f17406b7b1 (diff)
downloadports-aa3e03a8dd18093904289ee2ad2e266160dcc655.tar.gz
ports-aa3e03a8dd18093904289ee2ad2e266160dcc655.zip
- Fix building with GCC 4.x.
Reported by: pointyhat
Notes
Notes: svn path=/head/; revision=182028
Diffstat (limited to 'games/quake2-psychomod')
-rw-r--r--games/quake2-psychomod/files/patch-src__Makefile2
-rw-r--r--games/quake2-psychomod/files/patch-src__g_items.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/games/quake2-psychomod/files/patch-src__Makefile b/games/quake2-psychomod/files/patch-src__Makefile
index 3c8b681b5196..db762dd27e91 100644
--- a/games/quake2-psychomod/files/patch-src__Makefile
+++ b/games/quake2-psychomod/files/patch-src__Makefile
@@ -1,5 +1,5 @@
--- ./src/Makefile.orig Wed Feb 1 20:46:55 2006
-+++ ./src/Makefile Sun Dec 24 16:23:24 2006
++++ ./src/Makefile Wed Jan 10 19:11:16 2007
@@ -16,20 +16,10 @@
# this nice line comes from the linux kernel makefile
ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/alpha/axp/)
diff --git a/games/quake2-psychomod/files/patch-src__g_items.c b/games/quake2-psychomod/files/patch-src__g_items.c
new file mode 100644
index 000000000000..db547b75a80c
--- /dev/null
+++ b/games/quake2-psychomod/files/patch-src__g_items.c
@@ -0,0 +1,15 @@
+--- ./src/g_items.c.orig Wed Oct 10 12:53:12 2001
++++ ./src/g_items.c Wed Jan 10 19:11:41 2007
+@@ -21,9 +21,9 @@
+ gitem_armor_t combatarmor_info = { 50, 100, .60, .30, ARMOR_COMBAT};
+ gitem_armor_t bodyarmor_info = {100, 200, .80, .60, ARMOR_BODY};
+
+-static int jacket_armor_index;
+-static int combat_armor_index;
+-static int body_armor_index;
++int jacket_armor_index;
++int combat_armor_index;
++int body_armor_index;
+ static int power_screen_index;
+ static int power_shield_index;
+