aboutsummaryrefslogtreecommitdiff
path: root/games/quake2forge/files
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-08-11 19:09:02 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-08-11 19:09:02 +0000
commit62bdd749b054dcff40fcd17442066b1afe060207 (patch)
tree6130adb64e1fcc5ac189d0b104e3e3e7f0d1b720 /games/quake2forge/files
parented6a67b6a92b741db852acc3e930555ae0f8de8b (diff)
downloadports-62bdd749b054dcff40fcd17442066b1afe060207.tar.gz
ports-62bdd749b054dcff40fcd17442066b1afe060207.zip
Update to 0.3
PR: ports/70029 Submitted by: Ulrich Spoerlein (maintainer)
Notes
Notes: svn path=/head/; revision=115954
Diffstat (limited to 'games/quake2forge/files')
-rw-r--r--games/quake2forge/files/patch-configure10
-rw-r--r--games/quake2forge/files/patch-configure.in18
-rw-r--r--games/quake2forge/files/patch-main.c42
3 files changed, 18 insertions, 52 deletions
diff --git a/games/quake2forge/files/patch-configure b/games/quake2forge/files/patch-configure
deleted file mode 100644
index 17234f191498..000000000000
--- a/games/quake2forge/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Mon Mar 10 16:54:16 2003
-+++ configure Mon Mar 10 16:54:17 2003
-@@ -7829,6 +7829,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/games/quake2forge/files/patch-configure.in b/games/quake2forge/files/patch-configure.in
new file mode 100644
index 000000000000..054b34a97af5
--- /dev/null
+++ b/games/quake2forge/files/patch-configure.in
@@ -0,0 +1,18 @@
+--- configure.in.orig Tue Mar 16 11:07:38 2004
++++ configure.in Thu Aug 5 09:59:56 2004
+@@ -109,6 +109,7 @@
+ # test for the library first, for people who may have the libs
+ # installed but no headers
+ AC_CHECK_LIB(vga, vga_getmousetype,
++ SVGALIB_LIBS="$SVGALIB_LIBS -lvga"
+ HAVE_SVGALIB=maybe,
+ HAVE_SVGALIB=no,
+ [ $SVGALIB_LIBS ]
+@@ -125,7 +126,6 @@
+ # if it's all there, define the relevant bits
+ if test "x$HAVE_SVGALIB" = xyes ; then
+ AC_DEFINE(HAVE_SVGALIB, 1, [Define this if you have SVGAlib])
+- SVGALIB_LIBS="-lvga"
+ AC_SUBST(SVGALIB_CFLAGS)
+ AC_SUBST(SVGALIB_LIBS)
+ else
diff --git a/games/quake2forge/files/patch-main.c b/games/quake2forge/files/patch-main.c
deleted file mode 100644
index ca04bcd5b26b..000000000000
--- a/games/quake2forge/files/patch-main.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- src/main.c.orig Fri Feb 7 14:25:46 2003
-+++ src/main.c Fri Feb 7 14:34:14 2003
-@@ -49,12 +49,21 @@
- #include <mntent.h>
- #elif defined(__FreeBSD__) || defined(__bsd__) || defined (__NetBSD__)
- #include <fstab.h>
-+ #include <pthread.h>
- #elif defined(__sun__)
- #include <sys/file.h>
- #endif
-
- #ifdef HAVE_DLOPEN
- # include <dlfcn.h>
-+#endif
-+
-+/* This should probably go into configure
-+ * BSDs and Linux have SIGIO, Solaris needs SIGPOLL
-+ * This should probably be changed the other way round
-+ * SIGIO as default and SIGPOLL only for Solrais */
-+#ifndef SIGPOLL
-+#define SIGPOLL SIGIO
- #endif
-
- #include "qcommon.h"
-@@ -518,7 +527,7 @@
- ret = fread(ptr, size, nitems, fp);
- err = errno;
- if (ret != nitems) {
-- printf("verify_fread(...,%d,%d,...): return value: %d\n", size, nitems, ret);
-+ printf("verify_fread(...,%lu,%lu,...): return value: %lu\n", (unsigned long)size, (unsigned long)nitems, (unsigned long)ret);
- if (ret == 0 && ferror(fp)) {
- printf(" error: %s\n", strerror(err));
- printf(" fileno=%d\n", fileno(fp));
-@@ -536,7 +545,7 @@
- ret = fwrite(ptr, size, nitems, fp);
- err = errno;
- if (ret != nitems) {
-- printf("verify_fwrite(...,%d,%d,...) = %d\n", size, nitems, ret);
-+ printf("verify_fwrite(...,%lu,%lu,...) = %lu\n", (unsigned long)size, (unsigned long)nitems, (unsigned long)ret);
- if (ret == 0 && ferror(fp)) {
- printf(" error: %s\n", strerror(err));
- printf(" fileno=%d\n", fileno(fp));