aboutsummaryrefslogtreecommitdiff
path: root/games/quake2lnx/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-03-21 16:52:50 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-03-21 16:52:50 +0000
commit44f0f1027ad844f773185bf099376f14e378f240 (patch)
tree75a706de9977788eb9fc77423536ec5905be9f5f /games/quake2lnx/Makefile
parente721391e7f391ba6880c663034e47d32a0454a03 (diff)
downloadports-44f0f1027ad844f773185bf099376f14e378f240.tar.gz
ports-44f0f1027ad844f773185bf099376f14e378f240.zip
- Remove trivial patches, use REINPLACE_CMD instead
- Mute extraction of mission packs sources
Notes
Notes: svn path=/head/; revision=157900
Diffstat (limited to 'games/quake2lnx/Makefile')
-rw-r--r--games/quake2lnx/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/games/quake2lnx/Makefile b/games/quake2lnx/Makefile
index 42da4da8446f..7c0879943906 100644
--- a/games/quake2lnx/Makefile
+++ b/games/quake2lnx/Makefile
@@ -166,8 +166,6 @@ PLIST_SUB+= CTF="@comment "
.if defined(WITH_ROGUE)
DISTFILES+= roguesrc320.shar.Z:id
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_rogue_g__local.h \
- ${FILESDIR}/extra-patch-src_rogue_q__shared.c
MAKE_ARGS+= BUILD_ROGUE=YES
Q2MP+= rogue
ROGUE_OFF= 454
@@ -178,7 +176,6 @@ PLIST_SUB+= ROGUE="@comment "
.if defined(WITH_XATRIX)
DISTFILES+= xatrixsrc320.shar.Z:id
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_xatrix_q__shared.c
MAKE_ARGS+= BUILD_XATRIX=YES
Q2MP+= xatrix
XATRIX_OFF= 441
@@ -230,13 +227,17 @@ MAKE_ARGS+= NO_X86_ASM=YES
## END OF CONFIGURATION KNOBS ##
# ###
-post-extract:
+post-extract: .SILENT
.for mp in ${Q2MP}
- @${MKDIR} ${WRKSRC}/src/${mp}
- @(cd ${WRKSRC}/src/${mp} && ${GUNZIP_CMD} -c \
+ ${MKDIR} ${WRKSRC}/src/${mp}
+ cd ${WRKSRC}/src/${mp} && ${GUNZIP_CMD} -c \
${DISTDIR}/${DIST_SUBDIR}/${mp}src320.shar.Z > \
${mp}src320.shar && \
- ${TAIL} +${${mp:U}_OFF} ${mp}src320.shar | ${SH})
+ ${TAIL} +${${mp:U}_OFF} ${mp}src320.shar | ${SH} > /dev/null
+. if defined(WITH_XATRIX) || defined(WITH_ROGUE)
+ ${REINPLACE_CMD} -e 's/__ $$/&|| defined __FreeBSD__/' \
+ ${WRKSRC}/src/${mp}/q_shared.c
+. endif
.endfor
post-patch: .SILENT
@@ -245,6 +246,10 @@ post-patch: .SILENT
${WRKSRC}/src/linux/vid_so.c
${REINPLACE_CMD} -e 's|dllname, RTLD_LAZY|& \| RTLD_GLOBAL|' \
${WRKSRC}/src/linux/qgl_linux.c
+.if defined(WITH_ROGUE)
+ ${REINPLACE_CMD} -e '/^#include <nan.h>/d' ${WRKSRC}/src/rogue/g_local.h
+.endif
+ ${REINPLACE_CMD} -e 's|/dev/js|/dev/joy|' ${WRKSRC}/src/linux/joystick.c
do-install:
.for tgt in ${EXE_TARGETS}