aboutsummaryrefslogtreecommitdiff
path: root/games/quake2lnx/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-06-28 08:02:23 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-06-28 08:02:23 +0000
commit671887596b0acdfa0ad0f12159fcffbcaf89dfef (patch)
tree81d252a58cee3628b82a8045a80a79a0bb722970 /games/quake2lnx/Makefile
parent024652caf52777895cd89ecfdc6176c4e8ebd22b (diff)
downloadports-671887596b0acdfa0ad0f12159fcffbcaf89dfef.tar.gz
ports-671887596b0acdfa0ad0f12159fcffbcaf89dfef.zip
Allow client to be run from any directory.
Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=83767
Diffstat (limited to 'games/quake2lnx/Makefile')
-rw-r--r--games/quake2lnx/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/games/quake2lnx/Makefile b/games/quake2lnx/Makefile
index 0d2bf56138a8..ed42bc466dcc 100644
--- a/games/quake2lnx/Makefile
+++ b/games/quake2lnx/Makefile
@@ -25,6 +25,7 @@ MAINTAINER= danfe@regency.nsu.ru
COMMENT= Cleaned up copy of the original Quake II source code
USE_GMAKE= yes
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -240,6 +241,9 @@ pre-everything::
TGTDIR= ${WRKSRC}/release${ARCH}
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%%%BASEDIR%%%%|${DATADIR}|' ${WRKSRC}/src/qcommon/files.c
+
do-build:
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} build_release)
@@ -274,6 +278,6 @@ do-install:
.endif
post-install:
- @${SED} -e 's#$${PREFIX}#${PREFIX}#g' ${PKGMESSAGE}
+ @${SED} -e 's|$${DATADIR}|${DATADIR}|g' ${PKGMESSAGE}
.include <bsd.port.post.mk>