aboutsummaryrefslogtreecommitdiff
path: root/games/quake3-data
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-12 13:00:07 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-12 13:00:07 +0000
commitc23e6e8c43941e777fe53b23b875682f24161929 (patch)
tree681f2350239e886f37ff6efb61d6978d24b1a3db /games/quake3-data
parent959840222913e8b9349f659cb6fc3307260e8796 (diff)
downloadports-c23e6e8c43941e777fe53b23b875682f24161929.tar.gz
ports-c23e6e8c43941e777fe53b23b875682f24161929.zip
Cleanup quake3-data a bit more:
- Remove USE_CRLF knob: instead, when extracting ZIP archives, ask it to convert text files to Unix style. This should be no-op change, as all consumers of USE_CRLF also USE_ZIP - While here, remove unneeded output redirection in `do-extract' target
Notes
Notes: svn path=/head/; revision=317955
Diffstat (limited to 'games/quake3-data')
-rw-r--r--games/quake3-data/Makefile4
-rw-r--r--games/quake3-data/Makefile.include11
2 files changed, 4 insertions, 11 deletions
diff --git a/games/quake3-data/Makefile b/games/quake3-data/Makefile
index 549e639dbda3..fe12e27118d4 100644
--- a/games/quake3-data/Makefile
+++ b/games/quake3-data/Makefile
@@ -37,8 +37,8 @@ PLIST_SUB+= TEAMARENA="@comment "
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
- @cd ${WRKDIR} && ${TAIL} +356 ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
- ${TAR} zxf - >/dev/null
+ @cd ${WRKDIR} && ${TAIL} +356 \
+ ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | ${TAR} xzf -
do-install:
@${MKDIR} ${DATADIR}
diff --git a/games/quake3-data/Makefile.include b/games/quake3-data/Makefile.include
index e976c4b57723..a7f196158479 100644
--- a/games/quake3-data/Makefile.include
+++ b/games/quake3-data/Makefile.include
@@ -16,14 +16,7 @@ SUB_LIST+= Q3DIR="${Q3DIR}"
RUN_DEPENDS+= ${Q3DIR}/baseq3/pak1.pk3:${PORTSDIR}/games/quake3-data
.endif
-.if defined(USE_CRLF)
-. if defined(USE_ZIP)
+# When extracting ZIP archives, ask it to convert text files to Unix style
+.if defined(USE_ZIP)
EXTRACT_BEFORE_ARGS= -aqo
-. else
-pre-patch:
- @${FIND} ${WRKDIR} -type f -print0 | \
- ${XARGS} -0 ${FILE} | ${GREP} 'CRLF' | \
- ${SED} -e "s/:.*//" | ${SED} -e 's/ /\\ /g' | \
- ${XARGS} ${REINPLACE_CMD} -i "" -e "s/`${PRINTF} '\r'`$$//"
-. endif
.endif