aboutsummaryrefslogtreecommitdiff
path: root/games/quakeforge
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
commit672c044e2eee3598f19a0f5e618e0c2fe8aea68d (patch)
tree771bbdda8fc0a17d5351cfa925732955ccc44706 /games/quakeforge
parent86240c80e62c10278c8b2c49d61a2198db15e6ed (diff)
downloadports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.tar.gz
ports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.zip
Properly use SDL everywhere:
USE_SDL=yes -> USE_SDL=sdl (good examles everywhere) WANT_SDL/HAVE_SDL instead of exists(localbase/lib/lib...) See http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-sdl.html for more information on how to use USE_SDL, WANT_SDL and HAVE_SDL. PR: follow-ups of ports/55494, ports/61877 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Notes
Notes: svn path=/head/; revision=103247
Diffstat (limited to 'games/quakeforge')
-rw-r--r--games/quakeforge/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 3d5f44b6fbfc..dfe1356f48bf 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -36,6 +36,7 @@ USE_GMAKE= yes
USE_XLIB= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+WANT_SDL= yes
.include <bsd.port.pre.mk>
@@ -56,7 +57,7 @@ CFLAGS+= -ffast-math
.endif
.endif
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
.endif
@@ -127,7 +128,7 @@ PLIST_SUB+= XMMS:="@comment "
.endif
.if !defined(WITHOUT_SDL) && defined(WITH_SDL)
-USE_SDL= yes
+USE_SDL= sdl
CONFIGURE_ARGS+=--with-sdl=${LOCALBASE}
PLIST_SUB+= SDL:=""
.else