aboutsummaryrefslogtreecommitdiff
path: root/games/sampsvr
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-12-02 06:58:14 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-12-02 06:58:14 +0000
commit94a9d83355ef5730d51a44f22c4a1cdcfcf58356 (patch)
tree35244aad043b72b67b1e26a2029b6b8c769ce177 /games/sampsvr
parent97c620da8b5a78dca57e5c199c58ab5063b66000 (diff)
downloadports-94a9d83355ef5730d51a44f22c4a1cdcfcf58356.tar.gz
ports-94a9d83355ef5730d51a44f22c4a1cdcfcf58356.zip
- Update to 0.2.3, but in fact this is 0.2.X.
- Move files base to ${PREFIX}/libexec. PR: ports/129334 Submitted by: Alexander Logvinov <ports@logvinov.com> (maintainer)
Notes
Notes: svn path=/head/; revision=223702
Diffstat (limited to 'games/sampsvr')
-rw-r--r--games/sampsvr/Makefile36
-rw-r--r--games/sampsvr/distinfo6
-rw-r--r--games/sampsvr/files/sampd.in2
-rw-r--r--games/sampsvr/pkg-plist22
4 files changed, 39 insertions, 27 deletions
diff --git a/games/sampsvr/Makefile b/games/sampsvr/Makefile
index 7bebfe63ff83..ab81849cbbe8 100644
--- a/games/sampsvr/Makefile
+++ b/games/sampsvr/Makefile
@@ -5,30 +5,24 @@
# $FreeBSD$
PORTNAME= sampsvr
-DISTVERSION= 0.2.2
+PORTVERSION= 0.2.3
CATEGORIES= games linux
-MASTER_SITES= http://www.sa-mp.com/files/ \
- http://eu.littlewhitey.com/ \
- http://dedi.azer.nl/upload/ \
- http://www.kfcgang.com/files/ \
- http://files.gtanet.com/samp/ \
- http://thegtaplanet.net/download/ \
- http://sa-mp.popznet.com/files/
-DISTNAME= samp022svr
+MASTER_SITES= http://files.sa-mp.com/
+DISTNAME= samp02Xsvr
MAINTAINER= ports@logvinov.com
COMMENT= Rockstar's GTA: San Andreas multiplayer modification dedicated server
USE_LINUX= yes
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/samp022
-USE_DOS2UNIX= server.cfg *.pwn
+WRKSRC= ${WRKDIR}/${DISTNAME:S,svr,,}
+USE_DOS2UNIX= *.txt *.pwn
USE_RC_SUBR= sampd
-SAMPDIR= ${PREFIX}/lib/${PORTNAME}
+SAMPDIR= ${PREFIX}/libexec/${PORTNAME}
PORTDOCS= README
-PLIST_SUB= SAMPDIR="${SAMPDIR:S,^${PREFIX}/,,}"
+PLIST_SUB= SAMPDIR="${SAMPDIR:S,^${PREFIX}/,,}" SAMPBIN=${DISTNAME}
SUB_FILES= pkg-message
-SUB_LIST= SAMPDIR="${SAMPDIR}"
+SUB_LIST= SAMPDIR="${SAMPDIR}" SAMPBIN=${DISTNAME}
.if !defined(NOPORTDOCS)
SUB_LIST+= NOTEWORK="Read ${DOCSDIR}/README to configure SA-MP Server"
.else
@@ -39,20 +33,20 @@ SUB_LIST+= NOTEWORK=""
do-install:
${MKDIR} ${SAMPDIR}
-.for i in samp022svr announce
+.for i in ${DISTNAME} announce
${BRANDELF} -t Linux ${WRKSRC}/${i}
${INSTALL_PROGRAM} ${WRKSRC}/${i} ${SAMPDIR}
.endfor
${MKDIR} ${DATADIR}
cd ${WRKSRC} && \
${FIND} . -type d ! -empty -exec \
- ${MKDIR} "${DATADIR}/{}" \; && \
- ${FIND} filterscripts -type f -exec \
- ${INSTALL_DATA} "{}" "${DATADIR}/{}" \; && \
- ${FIND} gamemodes -type f -exec \
+ ${MKDIR} "${DATADIR}/{}" \;
+.for i in filterscripts gamemodes scriptfiles
+ cd ${WRKSRC} && \
+ ${FIND} ${i} -type f -exec \
${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
- ${LN} -sf ${DATADIR}/filterscripts/ ${SAMPDIR}/filterscripts
- ${LN} -sf ${DATADIR}/gamemodes/ ${SAMPDIR}/gamemodes
+ ${LN} -sf ${DATADIR}/${i}/ ${SAMPDIR}/${i}
+.endfor
.if !exists(${PREFIX}/etc/${PORTNAME}.cfg)
${INSTALL_DATA} ${WRKSRC}/server.cfg ${PREFIX}/etc/${PORTNAME}.cfg
.endif
diff --git a/games/sampsvr/distinfo b/games/sampsvr/distinfo
index 7d80bb191207..9b14ea86dd59 100644
--- a/games/sampsvr/distinfo
+++ b/games/sampsvr/distinfo
@@ -1,3 +1,3 @@
-MD5 (samp022svr.tar.gz) = dea3b86a7303a6527912685635b46e60
-SHA256 (samp022svr.tar.gz) = 3864ec979421834e252df8ff98c03c31978c6e18805c13378cbcf2acfa761065
-SIZE (samp022svr.tar.gz) = 569540
+MD5 (samp02Xsvr.tar.gz) = b466193afd886aac9ec48f19c55d8947
+SHA256 (samp02Xsvr.tar.gz) = 185c51e58976546496a9fe818d9da29a9d4064514957085e6a80df75ffae7289
+SIZE (samp02Xsvr.tar.gz) = 632308
diff --git a/games/sampsvr/files/sampd.in b/games/sampsvr/files/sampd.in
index 5346eb2c77a5..75f6fc5fe54c 100644
--- a/games/sampsvr/files/sampd.in
+++ b/games/sampsvr/files/sampd.in
@@ -20,7 +20,7 @@ load_rc_config $name
: ${sampd_enable="NO"}
: ${sampd_chdir="%%SAMPDIR%%"}
-command="%%SAMPDIR%%/samp022svr"
+command="%%SAMPDIR%%/%%SAMPBIN%%"
command_args="> /dev/null &"
required_files="%%PREFIX%%/etc/sampsvr.cfg"
start_precmd="sampd_prestart"
diff --git a/games/sampsvr/pkg-plist b/games/sampsvr/pkg-plist
index 97b70f63adea..9710d80247ff 100644
--- a/games/sampsvr/pkg-plist
+++ b/games/sampsvr/pkg-plist
@@ -1,12 +1,12 @@
@unexec if cmp -s %D/etc/sampsvr.cfg %D/etc/sampsvr.cfg.dist; then rm -f %D/etc/sampsvr.cfg; fi
etc/sampsvr.cfg.dist
@exec [ -f %B/sampsvr.cfg ] || cp %B/%f %B/sampsvr.cfg
-%%SAMPDIR%%/samp022svr
+%%SAMPDIR%%/%%SAMPBIN%%
%%SAMPDIR%%/announce
%%SAMPDIR%%/server.cfg
%%SAMPDIR%%/filterscripts
%%SAMPDIR%%/gamemodes
-%%DATADIR%%/filterscripts/DEBUG_05.amx
+%%SAMPDIR%%/scriptfiles
%%DATADIR%%/filterscripts/actions.amx
%%DATADIR%%/filterscripts/actions.pwn
%%DATADIR%%/filterscripts/adminspec.amx
@@ -43,7 +43,25 @@ etc/sampsvr.cfg.dist
%%DATADIR%%/gamemodes/sniper.pwn
%%DATADIR%%/gamemodes/timertest.pwn
%%DATADIR%%/gamemodes/timertest.amx
+%%DATADIR%%/scriptfiles/vehiclelists/README.txt
+%%DATADIR%%/scriptfiles/vehiclelists/bone.txt
+%%DATADIR%%/scriptfiles/vehiclelists/flint.txt
+%%DATADIR%%/scriptfiles/vehiclelists/ls_airport.txt
+%%DATADIR%%/scriptfiles/vehiclelists/ls_gen_inner.txt
+%%DATADIR%%/scriptfiles/vehiclelists/ls_gen_outer.txt
+%%DATADIR%%/scriptfiles/vehiclelists/ls_law.txt
+%%DATADIR%%/scriptfiles/vehiclelists/lv_airport.txt
+%%DATADIR%%/scriptfiles/vehiclelists/lv_gen.txt
+%%DATADIR%%/scriptfiles/vehiclelists/lv_law.txt
+%%DATADIR%%/scriptfiles/vehiclelists/red_county.txt
+%%DATADIR%%/scriptfiles/vehiclelists/sf_airport.txt
+%%DATADIR%%/scriptfiles/vehiclelists/sf_gen.txt
+%%DATADIR%%/scriptfiles/vehiclelists/sf_law.txt
+%%DATADIR%%/scriptfiles/vehiclelists/tierra.txt
+%%DATADIR%%/scriptfiles/vehiclelists/whetstone.txt
@dirrmtry %%DATADIR%%/gamemodes
@dirrmtry %%DATADIR%%/filterscripts
+@dirrmtry %%DATADIR%%/scriptfiles/vehiclelists
+@dirrmtry %%DATADIR%%/scriptfiles
@dirrmtry %%DATADIR%%
@dirrmtry %%SAMPDIR%%