aboutsummaryrefslogtreecommitdiff
path: root/games/scorched3d
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-14 10:48:08 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-14 10:48:08 +0000
commit1821746de27af20aedfa4aec4dd41e15278da191 (patch)
tree2bca08427e960cb404997f9ebf60300884463d86 /games/scorched3d
parent591d615232f9d7e82f613bcfbb62e360b893587b (diff)
downloadports-1821746de27af20aedfa4aec4dd41e15278da191.tar.gz
ports-1821746de27af20aedfa4aec4dd41e15278da191.zip
o Fix a problem that happens when wxWindows 2.4 and 2.6 are both installed. [1]
o Remove unecessary patches and use REINPLACE_CMD instead. [2] PR: ports/87367 [1] Submitted by: Sven Berkvens-Matthijsse <sven@ilse.net> [1], garga [2] Approved by: maintainer [1] [2]
Notes
Notes: svn path=/head/; revision=145358
Diffstat (limited to 'games/scorched3d')
-rw-r--r--games/scorched3d/Makefile34
-rw-r--r--games/scorched3d/files/patch-configure.ac32
-rw-r--r--games/scorched3d/files/patch-src-3dsparse-aseFile.tab.cpp15
-rw-r--r--games/scorched3d/files/patch-src-GLEXT-GLBitmap.cpp11
-rw-r--r--games/scorched3d/files/patch-src-GLEXT-GLState.h11
-rw-r--r--games/scorched3d/files/patch-src-GLEXT-GLStateExtension.cpp11
-rw-r--r--games/scorched3d/files/patch-src-client-ClientMain.cpp11
-rw-r--r--games/scorched3d/files/patch-src-client-SoftwareMouse.cpp11
-rw-r--r--games/scorched3d/files/patch-src-client-UniqueIdStore.cpp11
-rw-r--r--games/scorched3d/files/patch-src-common-Clock.cpp11
-rw-r--r--games/scorched3d/files/patch-src-common-Display.h11
-rw-r--r--games/scorched3d/files/patch-src-common-Gamma.cpp11
-rw-r--r--games/scorched3d/files/patch-src-common-Gamma.h11
-rw-r--r--games/scorched3d/files/patch-src-common-KeyStateTranslate.h11
-rw-r--r--games/scorched3d/files/patch-src-common-KeyTranslate.h11
-rw-r--r--games/scorched3d/files/patch-src-common-KeyboardHistory.h11
-rw-r--r--games/scorched3d/files/patch-src-common-Logger.cpp11
-rw-r--r--games/scorched3d/files/patch-src-common-Mouse.h11
-rw-r--r--games/scorched3d/files/patch-src-common-RandomGenerator.cpp11
-rw-r--r--games/scorched3d/files/patch-src-coms-NetBuffer.cpp11
-rw-r--r--games/scorched3d/files/patch-src-coms-NetBuffer.h13
-rw-r--r--games/scorched3d/files/patch-src-coms-NetMessageHandler.h11
-rw-r--r--games/scorched3d/files/patch-src-coms-NetMessagePool.h11
-rw-r--r--games/scorched3d/files/patch-src-engine-MainLoop.cpp11
-rw-r--r--games/scorched3d/files/patch-src-ode-config.h11
-rw-r--r--games/scorched3d/files/patch-src-scorched-MainDialog.cpp13
-rw-r--r--games/scorched3d/files/patch-src-scorched-main.cpp11
-rw-r--r--games/scorched3d/files/patch-src-server-ServerBrowserInfo.h11
-rw-r--r--games/scorched3d/files/patch-src-server-ServerMain.cpp11
29 files changed, 54 insertions, 317 deletions
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index 0f7b9bc0c8cd..8ed2bd950400 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -33,6 +33,7 @@ USE_GL= yes
USE_GMAKE= yes
USE_AUTOMAKE_VER= 15
USE_AUTOCONF_VER= 253
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/scorched
AUTOMAKE_ARGS= --foreign
@@ -49,6 +50,39 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" \
.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -E 's,#include.*<SDL/(SDL.*\.h)>,#include <SDL11/\1>,g' \
+ ${WRKSRC}/configure.ac \
+ ${WRKSRC}/src/GLEXT/GLBitmap.cpp \
+ ${WRKSRC}/src/GLEXT/GLState.h \
+ ${WRKSRC}/src/GLEXT/GLStateExtension.cpp \
+ ${WRKSRC}/src/client/ClientMain.cpp \
+ ${WRKSRC}/src/client/SoftwareMouse.cpp \
+ ${WRKSRC}/src/client/UniqueIdStore.cpp \
+ ${WRKSRC}/src/common/Clock.cpp \
+ ${WRKSRC}/src/common/Display.h \
+ ${WRKSRC}/src/common/Gamma.cpp \
+ ${WRKSRC}/src/common/Gamma.h \
+ ${WRKSRC}/src/common/KeyStateTranslate.h \
+ ${WRKSRC}/src/common/KeyTranslate.h \
+ ${WRKSRC}/src/common/KeyboardHistory.h \
+ ${WRKSRC}/src/common/Logger.cpp \
+ ${WRKSRC}/src/common/Mouse.h \
+ ${WRKSRC}/src/common/RandomGenerator.cpp \
+ ${WRKSRC}/src/coms/NetBuffer.cpp \
+ ${WRKSRC}/src/coms/NetBuffer.h \
+ ${WRKSRC}/src/coms/NetMessageHandler.h \
+ ${WRKSRC}/src/coms/NetMessagePool.h \
+ ${WRKSRC}/src/engine/MainLoop.cpp \
+ ${WRKSRC}/src/scorched/MainDialog.cpp \
+ ${WRKSRC}/src/scorched/main.cpp \
+ ${WRKSRC}/src/server/ServerBrowserInfo.h \
+ ${WRKSRC}/src/server/ServerMain.cpp
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,g' \
+ ${WRKSRC}/src/3dsparse/aseFile.tab.cpp \
+ ${WRKSRC}/src/ode/config.h
+
+
pre-configure:
@cd ${WRKSRC}/scripts && ${PERL} createAMMakefile.pl
@cd ${WRKSRC} && ${ACLOCAL}
diff --git a/games/scorched3d/files/patch-configure.ac b/games/scorched3d/files/patch-configure.ac
index 5c94484018ea..fbc27d6bca59 100644
--- a/games/scorched3d/files/patch-configure.ac
+++ b/games/scorched3d/files/patch-configure.ac
@@ -1,13 +1,21 @@
---- ./configure.ac.orig Sat Aug 6 13:57:14 2005
-+++ ./configure.ac Tue Aug 9 23:20:58 2005
-@@ -37,8 +37,8 @@
- have_SDLnet=yes
- if test "x$enable_sdltest" = "xyes" ; then
- AC_TRY_COMPILE([
-- #include <SDL/SDL.h>
-- #include <SDL/SDL_net.h>
-+ #include <SDL11/SDL.h>
-+ #include <SDL11/SDL_net.h>
+--- configure.ac.orig Fri Oct 14 10:18:06 2005
++++ configure.ac Fri Oct 14 10:19:33 2005
+@@ -248,13 +248,13 @@
+ ])
+ fi
+
+-CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS"
+-CXXFLAGS="$CXXFLAGS $WX_CXXFLAGS_ONLY"
+-CFLAGS="$CFLAGS $WX_CFLAGS_ONLY"
++CPPFLAGS="$WX_CPPFLAGS $CPPFLAGS"
++CXXFLAGS="$WX_CXXFLAGS_ONLY $CXXFLAGS"
++CFLAGS="$WX_CFLAGS_ONLY $CFLAGS"
+ if test x"$use_static_wx" = x"yes"; then
+- LIBS="$LIBS $WX_LIBS_STATIC"
++ LIBS="$WX_LIBS_STATIC $LIBS"
+ else
+- LIBS="$LIBS $WX_LIBS"
++ LIBS="$WX_LIBS $LIBS"
+ fi
- int main(int argc, char *argv[])
- { return 0; }
+ dnl Check for FreeType2
diff --git a/games/scorched3d/files/patch-src-3dsparse-aseFile.tab.cpp b/games/scorched3d/files/patch-src-3dsparse-aseFile.tab.cpp
deleted file mode 100644
index 2107b3a2b0f9..000000000000
--- a/games/scorched3d/files/patch-src-3dsparse-aseFile.tab.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./src/3dsparse/aseFile.tab.cpp.orig Sat Aug 6 13:57:38 2005
-+++ ./src/3dsparse/aseFile.tab.cpp Tue Aug 9 23:21:13 2005
-@@ -329,10 +329,10 @@
- #include <alloca.h>
- #else /* not sparc */
- #if defined (MSDOS) && !defined (__TURBOC__)
--#include <malloc.h>
-+#include <stdlib.h>
- #else /* not MSDOS, or __TURBOC__ */
- #if defined(_AIX)
--#include <malloc.h>
-+#include <stdlib.h>
- #pragma alloca
- #else /* not MSDOS, __TURBOC__, or _AIX */
- #ifdef __hpux
diff --git a/games/scorched3d/files/patch-src-GLEXT-GLBitmap.cpp b/games/scorched3d/files/patch-src-GLEXT-GLBitmap.cpp
deleted file mode 100644
index 4a82afc04f4f..000000000000
--- a/games/scorched3d/files/patch-src-GLEXT-GLBitmap.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/GLEXT/GLBitmap.cpp.orig Sat Aug 6 13:57:38 2005
-+++ ./src/GLEXT/GLBitmap.cpp Tue Aug 9 23:21:13 2005
-@@ -22,7 +22,7 @@
- #include <math.h>
- #include <GLEXT/GLState.h>
- #include <GLEXT/GLBitmap.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- GLBitmap::GLBitmap() :
- width_(0), height_(0), alpha_(false), newbits_(0)
diff --git a/games/scorched3d/files/patch-src-GLEXT-GLState.h b/games/scorched3d/files/patch-src-GLEXT-GLState.h
deleted file mode 100644
index 1281b8e6efba..000000000000
--- a/games/scorched3d/files/patch-src-GLEXT-GLState.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/GLEXT/GLState.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/GLEXT/GLState.h Tue Aug 9 23:21:14 2005
-@@ -27,7 +27,7 @@
- #define AFX_GLSTATE_H__32B0E2D0_566D_4438_94E4_B12FE82430B1__INCLUDED_
-
- #define WIN32_LEAN_AND_MEAN // Exclude rarely-used stuff from Windows headers
--#include <SDL/SDL_opengl.h>
-+#include <SDL11/SDL_opengl.h>
- #include <common/Defines.h>
-
- class GLState
diff --git a/games/scorched3d/files/patch-src-GLEXT-GLStateExtension.cpp b/games/scorched3d/files/patch-src-GLEXT-GLStateExtension.cpp
deleted file mode 100644
index ec1afad997dd..000000000000
--- a/games/scorched3d/files/patch-src-GLEXT-GLStateExtension.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/GLEXT/GLStateExtension.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/GLEXT/GLStateExtension.cpp Tue Aug 9 23:21:14 2005
-@@ -21,7 +21,7 @@
- #include <GLEXT/GLStateExtension.h>
- #include <GLEXT/GLConsole.h>
- #include <common/OptionsDisplay.h> // Hmm library code pollution
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
- #include <string.h>
- #include <string>
-
diff --git a/games/scorched3d/files/patch-src-client-ClientMain.cpp b/games/scorched3d/files/patch-src-client-ClientMain.cpp
deleted file mode 100644
index 0297cf49023b..000000000000
--- a/games/scorched3d/files/patch-src-client-ClientMain.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/client/ClientMain.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/client/ClientMain.cpp Tue Aug 9 23:21:17 2005
-@@ -70,7 +70,7 @@
- #include <common/Gamma.h>
- #include <common/Clock.h>
- #include <sound/Sound.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- static int mouseEventCount = 0;
- static bool paused = false;
diff --git a/games/scorched3d/files/patch-src-client-SoftwareMouse.cpp b/games/scorched3d/files/patch-src-client-SoftwareMouse.cpp
deleted file mode 100644
index c5a621a032dd..000000000000
--- a/games/scorched3d/files/patch-src-client-SoftwareMouse.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/client/SoftwareMouse.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/client/SoftwareMouse.cpp Tue Aug 9 23:21:17 2005
-@@ -25,7 +25,7 @@
- #include <GLEXT/GLState.h>
- #include <common/Defines.h>
- #include <common/OptionsDisplay.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- SoftwareMouse *SoftwareMouse::instance_ = 0;
-
diff --git a/games/scorched3d/files/patch-src-client-UniqueIdStore.cpp b/games/scorched3d/files/patch-src-client-UniqueIdStore.cpp
deleted file mode 100644
index 9cd53cf4360b..000000000000
--- a/games/scorched3d/files/patch-src-client-UniqueIdStore.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/client/UniqueIdStore.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/client/UniqueIdStore.cpp Tue Aug 9 23:21:17 2005
-@@ -24,7 +24,7 @@
- #include <common/OptionsDisplay.h>
- #include <coms/NetInterface.h>
- #include <XML/XMLFile.h>
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL_net.h>
- #include <stdlib.h>
-
- UniqueIdStore::UniqueIdStore()
diff --git a/games/scorched3d/files/patch-src-common-Clock.cpp b/games/scorched3d/files/patch-src-common-Clock.cpp
deleted file mode 100644
index 6d58c7fdbb1c..000000000000
--- a/games/scorched3d/files/patch-src-common-Clock.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Clock.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Clock.cpp Tue Aug 9 23:21:17 2005
-@@ -20,7 +20,7 @@
-
- #include <common/Defines.h>
- #include <common/Clock.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- Clock::Clock()
- {
diff --git a/games/scorched3d/files/patch-src-common-Display.h b/games/scorched3d/files/patch-src-common-Display.h
deleted file mode 100644
index 1bae05a7376b..000000000000
--- a/games/scorched3d/files/patch-src-common-Display.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Display.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Display.h Tue Aug 9 23:21:18 2005
-@@ -22,7 +22,7 @@
- #define _DISPLAY_H_
-
- #include <stdlib.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- class Display
- {
diff --git a/games/scorched3d/files/patch-src-common-Gamma.cpp b/games/scorched3d/files/patch-src-common-Gamma.cpp
deleted file mode 100644
index 250eb82f3d7d..000000000000
--- a/games/scorched3d/files/patch-src-common-Gamma.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Gamma.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Gamma.cpp Tue Aug 9 23:21:18 2005
-@@ -27,7 +27,7 @@
- #include <common/Gamma.h>
- #include <common/Defines.h>
- #include <math.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- //////////////////////////////////////////////////////////////////////
- // Construction/Destruction
diff --git a/games/scorched3d/files/patch-src-common-Gamma.h b/games/scorched3d/files/patch-src-common-Gamma.h
deleted file mode 100644
index c509cd42c580..000000000000
--- a/games/scorched3d/files/patch-src-common-Gamma.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Gamma.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Gamma.h Tue Aug 9 23:21:18 2005
-@@ -26,7 +26,7 @@
- //
- //////////////////////////////////////////////////////////////////////
-
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- struct GammaSettings
- {
diff --git a/games/scorched3d/files/patch-src-common-KeyStateTranslate.h b/games/scorched3d/files/patch-src-common-KeyStateTranslate.h
deleted file mode 100644
index 3e75b634cea6..000000000000
--- a/games/scorched3d/files/patch-src-common-KeyStateTranslate.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/KeyStateTranslate.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/KeyStateTranslate.h Tue Aug 9 23:21:18 2005
-@@ -19,7 +19,7 @@
- ////////////////////////////////////////////////////////////////////////////////
-
-
--#include <SDL/SDL_keysym.h>
-+#include <SDL11/SDL_keysym.h>
-
- struct KeyStateTranslation
- {
diff --git a/games/scorched3d/files/patch-src-common-KeyTranslate.h b/games/scorched3d/files/patch-src-common-KeyTranslate.h
deleted file mode 100644
index cac529212df2..000000000000
--- a/games/scorched3d/files/patch-src-common-KeyTranslate.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/KeyTranslate.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/KeyTranslate.h Tue Aug 9 23:21:18 2005
-@@ -19,7 +19,7 @@
- ////////////////////////////////////////////////////////////////////////////////
-
- #include <wx/defs.h>
--#include <SDL/SDL_keysym.h>
-+#include <SDL11/SDL_keysym.h>
-
- struct KeyTranslation
- {
diff --git a/games/scorched3d/files/patch-src-common-KeyboardHistory.h b/games/scorched3d/files/patch-src-common-KeyboardHistory.h
deleted file mode 100644
index 138f464f82e7..000000000000
--- a/games/scorched3d/files/patch-src-common-KeyboardHistory.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/KeyboardHistory.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/KeyboardHistory.h Tue Aug 9 23:21:18 2005
-@@ -26,7 +26,7 @@
- #if !defined(AFX_HISTORY_H__EFFEAE97_E779_4737_8DB4_B76AD9431BBC__INCLUDED_)
- #define AFX_HISTORY_H__EFFEAE97_E779_4737_8DB4_B76AD9431BBC__INCLUDED_
-
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- namespace KeyboardHistory
- {
diff --git a/games/scorched3d/files/patch-src-common-Logger.cpp b/games/scorched3d/files/patch-src-common-Logger.cpp
deleted file mode 100644
index 8f4cfba038d3..000000000000
--- a/games/scorched3d/files/patch-src-common-Logger.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Logger.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Logger.cpp Tue Aug 9 23:21:18 2005
-@@ -21,7 +21,7 @@
- #include <common/Defines.h>
- #include <common/Logger.h>
- #include <common/LoggerI.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
- #include <time.h>
- #include <stdio.h>
- #include <stdarg.h>
diff --git a/games/scorched3d/files/patch-src-common-Mouse.h b/games/scorched3d/files/patch-src-common-Mouse.h
deleted file mode 100644
index 7dbc782149ec..000000000000
--- a/games/scorched3d/files/patch-src-common-Mouse.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/Mouse.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/Mouse.h Tue Aug 9 23:21:18 2005
-@@ -23,7 +23,7 @@
- #define _MOUSE_H_
-
-
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- // Mouse.h: interface for the Mouse class.
- //
diff --git a/games/scorched3d/files/patch-src-common-RandomGenerator.cpp b/games/scorched3d/files/patch-src-common-RandomGenerator.cpp
deleted file mode 100644
index f98925bc2efb..000000000000
--- a/games/scorched3d/files/patch-src-common-RandomGenerator.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/common/RandomGenerator.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/common/RandomGenerator.cpp Tue Aug 9 23:21:18 2005
-@@ -20,7 +20,7 @@
-
- #include <common/RandomGenerator.h>
- #include <common/Defines.h>
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL_net.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <limits.h>
diff --git a/games/scorched3d/files/patch-src-coms-NetBuffer.cpp b/games/scorched3d/files/patch-src-coms-NetBuffer.cpp
deleted file mode 100644
index d699c97a3f04..000000000000
--- a/games/scorched3d/files/patch-src-coms-NetBuffer.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/coms/NetBuffer.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/coms/NetBuffer.cpp Tue Aug 9 23:21:19 2005
-@@ -20,7 +20,7 @@
-
-
- #include <coms/NetBuffer.h>
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL_net.h>
- #include <string.h>
-
- NetBuffer NetBufferDefault::defaultBuffer;
diff --git a/games/scorched3d/files/patch-src-coms-NetBuffer.h b/games/scorched3d/files/patch-src-coms-NetBuffer.h
deleted file mode 100644
index edc591087b05..000000000000
--- a/games/scorched3d/files/patch-src-coms-NetBuffer.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/coms/NetBuffer.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/coms/NetBuffer.h Tue Aug 9 23:21:19 2005
-@@ -23,8 +23,8 @@
-
- #include <string>
- #include <common/Vector.h>
--#include <SDL/SDL.h>
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL.h>
-+#include <SDL11/SDL_net.h>
-
- class NetBuffer
- {
diff --git a/games/scorched3d/files/patch-src-coms-NetMessageHandler.h b/games/scorched3d/files/patch-src-coms-NetMessageHandler.h
deleted file mode 100644
index 2c0f9b1d8afa..000000000000
--- a/games/scorched3d/files/patch-src-coms-NetMessageHandler.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/coms/NetMessageHandler.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/coms/NetMessageHandler.h Tue Aug 9 23:21:19 2005
-@@ -23,7 +23,7 @@
- #define __INCLUDE_NetMessageHandlerh_INCLUDE__
-
- #include <coms/NetMessage.h>
--#include <SDL/SDL_thread.h>
-+#include <SDL11/SDL_thread.h>
- #include <list>
-
- class NetMessageHandlerI
diff --git a/games/scorched3d/files/patch-src-coms-NetMessagePool.h b/games/scorched3d/files/patch-src-coms-NetMessagePool.h
deleted file mode 100644
index a369992e6255..000000000000
--- a/games/scorched3d/files/patch-src-coms-NetMessagePool.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/coms/NetMessagePool.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/coms/NetMessagePool.h Tue Aug 9 23:21:19 2005
-@@ -24,7 +24,7 @@
-
- #include <coms/NetMessage.h>
- #include <list>
--#include <SDL/SDL_thread.h>
-+#include <SDL11/SDL_thread.h>
-
- class NetMessagePool
- {
diff --git a/games/scorched3d/files/patch-src-engine-MainLoop.cpp b/games/scorched3d/files/patch-src-engine-MainLoop.cpp
deleted file mode 100644
index da37336cfa88..000000000000
--- a/games/scorched3d/files/patch-src-engine-MainLoop.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/engine/MainLoop.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/engine/MainLoop.cpp Tue Aug 9 23:21:20 2005
-@@ -23,7 +23,7 @@
- #include <common/Defines.h>
- #include <GLEXT/GLState.h>
- #include <GLEXT/GLInfo.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- MainLoop::MainLoop() : exitLoop_(false), lastDrawTime_(0.0f), flip_(false)
- {
diff --git a/games/scorched3d/files/patch-src-ode-config.h b/games/scorched3d/files/patch-src-ode-config.h
deleted file mode 100644
index 160a9f545c26..000000000000
--- a/games/scorched3d/files/patch-src-ode-config.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/ode/config.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/ode/config.h Tue Aug 9 23:21:22 2005
-@@ -36,7 +36,7 @@
- #if defined(__DARWIN__)
- #include <sys/malloc.h>
- #else
--#include <malloc.h> // for alloca under windows
-+#include <stdlib.h> // for alloca under windows
- #endif
-
- #include <string.h>
diff --git a/games/scorched3d/files/patch-src-scorched-MainDialog.cpp b/games/scorched3d/files/patch-src-scorched-MainDialog.cpp
deleted file mode 100644
index 78a19891240c..000000000000
--- a/games/scorched3d/files/patch-src-scorched-MainDialog.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/scorched/MainDialog.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/scorched/MainDialog.cpp Tue Aug 9 23:21:23 2005
-@@ -26,8 +26,8 @@
- #include <wx/msgdlg.h>
- #define WIN32_LEAN_AND_MEAN
- #include <windows.h>
--#include <SDL/SDL.h>
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL.h>
-+#include <SDL11/SDL_net.h>
- #include <scorched/MainDialog.h>
- #include <scorched/HtmlHelpDialog.h>
- #include <scorched/NetDialog.h>
diff --git a/games/scorched3d/files/patch-src-scorched-main.cpp b/games/scorched3d/files/patch-src-scorched-main.cpp
deleted file mode 100644
index 1424c58fe239..000000000000
--- a/games/scorched3d/files/patch-src-scorched-main.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/scorched/main.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/scorched/main.cpp Tue Aug 9 23:21:29 2005
-@@ -20,7 +20,7 @@
-
- #include <wx/wx.h>
- #include <wx/utils.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
- #include <client/ClientMain.h>
- #include <client/ClientSave.h>
- #include <client/ScorchedClient.h>
diff --git a/games/scorched3d/files/patch-src-server-ServerBrowserInfo.h b/games/scorched3d/files/patch-src-server-ServerBrowserInfo.h
deleted file mode 100644
index 1bc731328902..000000000000
--- a/games/scorched3d/files/patch-src-server-ServerBrowserInfo.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/server/ServerBrowserInfo.h.orig Sat Aug 6 13:57:39 2005
-+++ ./src/server/ServerBrowserInfo.h Tue Aug 9 23:21:30 2005
-@@ -21,7 +21,7 @@
- #if !defined(__INCLUDE_ServerBrowserInfoh_INCLUDE__)
- #define __INCLUDE_ServerBrowserInfoh_INCLUDE__
-
--#include <SDL/SDL_net.h>
-+#include <SDL11/SDL_net.h>
- #include <list>
- #include <string>
-
diff --git a/games/scorched3d/files/patch-src-server-ServerMain.cpp b/games/scorched3d/files/patch-src-server-ServerMain.cpp
deleted file mode 100644
index 613a412ad892..000000000000
--- a/games/scorched3d/files/patch-src-server-ServerMain.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/server/ServerMain.cpp.orig Sat Aug 6 13:57:39 2005
-+++ ./src/server/ServerMain.cpp Tue Aug 9 23:21:30 2005
-@@ -66,7 +66,7 @@
- #include <server/ServerBanned.h>
- #include <server/ScorchedServer.h>
- #include <server/ScorchedServerUtil.h>
--#include <SDL/SDL.h>
-+#include <SDL11/SDL.h>
-
- Clock serverTimer;
-