aboutsummaryrefslogtreecommitdiff
path: root/games/scourge
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-12-01 14:15:53 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-12-01 14:15:53 +0000
commitb5f8d285ca6c58aee8499064af67195fdad8f164 (patch)
treecff12c4d2853a5d71259f911d30bb1fc42479342 /games/scourge
parenta86bf44a54b5e7e99e1797f509fa61798319f105 (diff)
downloadports-b5f8d285ca6c58aee8499064af67195fdad8f164.tar.gz
ports-b5f8d285ca6c58aee8499064af67195fdad8f164.zip
- Use provided WX_CONFIG instead of local WXCONFIG.
- Use WANT_UNICODE instead of WX_UNICODE since it can be compiled with the non-Unicode version. - Use ARCH instead of MACHINE_ARCH to possibly allow cross-compiling. PR: ports/105495 Submitted by: alepulver (myself) Approved by: maintainer (timeout)
Notes
Notes: svn path=/head/; revision=178468
Diffstat (limited to 'games/scourge')
-rw-r--r--games/scourge/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index dfc4c96b4235..a3d1f7f88c8c 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -26,7 +26,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_LIBS}
LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-data-dir=${DATADIR}
@@ -34,7 +34,6 @@ CONFIGURE_ARGS= --with-data-dir=${DATADIR}
SUB_FILES= pkg-message
PLIST_FILES= bin/${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}
-WXCONFIG= wxgtk2${_WX_UC}-${_WX_VER}-config
OPTIONS= DEBUG "Produce an executable with debugging symbols" off \
EDITOR "Install scourge editor" on
@@ -52,7 +51,7 @@ CONFIGURE_ARGS+= --enable-debug
.if !defined(WITHOUT_EDITOR)
USE_WX= 2.6+
WX_COMPS= wx contrib
-WX_UNICODE= yes
+WANT_UNICODE= yes
PLIST_FILES+= bin/${PORTNAME}-editor
HAVE_EDITOR= true
.else
@@ -60,7 +59,7 @@ CONFIGURE_ARGS+= --disable-editor
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|wx-config|${WXCONFIG} |g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG:T} |g' ${WRKSRC}/configure
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin/