aboutsummaryrefslogtreecommitdiff
path: root/games/sdlquake2
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-07-28 23:14:50 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-07-28 23:14:50 +0000
commitb5b7f451119f41bcede13a38553b027b6dd2eda6 (patch)
tree5157742c5e5cc38d82f47e4d986fa75f179cf145 /games/sdlquake2
parent763dbcbad389c4208ea5190c5784421ec7ade6b4 (diff)
downloadports-b5b7f451119f41bcede13a38553b027b6dd2eda6.tar.gz
ports-b5b7f451119f41bcede13a38553b027b6dd2eda6.zip
- Bump PORTREVISION.
- Don't build game.so by default (provided by "games/quake2-data"). - Follow rules in "games/quake2-data/Makefile.include": fix handling of search paths.
Notes
Notes: svn path=/head/; revision=169015
Diffstat (limited to 'games/sdlquake2')
-rw-r--r--games/sdlquake2/Makefile3
-rw-r--r--games/sdlquake2/files/patch-files.c29
2 files changed, 13 insertions, 19 deletions
diff --git a/games/sdlquake2/Makefile b/games/sdlquake2/Makefile
index 78e8947d862f..6966fc9b1fc1 100644
--- a/games/sdlquake2/Makefile
+++ b/games/sdlquake2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdlquake2
PORTVERSION= 0.1.4
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://koti.mbnet.fi/~turol/sdlquake2/
@@ -21,7 +22,7 @@ USE_GMAKE= yes
OPTIONS= CLIENT "Build client" on \
DEDICATED "Build dedicated server" on \
- GAME "Build main game modification" on
+ GAME "Build a main game .so file" off
LIBDIR= ${PREFIX}/lib/${PORTNAME}
MAKE_ENV= LIBDIR="${LIBDIR}"
diff --git a/games/sdlquake2/files/patch-files.c b/games/sdlquake2/files/patch-files.c
index 0e9626afaa2e..2962d7defe86 100644
--- a/games/sdlquake2/files/patch-files.c
+++ b/games/sdlquake2/files/patch-files.c
@@ -1,5 +1,5 @@
---- ./files.c.orig Thu May 19 17:56:13 2005
-+++ ./files.c Sun Feb 26 11:23:56 2006
+--- files.c.orig Thu May 19 17:56:13 2005
++++ files.c Thu Jul 27 17:26:46 2006
@@ -233,7 +233,7 @@
#ifdef MAGIC_BTREE
rb = rbinit (_compare, 1);
@@ -9,15 +9,16 @@
rb = rbinit ((int (*)(const void *, const void *))strcmp, 0);
#else
rb = rbinit ((int (*)(const void *, const void *))Q_stricmp, 0);
-@@ -1158,6 +1158,7 @@
+@@ -1157,6 +1157,8 @@
+ {
Com_sprintf (fs_gamedir, sizeof(fs_gamedir), "%s/%s", fs_basedir->string, dir);
Cvar_FullSet ("gamedir", dir, CVAR_SERVERINFO|CVAR_NOSET);
- FS_AddGameDirectory (va("%s/%s", fs_basedir->string, dir) );
++ FS_AddGameDirectory (va("%s/%s", DATADIR, dir));
+ FS_AddGameDirectory (va("%s/%s", LIBDIR, dir));
+ FS_AddGameDirectory (va("%s/%s", fs_basedir->string, dir) );
}
}
-
-@@ -1383,6 +1384,9 @@
+@@ -1383,6 +1385,9 @@
*/
void FS_InitFilesystem (void)
{
@@ -27,24 +28,16 @@
current_filename = "unknown";
Cmd_AddCommand ("path", FS_Path_f);
-@@ -1405,7 +1409,7 @@
- // basedir <path>
- // allows the game to run from outside the data tree
+@@ -1412,6 +1417,8 @@
//
-- fs_basedir = Cvar_Get ("basedir", ".", CVAR_NOSET);
-+ fs_basedir = Cvar_Get ("basedir", DATADIR, CVAR_NOSET);
- fs_cache = Cvar_Get ("fs_cache", "7", 0);
- fs_noextern = Cvar_Get ("fs_noextern", "0", 0);
-
-@@ -1413,6 +1417,7 @@
// start up with baseq2 by default
//
- FS_AddGameDirectory (va("%s/"BASEDIRNAME, fs_basedir->string) );
++ FS_AddGameDirectory (va("%s/"BASEDIRNAME, DATADIR));
+ FS_AddGameDirectory (va("%s/"BASEDIRNAME, LIBDIR));
+ FS_AddGameDirectory (va("%s/"BASEDIRNAME, fs_basedir->string) );
// any set gamedirs will be freed up to here
- fs_base_searchpaths = fs_searchpaths;
-@@ -1421,4 +1426,13 @@
+@@ -1421,4 +1428,13 @@
fs_gamedirvar = Cvar_Get ("game", "", CVAR_LATCH|CVAR_SERVERINFO);
if (fs_gamedirvar->string[0])
FS_SetGamedir (fs_gamedirvar->string);