aboutsummaryrefslogtreecommitdiff
path: root/games/springlobby/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-01 14:46:28 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-01 14:46:28 +0000
commit01004500da9e52e7ec399ae7a0a0d2fa50fca465 (patch)
tree0a45b432fd624a69ab214ae1bbd939739647c1d6 /games/springlobby/Makefile
parent7d2745f83381383e70bdaac59ece67f81eaf2385 (diff)
downloadports-01004500da9e52e7ec399ae7a0a0d2fa50fca465.tar.gz
ports-01004500da9e52e7ec399ae7a0a0d2fa50fca465.zip
- Update to 0.61
Notes
Notes: svn path=/head/; revision=249030
Diffstat (limited to 'games/springlobby/Makefile')
-rw-r--r--games/springlobby/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/games/springlobby/Makefile b/games/springlobby/Makefile
index e6f6ebe4b9af..ff582c2ee8ad 100644
--- a/games/springlobby/Makefile
+++ b/games/springlobby/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= springlobby
-PORTVERSION= 0.29
-PORTREVISION= 1
+PORTVERSION= 0.61
CATEGORIES= games net
MASTER_SITES= http://www.springlobby.info/tarballs/ \
http://mirror.amdmi3.ru/distfiles/
@@ -16,16 +15,14 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Cross-platform lobby client for the Spring RTS project
RUN_DEPENDS= spring:${PORTSDIR}/games/spring
+LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
USE_BZIP2= yes
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USE_CMAKE= yes
+CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
USE_WX= 2.8+
MAKE_JOBS_SAFE= yes
-CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
-
PORTDOCS= *
OPTIONS= TORRENT "Support automatic content downloads via torrent" on \
@@ -37,26 +34,26 @@ OPTIONS= TORRENT "Support automatic content downloads via torrent" on \
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
-CONFIGURE_ARGS+=--disable-nls
+CMAKE_ARGS+= -DOPTION_TRANSLATION_SUPPORT:BOOL=OFF
PLIST_SUB+= NLS="@comment "
.endif
.if !defined(WITHOUT_TORRENT)
-LIB_DEPENDS+= torrent.1:${PORTSDIR}/net-p2p/rblibtorrent
+LIB_DEPENDS+= torrent-rasterbar.5:${PORTSDIR}/net-p2p/rblibtorrent-devel
.else
-CONFIGURE_ARGS+=--disable-torrent-system
+CMAKE_ARGS+= -DOPTION_TORRENT_SYSTEM:BOOL=OFF
.endif
.if !defined(WITHOUT_SOUND)
-USE_SDL+= sdl mixer
+USE_OPENAL= al
.else
-CONFIGURE_ARGS+=--disable-sound
+CMAKE_ARGS+= -DOPTION_SOUND:BOOL=OFF
.endif
-.if defined(NOPORTDOCS)
post-patch:
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-dist_docDATA||' \
- ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/install.*FILES.*share\/doc/ d' \
+ ${WRKSRC}/CMakeLists.txt
.endif
.include <bsd.port.mk>