aboutsummaryrefslogtreecommitdiff
path: root/games/starfighter
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-04-24 21:15:05 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-04-24 21:15:05 +0000
commit61caf9cf81206436a20d87c5aadab4781fd2551b (patch)
tree65e7ab30d491887e04f03e2c2d0cf8d6b15b687d /games/starfighter
parent6f1904ab75e6615deb12714ae4427c16454381d5 (diff)
downloadports-61caf9cf81206436a20d87c5aadab4781fd2551b.tar.gz
ports-61caf9cf81206436a20d87c5aadab4781fd2551b.zip
- Remove USE_REINPLACE.
- Remove LICENSE file before installing instead of after. - Fix OPTIONS handling. - Format tabs. - Bump PORTREVISION. Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=160394
Diffstat (limited to 'games/starfighter')
-rw-r--r--games/starfighter/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/games/starfighter/Makefile b/games/starfighter/Makefile
index 577ab0ac9e5c..2bcc7a1d1714 100644
--- a/games/starfighter/Makefile
+++ b/games/starfighter/Makefile
@@ -7,6 +7,7 @@
PORTNAME= starfighter
DISTVERSION= 1.1-1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.parallelrealities.co.uk/download.php?type=zip&file=
@@ -17,7 +18,6 @@ FETCH_BEFORE_ARGS+= -o ${DISTNAME}${EXTRACT_SUFX}
USE_GMAKE= yes
USE_SDL= image mixer sdl
-USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-1.1
@@ -29,24 +29,24 @@ MAKE_ENV= CXX="${CXX}"
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}
+ @${RM} ${WRKSRC}/docs/LICENSE
${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
- ${RM} ${DOCSDIR}/LICENSE
.endif
.include <bsd.port.pre.mk>
post-patch:
-# Fix Makefile
+# Fix Makefile.
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}| ; \
- s|\(-Wall\)|${CFLAGS} \1|' \
- ${WRKSRC}/${MAKEFILE}
+ s|\(-Wall\)|${CFLAGS} \1|' \
+ ${WRKSRC}/${MAKEFILE}
-# Fix SDL include statement
+# Fix SDL include statement.
@${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|' \
- ${WRKSRC}/code/*.cpp ${WRKSRC}/code/*.h
+ ${WRKSRC}/code/*.cpp ${WRKSRC}/code/*.h
-# Enable/disable compilation optimizations
-.if !defined(WITH_OPTIMIZED_CFLAGS)
+# Enable/disable compilation optimizations.
+.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/${MAKEFILE}
.endif