aboutsummaryrefslogtreecommitdiff
path: root/games/starlanes/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-11 01:34:05 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-11 01:34:05 +0000
commitf4d62f7d04e5dc1bec659290f75fe7771682bec6 (patch)
tree956fcdce5785d8ab1d26e376e7a14b85ef6fed12 /games/starlanes/Makefile
parentb5950c0e1216eacafaab4dcd9ab8b24c66eb71ef (diff)
downloadports-f4d62f7d04e5dc1bec659290f75fe7771682bec6.tar.gz
ports-f4d62f7d04e5dc1bec659290f75fe7771682bec6.zip
- Add stage support
Notes
Notes: svn path=/head/; revision=333468
Diffstat (limited to 'games/starlanes/Makefile')
-rw-r--r--games/starlanes/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/games/starlanes/Makefile b/games/starlanes/Makefile
index ead560557eac..86cfc9b47743 100644
--- a/games/starlanes/Makefile
+++ b/games/starlanes/Makefile
@@ -9,10 +9,8 @@ MASTER_SITES= SUNSITE/games/strategy
MAINTAINER= ports@FreeBSD.org
COMMENT= Classic space-age stock trading game
-MAN6= starlanes.6
-PLIST_FILES= bin/starlanes
+PLIST_FILES= bin/starlanes man/man6/starlanes.6.gz
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
's| restrict| m_restrict| ; \
@@ -23,7 +21,7 @@ do-build:
&& ${CC} ${CFLAGS} -o starlanes starlanes.c -lcurses)
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} starlanes ${PREFIX}/bin)
- (cd ${WRKSRC} && ${INSTALL_MAN} starlanes.6 ${MAN6PREFIX}/man/man6)
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} starlanes ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} starlanes.6 ${STAGEDIR}${MAN6PREFIX}/man/man6)
.include <bsd.port.mk>