aboutsummaryrefslogtreecommitdiff
path: root/games/starlanes
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2000-04-02 01:00:24 +0000
committerMichael Haro <mharo@FreeBSD.org>2000-04-02 01:00:24 +0000
commit4aed6f1e6536c2d3be11d0ac7596e10b27791cb5 (patch)
tree021f61372fc74d69c6dbb086d15d03b8a2cae67e /games/starlanes
parent77140e508e938432f22e37e787489915e2d78661 (diff)
downloadports-4aed6f1e6536c2d3be11d0ac7596e10b27791cb5.tar.gz
ports-4aed6f1e6536c2d3be11d0ac7596e10b27791cb5.zip
***
games/affenspiel - Support CC properly *** games/battalion - Support PREFIX properly *** games/block - Support CC/CFLAGS properly *** games/blue - Support CC/CFLAGS properly - Add WWW: line into pkg/DESCR New file: patches/patch-aa *** games/bs - Add WWW: line into pkg/DESCR *** games/columns - Support CXXFLAGS properly - Support sdl-config *** games/empire - Exclude GPL doc from package - Add WWW: line into pkg/DESCR *** games/freesweep to 0.87 - Update to version 0.87 *** games/galaxis - Support CC properly - Add WWW: line into pkg/DESCR *** games/garith - Support CC/CFLAGS properly - Support GTK_CONFIG *** games/gemdropx to 0.7 - Update to version 0.7 *** games/gtkballs - Exclude GPL doc from package - Support GTK_CONFIG *** games/icbm3d - Update WWW: line of pkg/DESCR *** games/mirrormagic - Support CC/X11BASE properly *** games/phalanx to 22 - Update to version 22 - Add WWW: line into pkg/DESCR *** games/spellcast - Update MASTER_SITES and WWW: line of pkg/DESCR - Support CFLAGS properly - Exclude GPL doc from package *** games/starlanes - Support CC properly - Exclude GPL doc from package *** games/xdigger to 1.0.10 - Update to version 1.0.10 New file: patches/patch-ad patches/patch-ae *** games/xtron - Support PREFIX properly - Exclude GPL doc from package *** games/xtruco - Support CC/CFLAGS/X11BASE properly *** games/xvier - Support X11BASE properly *** PR: 17741 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=27261
Diffstat (limited to 'games/starlanes')
-rw-r--r--games/starlanes/Makefile23
-rw-r--r--games/starlanes/files/patch-ab30
-rw-r--r--games/starlanes/pkg-plist3
3 files changed, 32 insertions, 24 deletions
diff --git a/games/starlanes/Makefile b/games/starlanes/Makefile
index 20c4bbee21bf..2197d2ca18e6 100644
--- a/games/starlanes/Makefile
+++ b/games/starlanes/Makefile
@@ -6,24 +6,17 @@
# $FreeBSD$
#
-DISTNAME= starlanes-1.2.2
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
+DISTNAME= starlanes-1.2.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/strategy
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-ALL_TARGET=
-MAN6= starlanes.6
+ALL_TARGET= # empty
+MAN6= starlanes.6
-pre-build:
- @ ${RM} ${WRKSRC}/starlanes
-
-do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/starlanes ${PREFIX}/bin/starlanes
- @ ${INSTALL_MAN} ${WRKSRC}/starlanes.6 ${PREFIX}/man/man6
- @ ${MKDIR} ${PREFIX}/share/doc/starlanes
- @ ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/starlanes/COPYING
- @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/starlanes/README
+post-extract:
+ @${RM} ${WRKSRC}/starlanes
.include <bsd.port.mk>
diff --git a/games/starlanes/files/patch-ab b/games/starlanes/files/patch-ab
index 57a417f3d47c..c9412b003c60 100644
--- a/games/starlanes/files/patch-ab
+++ b/games/starlanes/files/patch-ab
@@ -1,11 +1,29 @@
---- ./Makefile.org Sat Mar 29 16:36:44 1997
-+++ ./Makefile Tue Jun 10 02:44:54 1997
-@@ -3,7 +3,7 @@
+--- Makefile.orig Sun Mar 30 09:36:44 1997
++++ Makefile Thu Mar 30 01:54:39 2000
+@@ -2,21 +2,17 @@
+ # Makefile for Starlanes
#
- CC=gcc
+-CC=gcc
-CCOPTS=-Wall
-+CCOPTS=-Wall ${CFLAGS}
++CC?=gcc
++CCOPTS=${CFLAGS}
CURSESLIB=ncurses
- INSTALLDIR=/usr/local
+-INSTALLDIR=/usr/local
++INSTALLDIR=${PREFIX}
+ starlanes: starlanes.c
+ $(CC) $(CCOPTS) -o starlanes starlanes.c -l$(CURSESLIB)
+
+ install:
+- cp starlanes $(INSTALLDIR)/games
+- cp starlanes.6 $(INSTALLDIR)/man/man6
+- chown bin:bin $(INSTALLDIR)/games/starlanes
+- chown root:root $(INSTALLDIR)/man/man6/starlanes.6
+- chmod 755 $(INSTALLDIR)/games/starlanes
+- chmod 444 $(INSTALLDIR)/man/man6/starlanes.6
++ ${BSD_INSTALL_PROGRAM} starlanes $(INSTALLDIR)/bin
++ ${BSD_INSTALL_MAN} starlanes.6 $(INSTALLDIR)/man/man6
+
+ # fakeinstall just echos the install commands:
+ fakeinstall:
diff --git a/games/starlanes/pkg-plist b/games/starlanes/pkg-plist
index 892d4bc0f9e0..996c6e146517 100644
--- a/games/starlanes/pkg-plist
+++ b/games/starlanes/pkg-plist
@@ -1,4 +1 @@
bin/starlanes
-share/doc/starlanes/COPYING
-share/doc/starlanes/README
-@dirrm share/doc/starlanes