aboutsummaryrefslogtreecommitdiff
path: root/games/sudoku
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-03-16 01:33:19 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-03-16 01:33:19 +0000
commitc8e6b8408ae13848e59143ed5deb59a1c3af4adc (patch)
tree88f4c94807a7956a34b8e8b06d41077637423a3c /games/sudoku
parentd4c44f0a828d6c33343486bf781115169bc14818 (diff)
downloadports-c8e6b8408ae13848e59143ed5deb59a1c3af4adc.tar.gz
ports-c8e6b8408ae13848e59143ed5deb59a1c3af4adc.zip
Add sudoku 1.0.1, console based sudoku games.
PR: ports/93892 Submitted by: ijliao
Notes
Notes: svn path=/head/; revision=157361
Diffstat (limited to 'games/sudoku')
-rw-r--r--games/sudoku/Makefile45
-rw-r--r--games/sudoku/distinfo3
-rw-r--r--games/sudoku/pkg-descr17
3 files changed, 65 insertions, 0 deletions
diff --git a/games/sudoku/Makefile b/games/sudoku/Makefile
new file mode 100644
index 000000000000..42716bcb9710
--- /dev/null
+++ b/games/sudoku/Makefile
@@ -0,0 +1,45 @@
+# ex:ts=8
+# Ports collection makefile for: sudoku
+# Date created: Feb 27, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sudoku
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= http://www.laurasia.com.au/downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Console based sudoku games
+
+PLIST_FILES= bin/sudoku \
+ share/sudoku/template
+PLIST_DIRS= share/sudoku
+
+MAN6= sudoku.6
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ @${GREP} -lR "/usr/lib/sudoku" ${WRKSRC} | ${XARGS} \
+ ${REINPLACE_CMD} -e "s,/usr/lib/sudoku,${DATADIR},"
+
+do-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${PORTNAME} sudoku.c -lcurses
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MAN6PREFIX}/man/man6
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/template ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/sudoku.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/sudoku/distinfo b/games/sudoku/distinfo
new file mode 100644
index 000000000000..2b05e5de8ca5
--- /dev/null
+++ b/games/sudoku/distinfo
@@ -0,0 +1,3 @@
+MD5 (sudoku-1.0.1.tgz) = 80a6a4a52aec36ffef2f76c4b15fc571
+SHA256 (sudoku-1.0.1.tgz) = a067b3fb1ffd4e5bf0fa5bc705d391bafc33ca45d51f5d45db0733cad3da9d0f
+SIZE (sudoku-1.0.1.tgz) = 31576
diff --git a/games/sudoku/pkg-descr b/games/sudoku/pkg-descr
new file mode 100644
index 000000000000..2e243f10e05a
--- /dev/null
+++ b/games/sudoku/pkg-descr
@@ -0,0 +1,17 @@
+The sudoku board game is played on a 9x9 grid, divided into rows, columns,
+and 9 blocks of 3x3 squares. The objective is to fill the empty squares with
+the digits 1-9, so that each row, column, and block contains each of the
+digits 1-9 (and hence, it is not possible for any digit to appear twice in
+the same row, column or block).
+
+Features:
+ - character based (curses) interface;
+ - cross-platform (Minix, Unix, Windows) with full source code (ANSI C);
+ - generates hints upon request;
+ - classification of board difficulty (very easy, easy, medium, hard or
+ fiendish);
+ - generation of new boards;
+ - easy entry of boards published in newspapers, internet, etc...;
+ - multiple output formats (text,csv,html,postscript).
+
+WWW: http://www.laurasia.com.au/sudoku/