aboutsummaryrefslogtreecommitdiff
path: root/games/supertux
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-17 05:45:46 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-17 05:45:46 +0000
commit3d17c00e25455c971947afcffe97b26858260c22 (patch)
tree1802f03d682da58e4fecd7549a0ad1fda1444f38 /games/supertux
parent48bd24582f124aed2ba7e72113a28530737f86ba (diff)
downloadports-3d17c00e25455c971947afcffe97b26858260c22.tar.gz
ports-3d17c00e25455c971947afcffe97b26858260c22.zip
Add supertux 0.0.6,
Super Tux is a side-scrolling run-and-jump game with a level editor similar to the original game "Super Mario Bros." from the Nintendo Entertainment System. PR: ports/65650 Submitted by: michael johnson <ahze at ahze dot net>
Notes
Notes: svn path=/head/; revision=107312
Diffstat (limited to 'games/supertux')
-rw-r--r--games/supertux/Makefile45
-rw-r--r--games/supertux/distinfo2
-rw-r--r--games/supertux/pkg-descr5
-rw-r--r--games/supertux/pkg-plist226
4 files changed, 278 insertions, 0 deletions
diff --git a/games/supertux/Makefile b/games/supertux/Makefile
new file mode 100644
index 000000000000..e5c5c5c0930c
--- /dev/null
+++ b/games/supertux/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: supertux
+# Date created: 2004-04-17
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= supertux
+PORTVERSION= 0.0.6
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= super-tux
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Super Tux is a side-scroller similar to Super Mario Brothers
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+WANT_SDL= yes
+USE_SDL= image
+USE_GL= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --disable-debug
+OPTIONS= SOUND "SDL mixer (audio) support" on
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_SOUND)
+CONFIGURE_ARGS+=--disable-sound
+.else
+USE_SDL+= mixer
+PLIST_SUB+= SOUND=""
+.endif
+
+post-patch:
+.if defined(WITHOUT_SOUND)
+ @${RM} -f ${WRKSRC}/data/sounds/* ${WRKSRC}/data/music/*
+.endif
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' \
+ ${WRKSRC}/src/type.h
+
+.include <bsd.port.post.mk>
diff --git a/games/supertux/distinfo b/games/supertux/distinfo
new file mode 100644
index 000000000000..907a2d64b3b5
--- /dev/null
+++ b/games/supertux/distinfo
@@ -0,0 +1,2 @@
+MD5 (supertux-0.0.6.tar.bz2) = c5763a70bc397653f051953cd0ec1b44
+SIZE (supertux-0.0.6.tar.bz2) = 1950050
diff --git a/games/supertux/pkg-descr b/games/supertux/pkg-descr
new file mode 100644
index 000000000000..f771df00882d
--- /dev/null
+++ b/games/supertux/pkg-descr
@@ -0,0 +1,5 @@
+Super Tux is a side-scrolling run-and-jump game with a level editor
+similar to the original game "Super Mario Bros."from the Nintendo
+Entertainment System.
+
+WWW: http://super-tux.sourceforge.net/
diff --git a/games/supertux/pkg-plist b/games/supertux/pkg-plist
new file mode 100644
index 000000000000..9086637856b9
--- /dev/null
+++ b/games/supertux/pkg-plist
@@ -0,0 +1,226 @@
+bin/supertux
+%%DATADIR%%/CREDITS
+%%DATADIR%%/images/background/arctis.png
+%%DATADIR%%/images/highscore/highscore.png
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/icons/bgd.png
+%%DATADIR%%/images/icons/default-icon.png
+%%DATADIR%%/images/icons/down.png
+%%DATADIR%%/images/icons/emy.png
+%%DATADIR%%/images/icons/fgd.png
+%%DATADIR%%/images/icons/left.png
+%%DATADIR%%/images/icons/right.png
+%%DATADIR%%/images/icons/rubber.png
+%%DATADIR%%/images/icons/save.png
+%%DATADIR%%/images/icons/select-mode1.png
+%%DATADIR%%/images/icons/select-mode2.png
+%%DATADIR%%/images/icons/settings.png
+%%DATADIR%%/images/icons/test-level.png
+%%DATADIR%%/images/icons/up.png
+%%DATADIR%%/images/intro/beam.png
+%%DATADIR%%/images/intro/copter-squish.png
+%%DATADIR%%/images/intro/copter-stretch.png
+%%DATADIR%%/images/intro/copter1.png
+%%DATADIR%%/images/intro/copter2.png
+%%DATADIR%%/images/intro/gown-lookup.png
+%%DATADIR%%/images/intro/gown-sit.png
+%%DATADIR%%/images/intro/gown-upset.png
+%%DATADIR%%/images/intro/intro-old.png
+%%DATADIR%%/images/intro/intro.png
+%%DATADIR%%/images/intro/tux-mad.png
+%%DATADIR%%/images/intro/tux-sit.png
+%%DATADIR%%/images/intro/tux-upset.png
+%%DATADIR%%/images/leveleditor/select.png
+%%DATADIR%%/images/map/map.png
+%%DATADIR%%/images/shared/bag-left-0.png
+%%DATADIR%%/images/shared/bag-left-1.png
+%%DATADIR%%/images/shared/bag-right-0.png
+%%DATADIR%%/images/shared/bag-right-1.png
+%%DATADIR%%/images/shared/bigcape-left-0.png
+%%DATADIR%%/images/shared/bigcape-left-1.png
+%%DATADIR%%/images/shared/bigcape-right-0.png
+%%DATADIR%%/images/shared/bigcape-right-1.png
+%%DATADIR%%/images/shared/bigfiretux-left-0.png
+%%DATADIR%%/images/shared/bigfiretux-left-1.png
+%%DATADIR%%/images/shared/bigfiretux-left-2.png
+%%DATADIR%%/images/shared/bigfiretux-left-jump.png
+%%DATADIR%%/images/shared/bigfiretux-right-0.png
+%%DATADIR%%/images/shared/bigfiretux-right-1.png
+%%DATADIR%%/images/shared/bigfiretux-right-2.png
+%%DATADIR%%/images/shared/bigfiretux-right-jump.png
+%%DATADIR%%/images/shared/bigtux-left-0.png
+%%DATADIR%%/images/shared/bigtux-left-1.png
+%%DATADIR%%/images/shared/bigtux-left-2.png
+%%DATADIR%%/images/shared/bigtux-left-jump.png
+%%DATADIR%%/images/shared/bigtux-right-0.png
+%%DATADIR%%/images/shared/bigtux-right-1.png
+%%DATADIR%%/images/shared/bigtux-right-2.png
+%%DATADIR%%/images/shared/bigtux-right-jump.png
+%%DATADIR%%/images/shared/box-empty.png
+%%DATADIR%%/images/shared/box-full.png
+%%DATADIR%%/images/shared/bsod-falling-left.png
+%%DATADIR%%/images/shared/bsod-falling-right.png
+%%DATADIR%%/images/shared/bsod-left-0.png
+%%DATADIR%%/images/shared/bsod-left-1.png
+%%DATADIR%%/images/shared/bsod-left-2.png
+%%DATADIR%%/images/shared/bsod-left-3.png
+%%DATADIR%%/images/shared/bsod-right-0.png
+%%DATADIR%%/images/shared/bsod-right-1.png
+%%DATADIR%%/images/shared/bsod-right-2.png
+%%DATADIR%%/images/shared/bsod-right-3.png
+%%DATADIR%%/images/shared/bsod-squished-left.png
+%%DATADIR%%/images/shared/bsod-squished-right.png
+%%DATADIR%%/images/shared/bullet.png
+%%DATADIR%%/images/shared/cape-left-0.png
+%%DATADIR%%/images/shared/cape-left-1.png
+%%DATADIR%%/images/shared/cape-right-0.png
+%%DATADIR%%/images/shared/cape-right-1.png
+%%DATADIR%%/images/shared/cloud-00.png
+%%DATADIR%%/images/shared/cloud-01.png
+%%DATADIR%%/images/shared/cloud-02.png
+%%DATADIR%%/images/shared/cloud-03.png
+%%DATADIR%%/images/shared/cloud-10.png
+%%DATADIR%%/images/shared/cloud-11.png
+%%DATADIR%%/images/shared/cloud-12.png
+%%DATADIR%%/images/shared/cloud-13.png
+%%DATADIR%%/images/shared/coffee.png
+%%DATADIR%%/images/shared/distro-0.png
+%%DATADIR%%/images/shared/distro-1.png
+%%DATADIR%%/images/shared/distro-2.png
+%%DATADIR%%/images/shared/distro-3.png
+%%DATADIR%%/images/shared/duckfiretux-left.png
+%%DATADIR%%/images/shared/duckfiretux-right.png
+%%DATADIR%%/images/shared/ducktux-left.png
+%%DATADIR%%/images/shared/ducktux-right.png
+%%DATADIR%%/images/shared/firetux-left-0.png
+%%DATADIR%%/images/shared/firetux-left-1.png
+%%DATADIR%%/images/shared/firetux-left-2.png
+%%DATADIR%%/images/shared/firetux-right-0.png
+%%DATADIR%%/images/shared/firetux-right-1.png
+%%DATADIR%%/images/shared/firetux-right-2.png
+%%DATADIR%%/images/shared/flag-0.png
+%%DATADIR%%/images/shared/flag-1.png
+%%DATADIR%%/images/shared/golden-herring.png
+%%DATADIR%%/images/shared/laptop-falling-left.png
+%%DATADIR%%/images/shared/laptop-falling-right.png
+%%DATADIR%%/images/shared/laptop-flat-left.png
+%%DATADIR%%/images/shared/laptop-flat-right.png
+%%DATADIR%%/images/shared/laptop-left-0.png
+%%DATADIR%%/images/shared/laptop-left-1.png
+%%DATADIR%%/images/shared/laptop-left-2.png
+%%DATADIR%%/images/shared/laptop-right-0.png
+%%DATADIR%%/images/shared/laptop-right-1.png
+%%DATADIR%%/images/shared/laptop-right-2.png
+%%DATADIR%%/images/shared/mints.png
+%%DATADIR%%/images/shared/pole.png
+%%DATADIR%%/images/shared/poletop.png
+%%DATADIR%%/images/shared/red-glow.png
+%%DATADIR%%/images/shared/skidfiretux-left.png
+%%DATADIR%%/images/shared/skidfiretux-right.png
+%%DATADIR%%/images/shared/skidtux-left.png
+%%DATADIR%%/images/shared/skidtux-right.png
+%%DATADIR%%/images/shared/super-bkgd.png
+%%DATADIR%%/images/shared/tux-left-0.png
+%%DATADIR%%/images/shared/tux-left-1.png
+%%DATADIR%%/images/shared/tux-left-2.png
+%%DATADIR%%/images/shared/tux-life.png
+%%DATADIR%%/images/shared/tux-right-0.png
+%%DATADIR%%/images/shared/tux-right-1.png
+%%DATADIR%%/images/shared/tux-right-2.png
+%%DATADIR%%/images/shared/water.png
+%%DATADIR%%/images/shared/waves-0.png
+%%DATADIR%%/images/shared/waves-1.png
+%%DATADIR%%/images/shared/waves-2.png
+%%DATADIR%%/images/status/back.png
+%%DATADIR%%/images/status/checkbox-checked.png
+%%DATADIR%%/images/status/checkbox.png
+%%DATADIR%%/images/status/choose-level-subset.png
+%%DATADIR%%/images/status/choose-subset.png
+%%DATADIR%%/images/status/letters-black.png
+%%DATADIR%%/images/status/letters-blue.png
+%%DATADIR%%/images/status/letters-gold.png
+%%DATADIR%%/images/status/letters-red.png
+%%DATADIR%%/images/status/letters-white-big.png
+%%DATADIR%%/images/status/letters-white-small.png
+%%DATADIR%%/images/status/letters-white.png
+%%DATADIR%%/images/status/level-subset-info.png
+%%DATADIR%%/images/status/lives.png
+%%DATADIR%%/images/status/numbers.png
+%%DATADIR%%/images/status/score.png
+%%DATADIR%%/images/themes/antarctica/bkgd-00.png
+%%DATADIR%%/images/themes/antarctica/bkgd-01.png
+%%DATADIR%%/images/themes/antarctica/bkgd-02.png
+%%DATADIR%%/images/themes/antarctica/bkgd-03.png
+%%DATADIR%%/images/themes/antarctica/bkgd-10.png
+%%DATADIR%%/images/themes/antarctica/bkgd-11.png
+%%DATADIR%%/images/themes/antarctica/bkgd-12.png
+%%DATADIR%%/images/themes/antarctica/bkgd-13.png
+%%DATADIR%%/images/themes/antarctica/brick0.png
+%%DATADIR%%/images/themes/antarctica/brick1.png
+%%DATADIR%%/images/themes/antarctica/solid0.png
+%%DATADIR%%/images/themes/antarctica/solid1.png
+%%DATADIR%%/images/themes/antarctica/solid2.png
+%%DATADIR%%/images/themes/antarctica/solid3.png
+%%DATADIR%%/images/themes/darkstone/bkgd-00.png
+%%DATADIR%%/images/themes/darkstone/bkgd-01.png
+%%DATADIR%%/images/themes/darkstone/bkgd-02.png
+%%DATADIR%%/images/themes/darkstone/bkgd-03.png
+%%DATADIR%%/images/themes/darkstone/bkgd-10.png
+%%DATADIR%%/images/themes/darkstone/bkgd-11.png
+%%DATADIR%%/images/themes/darkstone/bkgd-12.png
+%%DATADIR%%/images/themes/darkstone/bkgd-13.png
+%%DATADIR%%/images/themes/darkstone/brick0.png
+%%DATADIR%%/images/themes/darkstone/brick1.png
+%%DATADIR%%/images/themes/darkstone/solid0.png
+%%DATADIR%%/images/themes/darkstone/solid1.png
+%%DATADIR%%/images/themes/darkstone/solid2.png
+%%DATADIR%%/images/themes/darkstone/solid3.png
+%%DATADIR%%/images/title/title-anim1.png
+%%DATADIR%%/images/title/title-anim2.png
+%%DATADIR%%/images/title/title.png
+%%DATADIR%%/levels/default/info
+%%DATADIR%%/levels/default/info.png
+%%DATADIR%%/levels/default/level1.dat
+%%DATADIR%%/levels/default/level2.dat
+%%DATADIR%%/levels/default/level3.dat
+%%DATADIR%%/levels/default/level4.dat
+%%SOUND%%%%DATADIR%%/music/Mortimers_chipdisko-fast.mod
+%%SOUND%%%%DATADIR%%/music/Mortimers_chipdisko.mod
+%%SOUND%%%%DATADIR%%/music/SALCON-fast.MOD
+%%SOUND%%%%DATADIR%%/music/SALCON.MOD
+%%SOUND%%%%DATADIR%%/sounds/bigjump.wav
+%%SOUND%%%%DATADIR%%/sounds/brick.wav
+%%SOUND%%%%DATADIR%%/sounds/bump-upgrade.wav
+%%SOUND%%%%DATADIR%%/sounds/coffee.wav
+%%SOUND%%%%DATADIR%%/sounds/distro.wav
+%%SOUND%%%%DATADIR%%/sounds/excellent.wav
+%%SOUND%%%%DATADIR%%/sounds/fall.wav
+%%SOUND%%%%DATADIR%%/sounds/herring.wav
+%%SOUND%%%%DATADIR%%/sounds/hurt.wav
+%%SOUND%%%%DATADIR%%/sounds/jump.wav
+%%SOUND%%%%DATADIR%%/sounds/kick.wav
+%%SOUND%%%%DATADIR%%/sounds/lifeup.wav
+%%SOUND%%%%DATADIR%%/sounds/ricochet.wav
+%%SOUND%%%%DATADIR%%/sounds/shoot.wav
+%%SOUND%%%%DATADIR%%/sounds/skid.wav
+%%SOUND%%%%DATADIR%%/sounds/squish.wav
+%%SOUND%%%%DATADIR%%/sounds/stomp.wav
+%%SOUND%%%%DATADIR%%/sounds/upgrade.wav
+%%SOUND%%@dirrm %%DATADIR%%/sounds
+%%SOUND%%@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/levels/default
+@dirrm %%DATADIR%%/levels
+@dirrm %%DATADIR%%/images/title
+@dirrm %%DATADIR%%/images/themes/darkstone
+@dirrm %%DATADIR%%/images/themes/antarctica
+@dirrm %%DATADIR%%/images/themes
+@dirrm %%DATADIR%%/images/status
+@dirrm %%DATADIR%%/images/shared
+@dirrm %%DATADIR%%/images/map
+@dirrm %%DATADIR%%/images/leveleditor
+@dirrm %%DATADIR%%/images/intro
+@dirrm %%DATADIR%%/images/icons
+@dirrm %%DATADIR%%/images/highscore
+@dirrm %%DATADIR%%/images/background
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%