aboutsummaryrefslogtreecommitdiff
path: root/games/tads
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-10-16 04:09:34 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-10-16 04:09:34 +0000
commit70ab3b08354c1ab1aa391166218522e7455308d3 (patch)
treee7d48cc84d2f134c0820e99e0b1f5979dcd930c4 /games/tads
parent00af0d471c7abcac72b3f68adc9556f475a7c19f (diff)
downloadports-70ab3b08354c1ab1aa391166218522e7455308d3.tar.gz
ports-70ab3b08354c1ab1aa391166218522e7455308d3.zip
Roll our own do-install target to make this port PREFIX-friendly.
Notes
Notes: svn path=/head/; revision=145504
Diffstat (limited to 'games/tads')
-rw-r--r--games/tads/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/games/tads/Makefile b/games/tads/Makefile
index 219bbef772ff..2f5aa72fa860 100644
--- a/games/tads/Makefile
+++ b/games/tads/Makefile
@@ -16,4 +16,13 @@ COMMENT= TADS compiler/interpreter for interactive fiction
WRKSRC= ${WRKDIR}/tads-3.0.8/tads2
+do-install:
+ ${MKDIR} ${PREFIX}/share/tads2
+.for i in tadsc tadsr tdb
+ ${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
+.endfor
+.for i in adv.t std.t gameinfo.t
+ ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/tads2
+.endfor
+
.include <bsd.port.mk>