aboutsummaryrefslogtreecommitdiff
path: root/games/tksol
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2003-10-14 08:18:58 +0000
committerThomas Gellekum <tg@FreeBSD.org>2003-10-14 08:18:58 +0000
commitb460a6fc8681f0e01483b8c4f799913acbf19029 (patch)
tree67bc2b9bd3c511b01dd25c0473fdf6db9aceb45b /games/tksol
parent77eb0c1ab850f8864bbb907db310a0e3a27111b2 (diff)
downloadports-b460a6fc8681f0e01483b8c4f799913acbf19029.tar.gz
ports-b460a6fc8681f0e01483b8c4f799913acbf19029.zip
Upgrade to 1.4.
Disown this port.
Notes
Notes: svn path=/head/; revision=91148
Diffstat (limited to 'games/tksol')
-rw-r--r--games/tksol/Makefile38
-rw-r--r--games/tksol/distinfo2
-rw-r--r--games/tksol/files/patch-a66
-rw-r--r--games/tksol/files/patch-b163
-rw-r--r--games/tksol/files/patch-c9
-rw-r--r--games/tksol/pkg-plist37
6 files changed, 65 insertions, 250 deletions
diff --git a/games/tksol/Makefile b/games/tksol/Makefile
index 22ed59a62192..891e65ceb12f 100644
--- a/games/tksol/Makefile
+++ b/games/tksol/Makefile
@@ -6,18 +6,42 @@
#
PORTNAME= tksol
-PORTVERSION= 1.0
+PORTVERSION= 1.4
CATEGORIES= games tk82
-MASTER_SITES= ftp://ftp.cs.umd.edu/pub/misc_software/tksol/
-EXTRACT_SUFX= .tar.Z
+MASTER_SITES= http://www.ibiblio.org/pub/Linux/games/solitaires/ \
+ http://www.gtlib.cc.gatech.edu/pub/linux/games/solitaires/ \
+ http://ftp.fi.muni.cz/pub/linux/metalab.unc.edu/games/solitaires/ \
+ ftp://metalab.unc.edu/pub/linux/games/solitaires/
+EXTRACT_SUFX= .tgz
-MAINTAINER= tg@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A version of the card game solitaire
-RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
-PATCH_STRIP= -p1
-WRKSRC= ${WRKDIR}/release
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
+NO_BUILD= yes
MAN6= tksol.6
+MANCOMPRESSED= yes
+
+TKSOLDIR= ${PREFIX}/share/games/tksol
+
+post-extract:
+ @${RM} -rf ${WRKSRC}/downbitmaps/.xvpics
+
+post-patch:
+ @${REINPLACE_CMD} -e "s;/usr/bin/wish;${PREFIX}/bin/wish8.4;" \
+ -e "s;/usr/local/lib/tksol;${TKSOLDIR};g" \
+ ${WRKSRC}/tksol
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tksol ${PREFIX}/bin
+ ${MKDIR} ${TKSOLDIR}
+.for dir in cardbitmaps downbitmaps pictures
+ cd ${WRKSRC}; tar -cpf - ${dir} | \
+ (cd ${TKSOLDIR}; tar -xpf -)
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/${MAN6}.gz ${PREFIX}/man/man6
.include <bsd.port.mk>
diff --git a/games/tksol/distinfo b/games/tksol/distinfo
index d2a6341d43c9..b54d7f846efc 100644
--- a/games/tksol/distinfo
+++ b/games/tksol/distinfo
@@ -1 +1 @@
-MD5 (tksol-1.0.tar.Z) = 24c27e1e1a3c651aad3097cf8ec78b70
+MD5 (tksol-1.4.tgz) = cc79298159e9fe0dd182048ca11c7795
diff --git a/games/tksol/files/patch-a b/games/tksol/files/patch-a
deleted file mode 100644
index 81c49ebb0bd7..000000000000
--- a/games/tksol/files/patch-a
+++ /dev/null
@@ -1,66 +0,0 @@
---- Makefile.orig Mon Feb 21 10:36:31 1994
-+++ Makefile Fri Jan 3 03:17:35 1997
-@@ -11,7 +11,7 @@
- CHMOD = chmod
- ECHO = echo
- MKDIR = mkdir -p
-- INSTALL = install -c -m 644
-+ INSTALL = install -c -m 644 -g bin -o bin
-
- BINSCRIPT = -e 's+@cardbitmaps@+$(CARDBITMAPS)+g' \
- -e 's+@downbitmaps@+$(DOWNBITMAPS)+g' \
-@@ -23,27 +23,27 @@
- ############################################
- # Absolute pathname of the wish executable #
- ############################################
--WISH = /usr/imports/bin/wish
-+WISH = ${PREFIX}/bin/wish8.2
-
- ####################################################
- # Directory where the script tksol will be located #
- ####################################################
--BINDIR = /homes/bao/src/test/tksol
-+BINDIR = ${PREFIX}/bin
-
- #####################################################
- # Directory where the tksol manpage will be located #
- #####################################################
--MANDIR = /homes/bao/src/man
-+MANDIR = ${PREFIX}/man/man6
-
- ####################################################################
- # Directory where the bitmaps for the faceup cards will be located #
- ####################################################################
--CARDBITMAPS = /homes/bao/src/test/tksol/cardbitmaps
-+CARDBITMAPS = ${PREFIX}/share/games/tksol/cardbitmaps
-
- ######################################################################
- # Directory where the bitmaps for the facedown cards will be located #
- ######################################################################
--DOWNBITMAPS = /homes/bao/src/test/tksol/downbitmaps
-+DOWNBITMAPS = ${PREFIX}/share/games/tksol/downbitmaps
-
- #####################################################################
- # Specify whether your wish has the TkPixmap patch installed or not #
-@@ -59,10 +59,10 @@
- $(SED) $(BINSCRIPT) tksol.in > tksol
-
- tksol.1: tksol.man Makefile
-- $(SED) $(MANSCRIPT) tksol.man > tksol.1
-+ $(SED) $(MANSCRIPT) tksol.man > tksol.6
-
- clean:
-- $(RM) tksol tksol.1
-+ $(RM) tksol tksol.6
-
- install: instbin instman instbitmap
-
-@@ -91,6 +91,6 @@
- $(INSTALL) * $(DOWNBITMAPS); \
- fi
-
--instman: tksol.1
-+instman: tksol.6
- -$(MKDIR) $(MANDIR)
-- $(INSTALL) tksol.1 $(MANDIR)/tksol.1
-+ $(INSTALL) tksol.6 $(MANDIR)/tksol.6
diff --git a/games/tksol/files/patch-b b/games/tksol/files/patch-b
deleted file mode 100644
index 294327996b9c..000000000000
--- a/games/tksol/files/patch-b
+++ /dev/null
@@ -1,163 +0,0 @@
---- release/tksol.in.orig Mon Feb 14 22:39:16 1994
-+++ release/tksol.in Wed Aug 12 14:19:13 1998
-@@ -22,7 +22,9 @@
-
- global argv tksol
-
-- set tksol(colormodel) [tk colormodel .]
-+ option add *highlightThickness 0
-+
-+ set tksol(colormodel) [winfo depth .]
-
- set tksol(version) 1.0; # don't change this!
- set tksol(debug) 0
-@@ -70,7 +72,7 @@
- set tksol(bottom_level) 150; # position of bottom level stacks
-
- set tksol(button.font) 9x15
-- if {$tksol(colormodel) == "color"} {
-+ if {$tksol(colormodel) > 1} {
- set tksol(button.foreground) White
- set tksol(button.background) DeepSkyBlue1
- set tksol(button.activeForeground) Black
-@@ -154,7 +156,7 @@
- ##########################################################
- proc SetupTable {} {
-
-- global ItemToCard Score tksol
-+ global ItemToCard Score tksol argv0 argv
-
- set canvas_width [expr (7 * $tksol(card.width)) + \
- (2 * $tksol(side_margin)) + \
-@@ -165,7 +167,7 @@
- set tksol(canvas.height) $canvas_height
-
- # create the canvas
-- if {$tksol(colormodel) == "color"} {
-+ if {$tksol(colormodel) > 1} {
- canvas .canvas -width $canvas_width -height $canvas_height \
- -background $tksol(canvas.background) -relief raise
- } else {
-@@ -192,7 +194,7 @@
- # create the dividing line
- set midpt [expr ($tksol(top_level) + $tksol(bottom_level) + \
- $tksol(card.height)) / 2]
-- if {$tksol(colormodel) == "color"} {
-+ if {$tksol(colormodel) > 1} {
- .canvas create line 0 $midpt $canvas_width $midpt -fill black
- } else {
- .canvas create line 0 $midpt $canvas_width $midpt -fill white
-@@ -223,7 +225,7 @@
-
- # create the bottom level placeholders, which are invisible
- set x $tksol(side_margin)
-- if {$tksol(colormodel) == "color"} {
-+ if {$tksol(colormodel) > 1} {
- set placeholder_color "-fill $tksol(canvas.background)"
- } else {
- set placeholder_color "-fill black -stipple gray50"
-@@ -241,6 +243,8 @@
- wm sizefrom . user
- wm iconname . "TkSol"
- wm title . "TkSolitaire $tksol(version)"
-+ wm command . [concat $argv0 $argv]
-+ wm group . .
-
- # now create a few buttons
- frame .button -background $tksol(canvas.background) -relief raise -bd 2
-@@ -632,7 +636,8 @@
- pack .b.outline -side top -fill x -padx 2 -pady 2
- label .b.outline.label -width $label_width -anchor e -text "Drag Outline:"
- foreach toggle {yes no} {
-- radiobutton .b.outline.$toggle -text $toggle -variable tksol(outline)
-+ radiobutton .b.outline.$toggle -text $toggle \
-+ -variable tksol(outline) -value $toggle
- }
- .b.outline.$tksol(outline) select
- pack .b.outline.label -side left -padx 2 -pady 2
-@@ -701,7 +706,7 @@
-
- # finally setup the bitmap canvas
- canvas .b.bitmap.canvas -background $tksol(canvas.background)
-- scrollbar .b.bitmap.scroll -background $tksol(canvas.background) \
-+ scrollbar .b.bitmap.scroll -troughcolor $tksol(canvas.background) \
- -command ".b.bitmap.canvas yview" -relief sunken
- pack .b.bitmap.scroll -side right -fill y -padx 2 -pady 2
- pack .b.bitmap.canvas -fill both -padx 2 -pady 2
-@@ -712,7 +717,7 @@
- .b.entry.bitmap.e insert 0 "$bitmap";
- }
-
-- .b.bitmap.canvas bind bitmap_Tag <Any-Double-ButtonPress-1> {
-+ .b.bitmap.canvas bind bitmap_Tag <Double-ButtonPress-1> {
- set bitmap [file tail [lindex [.b.bitmap.canvas gettags current] 1]]; \
- .b.entry.bitmap.e delete 0 end; \
- .b.entry.bitmap.e insert 0 "$bitmap"; \
-@@ -762,7 +767,7 @@
- .b.bitmap.canvas configure -height $canvas_height \
- -background $tksol(canvas.background) \
- -scrollregion [list 0 0 $canvas_width $scroll_height] \
-- -yscroll ".b.bitmap.scroll set" -relief sunken
-+ -yscrollcommand ".b.bitmap.scroll set" -relief sunken
-
- set x_offset [expr int($margin + ($spacing / 2))]
- set y_offset $x_offset
-@@ -1019,13 +1024,13 @@
- set xdistance [expr [lindex $endstk 0] - [lindex $beginstk 0]]
- # note that we divide by 12, not 13, since the last card is positioned
- # on the coordinates of the last playstack, ie. playspot6
-- set x_offset [expr $xdistance / 12]
-+ set x_offset [expr round([expr $xdistance / 12])]
- set ydistance [expr $tksol(canvas.height) - [lindex $beginstk 1] - \
- $tksol(card.height)]
- # we divide by 3 here since the bottom stack must be fully visible ...
- set y_offset [expr $ydistance / 3]
-- set x [lindex $beginstk 0]
-- set y [lindex $beginstk 1]
-+ set x [expr round([lindex $beginstk 0])]
-+ set y [expr round([lindex $beginstk 1])]
- for {set endstk_no 0} {$endstk_no < 4} {incr endstk_no} {
- # layout each suit on the canvas
- .canvas raise endstk${endstk_no}_Tag all
-@@ -1040,7 +1045,7 @@
- update idletasks
- incr x $x_offset
- }
-- set x [lindex $beginstk 0]
-+ set x [expr round([lindex $beginstk 0])]
- incr y [expr round(floor($y_offset))]
- }
-
-@@ -1950,25 +1955,25 @@
- global tksol
-
- # single click on drawleft stack flip the card over to drawright
-- .canvas bind drawleft_Tag <Any-ButtonPress-1> "MoveRightMany"
-+ .canvas bind drawleft_Tag <ButtonPress-1> {MoveRightMany; break}
-
- # single click on flip move all the cards from drawright over
-- .canvas bind flip_Tag <Any-ButtonPress-1> "MoveLeft"
-+ .canvas bind flip_Tag <ButtonPress-1> "MoveLeft"
-
- # single click on a facedown card on top of a stack flip it
-- .canvas bind down_Tag <Any-ButtonPress-1> "FlipUp"
-+ .canvas bind down_Tag <ButtonPress-1> "FlipUp"
-
- # press of button-1 on a faceup card setup the current working stack
-- .canvas bind up_Tag <Any-ButtonPress-1> "SetupWorkStack %x %y"
-+ .canvas bind up_Tag <ButtonPress-1> "SetupWorkStack %x %y"
-
- # motion drags the current working stack around
-- .canvas bind up_Tag <Any-B1-Motion> "DragWorkStack %x %y"
-+ .canvas bind up_Tag <B1-Motion> "DragWorkStack %x %y"
-
- # release of button-1 moves the working stack to a new location (maybe)
-- .canvas bind up_Tag <Any-ButtonRelease-1> "ProcessWorkStack %x %y"
-+ .canvas bind up_Tag <ButtonRelease-1> "ProcessWorkStack %x %y"
-
- # double click on an up card attempts to move it to the end stack
-- .canvas bind up_Tag <Any-Double-ButtonPress-1> "ClearWorkStack %x %y"
-+ .canvas bind up_Tag <Double-ButtonPress-1> "ClearWorkStack %x %y"
- }
-
-
diff --git a/games/tksol/files/patch-c b/games/tksol/files/patch-c
deleted file mode 100644
index 5ec4a632fca0..000000000000
--- a/games/tksol/files/patch-c
+++ /dev/null
@@ -1,9 +0,0 @@
---- tksol.man.orig Mon Feb 14 13:23:15 1994
-+++ tksol.man Fri Jan 3 03:20:10 1997
-@@ -1,5 +1,5 @@
- .\" Copyright (c) 1993 by Bao Trinh
--.TH TKSOL 1 "January 5, 1994"
-+.TH TKSOL 6 "January 5, 1994"
- .SH NAME
- tksol \- Tcl/Tk based solitaire card game
- .PP
diff --git a/games/tksol/pkg-plist b/games/tksol/pkg-plist
index 4e0d37ab70a8..87938c313e2a 100644
--- a/games/tksol/pkg-plist
+++ b/games/tksol/pkg-plist
@@ -53,10 +53,39 @@ share/games/tksol/cardbitmaps/s6
share/games/tksol/cardbitmaps/s7
share/games/tksol/cardbitmaps/s8
share/games/tksol/cardbitmaps/s9
-share/games/tksol/downbitmaps/bk_circles
-share/games/tksol/downbitmaps/bk_darts
-share/games/tksol/downbitmaps/bk_lines
-@dirrm share/games/tksol/cardbitmaps
+share/games/tksol/downbitmaps/bucky.xbm
+share/games/tksol/downbitmaps/circles.xbm
+share/games/tksol/downbitmaps/darts.xbm
+share/games/tksol/downbitmaps/default
+share/games/tksol/downbitmaps/gnu.xbm
+share/games/tksol/downbitmaps/leopard.xbm
+share/games/tksol/downbitmaps/lines.xbm
+share/games/tksol/downbitmaps/linux.xbm
+share/games/tksol/downbitmaps/rock.xbm
+share/games/tksol/downbitmaps/x.xbm
+share/games/tksol/downbitmaps/xx.xbm
+share/games/tksol/pictures/armidillo.xbm
+share/games/tksol/pictures/butterfly.xbm
+share/games/tksol/pictures/chess.xbm
+share/games/tksol/pictures/default
+share/games/tksol/pictures/extra/bosch7a.xbm
+share/games/tksol/pictures/extra/deer.xbm
+share/games/tksol/pictures/extra/dugong.xbm
+share/games/tksol/pictures/extra/fruit.xbm
+share/games/tksol/pictures/extra/mensetmanus.xbm
+share/games/tksol/pictures/extra/squirrel.xbm
+share/games/tksol/pictures/flower.xbm
+share/games/tksol/pictures/frog.xbm
+share/games/tksol/pictures/grapes.xbm
+share/games/tksol/pictures/grypheura.xbm
+share/games/tksol/pictures/halloween.xbm
+share/games/tksol/pictures/hwowl.xbm
+share/games/tksol/pictures/kittyt.xbm
+share/games/tksol/pictures/rooster.xbm
+share/games/tksol/pictures/snake.xbm
+@dirrm share/games/tksol/pictures/extra
+@dirrm share/games/tksol/pictures
@dirrm share/games/tksol/downbitmaps
+@dirrm share/games/tksol/cardbitmaps
@dirrm share/games/tksol
@dirrm share/games