aboutsummaryrefslogtreecommitdiff
path: root/games/tnl/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-22 00:05:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-22 00:05:41 +0000
commita9b12de60c94b8373766969c62475a1217db8281 (patch)
treecc2c5594a7a8b08dba4437c1e0f709d5c86305d9 /games/tnl/Makefile
parent4b83d6cc46e8da3763aed4a9b1eb7e67a6bd030a (diff)
downloadports-a9b12de60c94b8373766969c62475a1217db8281.tar.gz
ports-a9b12de60c94b8373766969c62475a1217db8281.zip
Thunder&Lightning is a futuristic action flight simulator and
realtime strategy game that takes place in a large 3D environment. Jump into the pilot seat of your Lightning aircraft and fight against Thunder tanks in a fierce battle for control of the island! Apart from flight simulators, Thunder&Lightning takes inspiration from (but is not a clone or remake of) the 80's classic Carrier Command. This means that you will find yourself in control of a futuristic carrier with aircraft and amphibious tanks at your disposal. In the long run, there will be multiple Islands to conquer, each with its own defense strategy. Although Thunder&Lightning already supports missions, it aims to be an open-ended game with a dynamically developing world with scripted events on some occasions. WWW: http://tnlgame.net/ PR: ports/121132 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Notes
Notes: svn path=/head/; revision=213484
Diffstat (limited to 'games/tnl/Makefile')
-rw-r--r--games/tnl/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/games/tnl/Makefile b/games/tnl/Makefile
new file mode 100644
index 000000000000..745cbcae0ff8
--- /dev/null
+++ b/games/tnl/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: tnl
+# Date created: 05 Feb 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tnl
+PORTVERSION= 071111
+CATEGORIES= games
+MASTER_SITES= http://tnlgame.net/downloads/tnl/${PORTVERSION}/ \
+ http://www.amdmi3.ru/distfiles/
+DISTNAME= TnL-source-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${DISTNAME:S/source/data/}${EXTRACT_SUFX}
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Futuristic action flight simulator and realtime strategy game
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libiovmall.so:${PORTSDIR}/lang/io
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
+ alut.1:${PORTSDIR}/audio/freealut \
+ sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
+ CEGUIBase.1:${PORTSDIR}/graphics/cegui \
+ png.5:${PORTSDIR}/graphics/png \
+ GLEW.1:${PORTSDIR}/graphics/glew
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GCC= 4.2+
+USE_GL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFIGURE_ARGS= --with-io-cflags="-I${LOCALBASE}/include/io" \
+ --with-io-libs="-L${LOCALBASE}/lib -liovmall"
+
+WRKDATADIR= ${WRKDIR}/TnL-data/share/tnl
+
+SUB_FILES= tnl
+
+post-patch:
+ @${REINPLACE_CMD} -i "" -e 's|getenv|getEnvironmentVariable|' \
+ ${WRKDATADIR}/scripts/Settings.io
+
+post-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKDATADIR} && ${COPYTREE_SHARE} . ${DATADIR}
+
+ ${INSTALL_SCRIPT} ${WRKDIR}/tnl ${PREFIX}/bin
+
+.include <bsd.port.mk>