aboutsummaryrefslogtreecommitdiff
path: root/games/ttraffic/Makefile
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-26 05:33:51 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-26 05:33:51 +0000
commita4fc6158f566f3061d1acce1ef519be9cd17a69a (patch)
treeeb22256c13100460a384a64ae5d3fbefbaab9ab7 /games/ttraffic/Makefile
parentf720ee1568631cec981d47b6deaf26f18bc44159 (diff)
downloadports-a4fc6158f566f3061d1acce1ef519be9cd17a69a.tar.gz
ports-a4fc6158f566f3061d1acce1ef519be9cd17a69a.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Notes
Notes: svn path=/head/; revision=323680
Diffstat (limited to 'games/ttraffic/Makefile')
-rw-r--r--games/ttraffic/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/games/ttraffic/Makefile b/games/ttraffic/Makefile
index a73656558e67..dcb9b0b93253 100644
--- a/games/ttraffic/Makefile
+++ b/games/ttraffic/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: games/ttraffic
-# Date created: 14 November 2001
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ttraffic
PORTVERSION= 0.8
@@ -20,11 +16,16 @@ RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
NO_BUILD= yes
USE_PERL5_BUILD=yes
+USES= shebangfix
+SHEBANG_FILES= ttraffic.tcl
+SHEBANG_LANG= wish
+wish_OLD_CMD= /usr/bin/wish
+wish_CMD= ${LOCALBASE}/bin/wish8.4
post-patch:
- ${PERL} -pi -e 's|/usr/local/share/ttraffic/|${DATADIR}/|g;' \
- -e 's|#!/usr/bin/wish|#!${LOCALBASE}/bin/wish8.4|g' \
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local/share/ttraffic/|${DATADIR}/|' \
${WRKSRC}/ttraffic.tcl
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/ttraffic.tcl ${PREFIX}/bin/ttraffic
${MKDIR} ${DATADIR}