aboutsummaryrefslogtreecommitdiff
path: root/games/tuxfighter/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-11-29 22:26:25 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-11-29 22:26:25 +0000
commitc3e93f2e81b4fd682c984b454659cb88cccbd31a (patch)
treed70d00dc613662ef77e014cf6a6bf09afab0d5a8 /games/tuxfighter/Makefile
parentcc60f2572de6995910fd1026860008b157d69d7b (diff)
downloadports-c3e93f2e81b4fd682c984b454659cb88cccbd31a.tar.gz
ports-c3e93f2e81b4fd682c984b454659cb88cccbd31a.zip
- Change Makefile header
- Change master sites - Change maintainer email to @FreeBSD.org - Support STAGEDIR - Add build - Change files/tuxfighter.in - Change pkg-message - Change pkg-plist, remove mtree Approved by: pawel / wg (mentors, implicit)
Notes
Notes: svn path=/head/; revision=335241
Diffstat (limited to 'games/tuxfighter/Makefile')
-rw-r--r--games/tuxfighter/Makefile41
1 files changed, 23 insertions, 18 deletions
diff --git a/games/tuxfighter/Makefile b/games/tuxfighter/Makefile
index 1d75c2d73d6a..4b72b8e03868 100644
--- a/games/tuxfighter/Makefile
+++ b/games/tuxfighter/Makefile
@@ -1,4 +1,4 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= tuxfighter
@@ -6,12 +6,12 @@ PORTVERSION= 54
PORTREVISION= 2
CATEGORIES= games python
MASTER_SITES= SF/pygamebook/TuxFighter/TuxFighter${PORTVERSION}_source/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/games/:icons
DISTFILES= TuxFighter${DISTVERSION}.tar.gz \
${PORTNAME}_icons.tar.gz:icons
DIST_SUBDIR= python
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Little Asteroids-like Shooter game
LICENSE= GPLv2
@@ -22,7 +22,6 @@ WRKSRC= ${WRKDIR}
FETCH_ARGS?= -Fpr
USE_PYTHON= yes
-NO_BUILD= yes
PORTDOCS= readme_TuxFighter54.txt
@@ -34,27 +33,33 @@ SUB_FILES= ${PORTNAME}
DESKTOP_ENTRIES="TuxFighter" "${COMMENT}" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+do-build:
+ @${PYTHON_CMD} -m compileall ${WRKSRC}
+ @${PYTHON_CMD} -O -m compileall ${WRKSRC}
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} data ${DATADIR}
+ @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
+ ${WRKDIR}/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+
+.for d in *.py *.pyc *.pyo
+ @(cd ${WRKSRC} ; ${INSTALL_SCRIPT} ${d} ${STAGEDIR}${DATADIR})
+.endfor
+
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${STAGEDIR}${DATADIR})
post-install:
.for s in ${ICON_SIZES}
- ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
- ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>