aboutsummaryrefslogtreecommitdiff
path: root/games/tuxracer-commercial
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-01-14 19:33:01 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-01-14 19:33:01 +0000
commitf3395d96cc0fc5264a9d43cb66758dbc6445e78c (patch)
tree30439b760b1105d2bda6d165c31ff9f6a1d3eb35 /games/tuxracer-commercial
parent6bb3292235eddc76a64a8818ddc467172a094ec2 (diff)
downloadports-f3395d96cc0fc5264a9d43cb66758dbc6445e78c.tar.gz
ports-f3395d96cc0fc5264a9d43cb66758dbc6445e78c.zip
Use --with-tcl-lib-name=tcl82, and add a fix when Mesa compile with thread support.
Notes
Notes: svn path=/head/; revision=37194
Diffstat (limited to 'games/tuxracer-commercial')
-rw-r--r--games/tuxracer-commercial/Makefile3
-rw-r--r--games/tuxracer-commercial/files/patch-aa10
-rw-r--r--games/tuxracer-commercial/files/patch-configure38
3 files changed, 40 insertions, 11 deletions
diff --git a/games/tuxracer-commercial/Makefile b/games/tuxracer-commercial/Makefile
index 662c933ac6a0..2bfffbf38062 100644
--- a/games/tuxracer-commercial/Makefile
+++ b/games/tuxracer-commercial/Makefile
@@ -20,9 +20,10 @@ LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/Mesa3 \
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-tcl-inc="${LOCALBASE}/include/tcl8.2" \
--with-tcl-libs="${LOCALBASE}/lib" \
+ --with-tcl-lib-name=tcl82 \
--with-glut-libs="${X11BASE}/lib" \
--with-glut-inc="${X11BASE}/include" \
--with-data-dir=${PREFIX}/share/tuxracer
diff --git a/games/tuxracer-commercial/files/patch-aa b/games/tuxracer-commercial/files/patch-aa
deleted file mode 100644
index 69c5074a86fa..000000000000
--- a/games/tuxracer-commercial/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.in.orig Fri Jun 16 16:19:43 2000
-+++ configure.in Fri Jun 16 16:19:29 2000
-@@ -26,7 +26,7 @@
- AC_ARG_ENABLE(profile,[ --enable-profile Produce a profiled executable], TUXRACER_EXTRA_CFLAGS="$TUXRACER_EXTRA_CFLAGS -pg")
-
- dnl Tcl options
--TCL_LIB_NAME=tcl
-+TCL_LIB_NAME=tcl82
-
- AC_ARG_WITH(tcl-libs, [ --with-tcl-libs=DIR Specify Tcl 8.0 library location],TCL_LIB_PATH="-L$withval")
diff --git a/games/tuxracer-commercial/files/patch-configure b/games/tuxracer-commercial/files/patch-configure
new file mode 100644
index 000000000000..1932f9caef48
--- /dev/null
+++ b/games/tuxracer-commercial/files/patch-configure
@@ -0,0 +1,38 @@
+--- configure.orig Tue Apr 18 09:05:12 2000
++++ configure Mon Jan 15 03:26:36 2001
+@@ -2776,7 +2776,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lMesaGL $LIBS"
++LIBS="-lMesaGL -lc_r $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2782 "configure"
+ #include "confdefs.h"
+@@ -2810,7 +2810,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lMesaGL $LIBS"
++ LIBS="-lMesaGL -lc_r $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+@@ -2874,7 +2874,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lMesaGLU $LIBS"
++LIBS="-lMesaGLU -lc_r $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2880 "configure"
+ #include "confdefs.h"
+@@ -2908,7 +2908,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lMesaGLU $LIBS"
++ LIBS="-lMesaGLU -lc_r $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6