aboutsummaryrefslogtreecommitdiff
path: root/games/tyrquake
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
commit8199e9dc487a0e6b99c306fa637033bf11374c41 (patch)
treefd7ac6263851705bfeae2fb7d9dce6af494453c8 /games/tyrquake
parentfe6302c7633911c7e779bee40e0b1c093ff8260a (diff)
downloadports-8199e9dc487a0e6b99c306fa637033bf11374c41.tar.gz
ports-8199e9dc487a0e6b99c306fa637033bf11374c41.zip
- adopt optionsNG for games
- trim historical headers and trim comments - some Makefile cleanup Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=319495
Diffstat (limited to 'games/tyrquake')
-rw-r--r--games/tyrquake/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/games/tyrquake/Makefile b/games/tyrquake/Makefile
index c96b9f05f1d6..3c6afab54e27 100644
--- a/games/tyrquake/Makefile
+++ b/games/tyrquake/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tyrquake
-# Date created: 13 May 2006
-# Whom: alepulver
-#
+# Created by: alepulver
# $FreeBSD$
-#
PORTNAME= tyrquake
PORTVERSION= 0.59
@@ -20,18 +16,21 @@ USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
MAKE_ENV= QBASEDIR="${Q1DIR}" X11BASE=${LOCALBASE}
-OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- X86_ASM "Enable x86 assembly code when possible" on
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
+OPTIONS_DEFINE_i386= ASM
+ASM_DESC= x86 assembly code when possible
+
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS ASM
.include "${.CURDIR}/../quake-data/Makefile.include"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ! ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
MAKE_ENV+= OPTIMIZED_CFLAGS=N
.endif
-.if defined(WITHOUT_X86_ASM) || ${ARCH} != "i386"
+.if ! ${PORT_OPTIONS:MASM}
MAKE_ENV+= USE_X86_ASM=N
.endif
@@ -42,7 +41,7 @@ do-install:
.for file in tyr-quake tyr-glquake tyr-qwcl tyr-glqwcl tyr-qwsv
${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
.endif
@@ -52,4 +51,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>